Sign in with
Sign up | Sign in
Your question

Create system image failed-device not connected

Tags:
Last response: in Windows 7
Share
January 9, 2010 4:05:06 PM

I recently built a windows 7 home premium PC with an Intel 160
GB SSD as (C) for OS/programs and second 1TB HDD as (D) for data and backups. I also have a DVD burner (H). They are all SATA drives running in AHCI mode.

Immediately after installing just windows, I used the windows
backup feature to successfully create a system image to a local disk
(D) which was and still is nearly empty.

The next day, after installing drivers, updates, and a few programs,
I went to create a second system image but this time it failed. The
process started as it should have but halfway through it failed with
the following message:

"The backup failed"
"The device is not connected (0x8007048f)"

At that point, after exiting the program , the D drive does not show
up on my computer. Upon rebooting the D drive reappears.

I searched the web and found some references to checking whether
volume shadow copying services and their dependent services were working
and that didn't help.

Another reference said to try updating to a newer bios as some
have bugs that screw up the enumerator for the drive order. The
BIOS I use is the latest and wasn’t changed since my first
successful attempt at creating the system image.

It is funny that it worked the first time around but not now.

Any advice would be appreciated.

Windows 7 Home Premium
Gigabyte GA-P55A-UD4 Bios 6 (latest)
Intel 160 GB SSD (C) OS
1 TB HDD (D)
Raedon 5770
4 GB DDR3 RAM

January 10, 2010 4:28:41 PM

I think I may have solved my problem.

I was suspicious that something was wrong with disk 1 (D) so I tried to run the windows "check disk for errors" tool from within windows. When I did, it "crashed" my drive D and it disappeared like it did during the failed backup. Rebooting restored it but then the drive was totally hosed as it "crashed" whenever I tried to read or write to it.
Suspecting that the drive itself might be faulty I wanted to test it outside of the windows environment.


I then used the western digital datalife diagnostic tool (downloaded from their website) to check disk 1 (D) from outside windows (booted to a DOS based utility). When I ran the quick test, it found some errors and suggested I needed to run a "scan all media" test which I am now doing. Since it is a huge 1 TB drive, this takes a really long time to run since the test literally checks the integrity of each sector. The test has been running for 18 hours and still has a few more to go until finished.

If the drive fails, then it needs to be replaced. If it passes, I will repartition, reformat and try again.

I will report back with the final outcome.
m
0
l
January 13, 2010 7:41:51 PM

After the 28 hours required to run a full media scan with the western digital diagnostics utility, an error code was generated which told me the hard drive was faulty.

After replacement with a new WD 1 TB Black edition drive, all is well and functioning as it should.

In retrospect, I wonder...... Had I taken the time to do a full format instead of a quick format, would the problem with the drive been uncovered?
m
0
l
November 3, 2012 2:59:01 PM

The drive may not have been faulty. I had exactly the same problem. The errors you found could have been due to the failed backup, sort of like when you shut down the machine without using the shutdown command. It leaves stuff undone that reads as errors. In my case, I didn't get the backup failed error until I did my second image after an update. There was plenty of room on the disk but it failed anyway with the same message you got. What I did is reboot to bring the drive back, erase the previous system image, and restart the system image. It then worked fine. Even if your case was the drive, I think there is still some kind of glitch in the Windows backup.
m
0
l
!