Sign in with
Sign up | Sign in
Your question
Closed

Wakes from sleep

Tags:
  • Configuration
  • LAN
  • Basic
  • Windows 7
Last response: in Windows 7
Share
December 30, 2011 10:36:22 PM

I have a window 7 machine which will not stay asleep for more than 20-30 seconds. I have disabled all except basic OS processes and stopped all applications. It is always the LAN card which causes the wake event, even though nothing is using the LAN

More about : wakes sleep

a b $ Windows 7
December 30, 2011 11:11:43 PM

You need to change a setting in the BIOS under the power section, disable wake from sleep (or something similar) for the lan setting.
Score
0
a b $ Windows 7
December 30, 2011 11:58:38 PM

In the device manager, there should also be an option to not allow that device to wake the pc up.

Looks a little different from card to card, but like these

Score
0
Related resources
December 31, 2011 11:40:47 AM

Problem is that I do need the machine to wake on a genuine wake-up call. Main computer is hard wired to a Bell wireless modem, and from time to time a remote laptop will need to wake the machine by accessing shared data. This has worked well for many months until recently
Score
0
a b $ Windows 7
December 31, 2011 3:21:16 PM

If it is an Intel card, there are more options. How did you check to see if it was the network waking the system up? Did you use "powercfg -lastwake"(in command prompt)?

If not, i would do that after a wake, to make sure it is not something else.

In my case, media center kept waking the machine up for various reasons such as updating the guide and the remote sensor seeing almost any remote.
Score
0
December 31, 2011 6:27:46 PM

It is definietly the LAN card, as confirmed by powercfg and Windows Event Viewer
Score
0
a b $ Windows 7
December 31, 2011 8:13:49 PM

Hmmm strange. I wonder if ANY network broadcast will wake up up.

Try with the Only Allow a magic packet to wake the computer. See if when the access is needed if a magic packet is getting sent.

The reason i say this, is that if any old broadcast wakes the computer. Any computer asking for an IP will broadcast, hell even accessing a device on the network will broadcast to get its ip address the first time.
Score
0
January 1, 2012 1:08:13 PM

When I set Magic Packet only, the computer does not wake even when the remote computer tries to access it - so it is not sending a Magic Packet. All my tests have been with the laptop totally shut down.
Score
0
a b $ Windows 7
January 1, 2012 3:27:06 PM

So there are only the 2 computers on the network right?

You did not get any kind of new router or anything did you? I know one of the routers I have had some kind of uni cast option that seemed to broadcast to all pc's allot and would wake up a pc.

For the hell of it, have you tried to make it sleep with a dummy network, Just a switch and a manual IP(this way the network card is still running). This would ensure the network card is not just waking up with no activity.

WOL can be a pain at the best of times.

I did a quick search for you and saw this, may be worth a shot. At least as long as it does not prevent the wake you need.

http://jack.ukleja.com/fix-for-windows-7-random-wake-fr...
Score
0
January 1, 2012 8:53:24 PM

Not sure what you mean by 'just a switch and a manual IP' My entire network is the modem with an ethernet cable to the computer. If I pull the cable, I have no wake-up, so seems to be something coming from the modem???. I will follow up the link you gave.
Score
0
a b $ Windows 7
January 2, 2012 2:34:48 AM

If you have a network switch, you can just setup the local computers, without the internet, but if your internet modem, then you may not be able to do this.

That would rule out some kind of broadcast from the modem waking the computer.
Score
0
January 2, 2012 12:31:54 PM

I tried killing the 'Wake on Pattern Match' switch and it let the computer sleep, but then it would not wake on a genuine call from the remote wireless machine. I borrowed a DLink router and put between the main coomputer and the Bell modem. Total Fix!! This SEEMS to prove that the Bell modem is sending some kind of regular packet which does not get through the router to the Computer
Score
0

Best solution

a b $ Windows 7
January 2, 2012 1:17:52 PM

Is networking not fun :) 

If you power up a computer on the network, the computer may still wake up as well when the computer broadcasts that it wants an IP from the routers DHCP server.

There are lots of features on modern cards that are supposed to allow the computer to sleep through such things. So I guess there may be some trial and error under different situations.

Glad you seem to have an idea of what the problem is. Next step may be to see if Bell has any way for you to change options on there modem.
Share
January 2, 2012 2:31:00 PM

nukemaster said:
Is networking not fun :) 

If you power up a computer on the network, the computer may still wake up as well when the computer broadcasts that it wants an IP from the routers DHCP server.

There are lots of features on modern cards that are supposed to allow the computer to sleep through such things. So I guess there may be some trial and error under different situations.

Glad you seem to have an idea of what the problem is. Next step may be to see if Bell has any way for you to change options on there modem.


Thanks for all your help. It was better when the entire OS and Applicartions were on a 64Kb diskette!!!!!. I will tackle Bell again
Score
0
January 8, 2012 11:17:50 PM

Best answer selected by davpol.
Score
0
January 8, 2012 11:21:42 PM

FINALLY, after two weeks of escalation via technical support, Bell admitted that their modem "broadcasts an ARP packet to determine which clients are active/inactive and updates the GUI's Device List accordingly". This behaviour cannot be changed. It is my belief that the frequency of such requests has dramatically increased over the last three months.

I have achieved a fix by attaching the modem through a router - why that works I do not know, but for now it does
Score
0
a b $ Windows 7
January 9, 2012 12:40:17 AM

The router blocks them since they belong outside the network :) 

Computers will also send arp requests when they first try to look for a computer as well.
Score
0
a b $ Windows 7
January 9, 2012 3:52:53 AM

This topic has been closed by Nikorr.
Score
0
!