Sign in with
Sign up | Sign in
Your question
Closed

Why my asus show nvidia adapter when play mafia2 and show intel HD ?

Tags:
  • Nvidia
  • Asus
  • Intel
  • Graphics
Last response: in Graphics & Displays
Share
October 20, 2011 8:58:47 AM

Greeting all
i have asus k53JS with 1Gb nvidia gt520 and i3 intel +4 Gb of ram.
when running benchmark on below games.
show nvidia adapter when play mafia2 & PEs2011 and show intel HD graphics on gta IV ?

playing GTA give bad speed ?
mafia with great quality

i believe there is some config i had to made from nvidia control panel to make GTA use it instead of intel HD

is that true ?

thanx in advance

More about : asus show nvidia adapter play mafia2 show intel

October 20, 2011 10:03:48 AM

any ideas ?
Score
0
a b Ĉ ASUS
October 20, 2011 10:22:09 AM

http://www.asus.com/Notebooks/Versatile_Performance/K53...

here's the deal; the laptop you have is build around the sandy bridge CPU from intel. now that cpu architecture actually houses a gpu within the processor. soin effect you have a gpu on that cpu and you also have a dedicated GT520

i don't know if you have both GPU drivers installed but that will cause some errors during games.

btw the GT520 is better than the intel you have now on your laptop.

oh, welcome to the forums, newcomer!
Score
0
Related resources
October 20, 2011 11:27:11 AM

Dear lutifi ,

Thanx 4 replay...and yes , nvidia drivers are installed and updated. mafia 2
detect nvidia and it's working smoothly, but GTA not,
i wonder if there is some setting to do within GTA or nvidia control panel that i missed,,,thanx again
Score
0

Best solution

a b Ĉ ASUS
October 20, 2011 4:39:57 PM

i haven't played GTA (any within that series) but i know that games have a gpu detect/config utility prior to loading the game. maybe select the intended GPU wihtin that utility. I say this because i played Mass Effect 2 and before the game starts up you are greeted by a screen and you can select the GPU/settings.

another note; go to Control Panel\Programs\Programs and Features and see if you have any intel HD display drivers. if you do then uninstall them. reboot and then try running GTA - see if that helps with the GPU detection.

You're welcome but don't thank me yet.
Share
October 22, 2011 5:36:24 AM

Best answer selected by toonz.
Score
0
October 22, 2011 5:43:18 AM

dear lutfij,
thanx for instructions , in addition you could right click on application (game) short cut and choose to run with Intel HD or nvidia graphics card..but i am sure now problem is with game which refuse to run on nvidia ...by the way , on ASUS , you could use nvidia control panel the go to 3d setting then manually add application to run below..i did this with PES2011 , it didn't work at firs(no card detected) after adding to 3D setting its work perfectly ...thanx all
Score
0
a b Ĉ ASUS
October 22, 2011 5:51:04 AM

thank you for the vote mate!
Score
0
a b Î Nvidia
a b Ĉ ASUS
October 22, 2011 5:19:32 PM

This topic has been closed by Hunter315
Score
0
!