Sign in with
Sign up | Sign in
Your question
Closed

HD Radeon 6870 + 42" HDTV = bad combination?

Tags:
  • Graphics Cards
  • Graphics
Last response: in Graphics & Displays
Share
October 20, 2011 5:49:57 PM

Build:

CPU: AMD Phenom II X6 1100T Processor, Black Edition (not overclocked, YET)

CPU Cooler: Cooler Master V8 Nickel Plated Copper Base Aluminum Fins 8 Heatpipes

Case: Cooler Master HAF X Full Tower w/ SuperSpeed USB 3.0 w/ Window w/ Black Interior ATX Case)

HDDs: Seagate Barracuda XT 2 TB 7200RPM SATA 6 Gb/s 64MB Cache 3.5 Inch Internal Bare Drive ST32000641AS
Seagate Barracuda Green 2TB SATA 6Gb/s 64MB Cache 3.5-Inch Internal Bare Drive ST2000DL003

(was planning on making this my SAP server too, that's why I have the excessive drive space)

Graphics Card: MSI Radeon HD 6870 1 GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card with Eyefinity R6870 Twin Frozr II

Power Supply: X4 Series 850W Atx Ps

Motherboard: ASUS Sabertooth 990FX - AM3+ - TUF Series

RAM: 2x Corsair XMS3 4GB PC12800 DDR3 1600MHz 4096MB

HDTV: 42" 120Hz 1080p Sony. 1920x1080 Max Res



First let me apologize if this is a stupid question. I am new to the Computer Gaming/Hardware world.


I want to play my PC games (Crysis, Metro 2033, MTW, Etc) at the highest quality while keeping a good framerate.

I have been trying to mess with the settings in Crysis to do this and it is looking like SH*T.

I've tried with all of the default quality settings and tried my own, but whenever there is "action" going on, the screen gets really choppy. (horizontal lines)

I am trying to run my games at the HDTV max res (1920x1080).


Is my Graphics card too weak to provide good Frame rate and Quality? Should I upgrade? Is there something I am missing here?

(I will update this post with my current frames per sec, using FRAPS, when I get home)


Thanks in Advance.

More about : radeon 6870 hdtv bad combination

Best solution

October 20, 2011 6:46:23 PM

My wife was playing her games on our 55" 1080p LED LCD (with a 6770) with Max Settings. You will be fine. Make sure to turn "Game Mode" on the TV. I have a 6870 and when I used it, it was fun with the big screen:) 
Share
October 20, 2011 6:49:18 PM

Why should I make sure to turn on "Game Mode"? Does this really affect the quality/playability?
Score
0
Related resources
a b U Graphics card
October 20, 2011 7:00:04 PM

Game mode is probably just a preset in the tv with adjustments that they think will be best for gaming like color settings, contrast and such. TV's a fine for gaming, as I use my 37 inch Samsung lcd for it. With that 6870, you won't be able to play Crysis or Metro 2033 at max though, they are both very demanding games, most other games you should be fine though.
Score
0
October 20, 2011 7:02:06 PM

I use a 37" 1920x1080 and it works great with a HD 4870.
Which has similar benchmarks as the HD 6770 does.
With a 6870 you are using it should be running plenty fast for most games. I have not tried to max out crysis but I can play most new games with some eye candy and get a good frame rate...
StarCraft 2 looks awesome!
I would check to make sure that your computer isn't doing something else in the background causing the slowdown/issue.
I do know that Crysis is extremely demanding. If you are trying to max it out completely then I don't think that is gonna happen.
Score
0
October 20, 2011 7:02:44 PM

holdingholder said:
Game mode is probably just a preset in the tv with adjustments that they think will be best for gaming like color settings, contrast and such. TV's a fine for gaming, as I use my 37 inch Samsung lcd for it. With that 6870, you won't be able to play Crysis or Metro 2033 at max though, they are both very demanding games, most other games you should be fine though.



And that is pretty much what I figured. But even when I tried playing Crysis at "Medium" settings, I still received a lot of screen choppiness.

I can understand not being able to Max it out. But really? not even "medium" quality?
Score
0
October 20, 2011 7:06:47 PM

dark_lord69 said:
I use a 37" 1920x1080 and it works great with a HD 4870.
Which has similar benchmarks as the HD 6770 does.
With a 6870 you are using it should be running plenty fast for most games. I have not tried to max out crysis but I can play most new games with some eye candy and get a good frame rate...
StarCraft 2 looks awesome!
I would check to make sure that your computer isn't doing something else in the background causing the slowdown/issue.
I do know that Crysis is extremely demanding. If you are trying to max it out completely then I don't think that is gonna happen.



Hmmm. Ok. My computer is pretty bare when it comes to programs, it is a relatively new build. I try to make sure most things are turned off. But I must be missing something.


So at least now I know my graphics card should be able to handle this, I just need to find out what is causing the issue.

Score
0
October 20, 2011 7:31:39 PM

Check all your drivers, updates, firmware on everything. Bios for your mobo. And turn Game Mode on:)  For the most part yes, it will preset a lot of your visuals, BUT, it will also help reduce the latency from the video card->tv->you :) 
Score
0
October 20, 2011 7:34:58 PM

OC your 1100 to 4.1 too. And yea you won't run Crysis as Max without any FPS lag as it's very CPU as well as GPU dependent, and well, sucks for us 1100ers but, yeah Sandy Bridge>Phenom II. And 6800 series is meant as an in-between of cheapo budgeters and super single GPU solutions. CF will help, micro stuttering will ensue then however. Best is x3 CF solution. Depending on your mob however, you may want to look into a single 6870 and a 6870x2.
Score
0
October 20, 2011 7:38:08 PM

If what you see is tearing in the lines on the screen, you may want to know that your input on the TV may only support 24 Hz. This is because thats what Blu rays play at and that is what TV's recognize at Full HD. Computer monitors support higher input rates than TVs do. The TV gets an input at 24Hz and then puts it through a processor to upscale that to 60 Hz, or the TV refresh rate. Computer monitors though accept inputs from the DVI port or display Ports that accept much higher inputs to Refresh rates so they dont have the Ghosting\Tearing effect that you get when you up a 24Hz to 60 Hz or even worse 120 Hz. the output on your computer is sending it out at 60Hz then getting downscaled to 24Hz then getting upped to 60/120/240 Hz. Consoles dont have this problem because they output at 24Hz that the TV input accepts. Play with your refresh rate on The TV to see what is the best for your games.

I have a 42" 60Hz TV with an 8800GTS and don't have a big issue with the screen tears or Ghosting, and cn play Crysis at full resolution.
Score
0
October 20, 2011 7:40:41 PM

It's not your CPU unless something else is running and causing the slow down.. I agree you should check for a game mode and see if that makes a difference.
Score
0
a c 365 U Graphics card
October 20, 2011 8:11:22 PM

Game mode basically switches a 120Hz (and 240Hz) HDTV to 60Hz mode.

HDTVs only have 60Hz input so that limits frames to 60 per second. 120Hz HDTVs uses video interpolation to create an "in between" frame between every 2 actual frames to output at 120Hz (or 120 frames per second). This is done to improve movie and video smoothness. However, because it takes time to create each interpolated frame, this would cause increased input lag in games.
Score
0
a b U Graphics card
October 20, 2011 8:41:07 PM

. LCDs don't have a refresh rate. They are not CRTs. You only see a refresh rate in windows because it needs to be compatible with hardware that are use to receiving from the frame buffer that's why we still see a refresh rate in windows. To say fps equals refresh is not correct. Refresh rate or the hz is what your screen needs to emulate. Fps is how much frames your gpu can produce. Just switch on Vsync to let your gpu know about your monitors limitation
Score
0
October 20, 2011 9:41:38 PM

Why would it be a bad option as long as its 1080P go with it. You may have to scale the Image to the whole screen on AMD settings but thats it. my 6950 loves my Acer 32Inch 1080P tv.
Score
0
October 23, 2011 2:23:40 PM

I can't believe it, but putting my tv into Game mode fixed it. Runs beautifully at all high settings + AA. Never would have guessed that.

Thank You All
Score
0
October 23, 2011 2:23:59 PM

Best answer selected by sardonicjester.
Score
0
a c 274 U Graphics card
October 23, 2011 3:23:15 PM

This topic has been closed by Mousemonkey
Score
0
!