Sign in with
Sign up | Sign in
Your question
Solved

Temps on i2500k seem a bit too high?

Tags:
Last response: in CPUs
Share
March 23, 2012 6:57:13 AM

Hello, Quite recently I installed an i2500k using artic silver x-2 and the stock fan. Anyways, im running it at standard settings and i hadn't had a chance to really use it until today when i started playing a not very demanding game called combat arms. I took a screenshot of the temps at the time but i forgot the photobucket info. and i do not feel like creating a new account at the moment. At the time, the temp went as high as 56 C and mb temp was up to 34 C. The cpu usage was up to 60%. I figured that the problem was due to the way in which i applied the thermal paste. So i went ahead, cleaned it up and re-applied it. I tried the game again right after applying the paste and the temps stayed at a max of 44C. Idk if that is a bad thing and if there is anything I should do? Idk if the x-2 is supposed to be good paste. I was thinking that maybe the problem is due to a paste defficiency and that i could fix it by getting a better paste but Im not sure if that could be it. Im rather broke at the moment and would rather not buy an aftermarket sink.

Any suggestions? And say I was to keep things the way they are for a while until I can buy a better sink. What is the highest temp that i can safely go up to without causing any damage?

Thanks,

Isaac, R.

More about : temps i2500k bit high

a c 186 à CPUs
March 23, 2012 7:02:35 AM

When you go above 70C you should be worried. Anyways, those temps are fine.
m
0
l
March 23, 2012 7:20:59 AM

Hmm, okay. Thanks for the quick reply!
m
0
l
Related resources
March 23, 2012 8:04:28 AM

The MAX is like 80c (Damage to Processor) There are a lot of overclocked i5's that hit 72c as their Max while Stressing the system for long peroids. I've got mine maxxing out at 68c after Stressing. So on a hot day while gaming I might hit 72c ... MAYBE...
m
0
l
a c 172 à CPUs
March 23, 2012 8:08:10 AM

But the new CPU's will automatically throttle back to prevent selfdestruction.
m
0
l
a b à CPUs
March 23, 2012 8:14:02 AM

The i5-2500K has a thermal limit of 98 deg C...so no worries there.

Your first run at 56 deg C seemed a bit high, but the 44 deg C seems like a normal temp for gaming, even an undemanding game. Other factors come into play too...the cooler you have, case ventilation and airflow, dust build-up etc.
m
0
l
March 23, 2012 11:26:57 AM

diellur said:
The i5-2500K has a thermal limit of 98 deg C...so no worries there.

Your first run at 56 deg C seemed a bit high, but the 44 deg C seems like a normal temp for gaming, even an undemanding game. Other factors come into play too...the cooler you have, case ventilation and airflow, dust build-up etc.


There shouldn't be any dust since i just put up the system together 2 days ago. And im using the antec df 85 (running all the fans on low though). My usual temp when im not doing anything but watching the temp via the built in program and browing the internet seems to be between 33-35 C.

So, overall Im okay?
m
0
l
March 23, 2012 11:48:47 AM

Okay, something else that is worrying me. So, im running on clear internet because it is the only net available in my area and im trying to download bf3 via origin. I like to download at night because by then everyone is gone to sleep and I can have the net to myself. The problem is that the pc goes into hyber mode after 30 mins of inactivity and at some point I get disconnected and my download becomes paused. Quite frankly im unfure if it is a pc, a net or an prigin issue. Anyways, tonight, i disabled hyber mode and left the pc downloading and on screensaver mode. So, I woke up three hours later and after coming back from hybermode I get a black screen with no background and the origin screen in the middle of the screen. The download was paused so i went on ahead and hit the resume download button. Anyways, at this point i hadn't noticed that my background was gone. So, i hit clear +alt+del to bring up the commander (lol) and the commander popped up like it normally does and then i closed it down. I hit okay and then i was stuck on the background that comes up when you bring up the commander. Tried clr+alt+del again while stuck there but nothing happened. Also, the cursor was working just fine even while i was stuck in that background.

What worries me is that the cpu may be having trouble? or did i mess up by turning hyber off and leaving the pc on screensaver mode for 3 hrs? I highly doubt that it is a gpu related problem because i haven't had any issues with it yet... Any ideas of what may have caused such problem? Please don't tell me that I have to babysit the download because it is going to take another 20 hours...

System specs in case you need them?
gskill ripjaws seris 2x4gb
asusvg236he
seasonic m12II 620 bronze
sapphire 7950
i2500k
antec df-85
ASRock P67 PRO3 (B3) LGA 1155 Intel P67

m
0
l
March 23, 2012 12:02:27 PM

Argh, slow internet wont let me load the edit page. Forgot to mention that im running windows 7 ultimate x64.
m
0
l

Best solution

a c 186 à CPUs
March 26, 2012 3:30:06 PM

Power mode to performance, and sleep to never.
Share
March 31, 2012 4:37:12 AM

Best answer selected by xtremeclowny.
m
0
l
!