PC lag problem

Hello, i have the following pc configuration for about 1 year:

AMD Athlon x3 450
ATI HD 5670
MB Gigabyte GA-MA78LMT-S2
Sirtec ATX-410-212
Win 7 32 bit Home Premium
Kaspersky antivirus

The problem appeared a couple of days ago, while I was playing Skyrim.
It started to lag pretty badly, even on the lowest settings. I would have understood if it was lagging from the begining, probably my pc couldn't handle the game, but the strange thing is that it was working just fine before, no lag, constant fps (above 30 on medium settings), now its like 10-15 fps.

I have this problem with all of my other games too, games that worked perfectly before.

I'm pretty pissed off right now, i've tried dusting my pc, scanning for viruses, updating my Windows, updating my drivers, defragging; i've also tryed replacing my psu with a higher power one, but didn't change anything.

Some symptoms that I thought were important (and weird):

-I’ve tried pulling out the ram stick and putting it back in and for about 5-10 minutes it worked perfectly but then it started to lag again.
-It starts to lag after some time after the install, in the first couple of minutes it works ok but then it lags every time I run it.
-In some games (like black ops) it only lags in single player, in multiplayer it works great.

The temperatures are fine, the graphic card does not pass 60* and my cpu stays at around 40-50* (in game).

I would be very grateful if someone could help me.
4 answers Last reply
More about problem
  1. If you think it might be tied to RAM, download and run memtest.
  2. i did run memtest and it showed 0 errors
  3. i'm waiting for some more suggestions guys..
Ask a new question

Read More

Lag Components