Sign in with
Sign up | Sign in
Your question
Closed

Red light on DRAM please help!

Last response: in Memory
Share
January 31, 2013 4:29:11 AM

So I upgraded every part in my old computer except for the processor! My old computer worked wonderfully but I just wanted some new hardware. I gave my old PC (which had everything except for a processor) to my boss and he bought an i7 3770 to drop in it. So today we put the processor in and we get a solid red light near the ram. I find this odd because all those parts had been working just a month ago. Now there was ALOT of dust in the case and there was no cover over the CPU socket when it was sitting in the corner of my house. Do you think dust is the problem? Also, it should be noted, I never reformatted the hard drive. So im still running a hard drive that was never wiped of anything on a new CPU, but would that cause a RAM problem? Thanks for the help in advance, afterall id like to keep my boss happy!

Specs follow:
Asus p6p67 mobo socket 1155
intel i7 3770
corsair 8g 1333 ram
1tb hard drive
antec 650 PSU.
some random graphics card...a 210 i believe?


let me know if you need anymore information

More about : red light dram

a b } Memory
January 31, 2013 5:06:37 AM

If the RAM LED lights up, it means you have a problem either with the CPU socket, DIMM slots, DIMMs or CMOS settings.

First thing to try would be resetting the CMOS to default and see if that helps. Many Asus motherboards have the "MemOK" button that reset RAM settings to safe values. If that does not work, you can try re-seating the DIMMs but considering the contact force those slots have, I doubt much dust would survive insertion. If that still doesn't work, you may try dusting off the CPU socket using canned air from far enough to avoid the air blast bending pins.

If none of those help then something may have broke. Might want to try with your old CPU to see if it might be the new CPU that is either defective or does not like your RAM for some reason.
Score
0
January 31, 2013 6:01:31 AM

are defective CPU's a common thing? i know dead ram is but like i said i know this ram is good.
Score
0
Related resources
a b } Memory
January 31, 2013 6:53:51 AM

3770/ 3770K was not supported until BIOS revision 3207. Not saying that it is the problem but did you update the BOIS to make it 3rd Gen capable? Any BIOS version prior to 2001 does not support 3rd gen at all. If the BIOS was not updated do that first. DOA CPU's are uncommon. If the BIOS was not updated you should put a 2nd Gen CPU back in to update it.
Score
0
January 31, 2013 7:13:43 AM

Does the bios update automatically? I was never prompted to update it. Like i said the computer was running just a month ago.
Score
0
January 31, 2013 7:25:27 AM

The fact that the computer wont even post doesnt have anything to do with the bios does it? I mean the computer turns on for about 3 seconds and turns off again and then comes back on and will stay on until i turn it off manually.
Score
0

Best solution

a b } Memory
January 31, 2013 7:54:44 AM

The BIOS does not update itsself you have to download the BIOS from the ASUS site. You can download bios 3602 from http://www.asus.com/Motherboard/P8P67/#support_Download... . You will need to press the delete button at BIOS post to enter the BIOS. Once there you can use the ASUS EZ flash to update your BIOS. I personaly have never put a 3rd Gen processor into a 2nd gen motherboard that has not been updated to support 3rd gen processors so I do not know for sure but I think that the BIOS is the most likley culperate for this problem sence everything worked fine before and you have not updated the BIOS to support 3rd Gen CPU's. I think the BIOS does not know what to set the processor at Multplier, voltage how many cores etc. and that non detection is causing it not to post. you should put your old CPU back in the comp update the BIOS then put the 3rd gen back in.
Share
a b } Memory
January 31, 2013 6:56:26 PM

coolmanfoo said:
are defective CPU's a common thing? i know dead ram is but like i said i know this ram is good.

DOA semiconductors are actually pretty uncommon in general since most of them go through multiple checks along the manufacturing process.

I forgot about the BIOS as another possibility so as others above said, you might want to make sure it is up to date. Since your motherboard is a SB-generation one, it almost certainly did not have Ivy Bridge support out-of-the-box. Since you asked whether or not BIOS auto-updates, I'm guessing you are still running on the original BIOS.

To update the BIOS, you will need to put your old CPU back in to make the computer boot and do the update from there. Either by booting the OS, downloading the tools and new BIOS then running that or putting the updated BIOS on a USB key and using the BIOS' update from USB option if it has one.
Score
0
February 1, 2013 8:10:12 PM

Best answer selected by coolmanfoo.
Score
0
February 1, 2013 8:10:23 PM

Turns out it was a bios issue, when I put the 2600k back in the old build it turned on and everything has been working flawlessly. Thanks everyone for the help!
Score
0
!