Am using the ga g41 es2l with 2GB of RAM, but suddenly it does not display anymo

Am using the GA G41M ES2L with 2GB RAM, WINDOWS XP PROFESSIONAL service pack 2. But suddenly no more display. I tried with other Ram still no success.Please help my email: nissy357@yahoo.com
5 answers Last reply
More about es2l suddenly display anymo
  1. Did you reset the bios first? Try with only one ram card in slot 2.
  2. Yes i did reset the bios by resetting jumpers but can not know if it worked since there is no display
  3. Do you use onboard video ??
  4. yes am using on-board, but have tried with a working video card from my second pc but still no success
  5. Did you have a graphics card on your current build or were you using onboard video?
    Try staring without a hdd. Try a different video cable. Is anything displayed on the monitor like no video input? Are the motherboard giving of any error beeps? Does the fans and lights power up when you switch on the computer?
Ask a new question

Read More

Motherboards RAM Windows XP Displays