Sign in with
Sign up | Sign in
Your question

Interesting Problem After RMA

February 1, 2013 6:38:09 AM

Prereq's:
MB: SABERTOOTH Z77
CPU: i7 3770k (Cooled by a Corsair H100 Liquid Cooling system)
PSU: Thermaltake BlackWidow 850w TR2 RX
GPU1: Radeon 6850 HD
GPU2: Radeon 6870 HD
RAM: Corsair VengeanceLP (4x4GB - 16 GB)
Case: Corsair Carbide 500R

So recently I got a SABERTOOTH Z77 and a 3770k, but the mobo turned out to be a bum board so I RMA'd it through ASUS and they sent me a new one. While I was waiting on the RMA I bought a 6870 GPU to crossfire with my 6850 (was the same price as the 6850 and I can always get another 6870 to avoid the downclock) and also bought a new PSU to make sure I had enough power for it all.

Now I have my mobo back and have everything installed just as it was before, but with my extra GPU and new PSU in. The problem is that whenever I try to load a YouTube video in any browser, shockwave flash crashes and the video won't load. I have tried updating Flash, downgrading flash, trying the current beta build, rolling back my drivers, updating my drivers, and trying out the beta drivers for my current hardware, but nothing works. I even entirely reinstalled windows and only installed a LAN driver to make sure a driver wasn't conflicting with Flash.

Another thing, when I try to log into League of Legends, after I click the play button (when the client would normally open - I believe it runs in Adobe Air) the client never loads, or I get an error message (the error message tells me nothing as it's a generic error for the game and Riot Games couldn't help me with it), OR the client opens but remains a black box inside of the game frame.

And once more, when I try to load XSplit to stream, the video streams but is extremely laggy even under the most lightweight settings where it shouldn't lag at all.

I have tried removing one GPU, and removing both of them and running on integrated, but the problem persists.

Disabling hardware acceleration or disabling the embedded chrome flash player does not fix the problem.

ANY and ALL help is needed. I can usually solve PC problems on my own but this one really has me stumped.

EDIT:

Just tried resetting the CMOS twice (because I know that's always the step 1 suggestion :p ). Problem persists.
!