Sign in with
Sign up | Sign in
Your question
Closed

Problem with Sapphire Radeon hd 6870

Last response: in Graphics & Displays
Share
October 23, 2011 7:36:14 AM

Just bought a new Sapphire Radeon 6870 GPU for my new pc. Without the card, everything works just fine and I have no problems doing anything with the on board graphics on the i5 2500k. When I installed the card and started up my pc (everything seems to work perfectly), the resolution was restricted to 800 by 600 (because I have not yet installed the drivers yet). I went to Sapphire's website and download the drivers, installed and restarted my pc. It gets up to where windows 7 shows the loading screen with "Microsoft Corporation" written on the bottom and then the screen goes completely black and stays like that. I'm still able to go into the bios and load windows in safe mode using the card, but I cant go into normal windows (because of the black screen after the loading screen). When I remove the card from the motherboard and plug my monitor into the integrated gpu port, everything continues to work fine. I tried using the drivers from the amd website directly and I still have the same issue. As soon as I install the drivers and restart, I get the same black screen after the windows loading screen. It seems to be some sort of driver issue. Sapphires tech support is a hassle (in my experience), and I would really appreciate it if someone could help me out before/while I try to get in contact with tech support.

I never had a card do this to me before :o 

My specs:
Core i5 2500k at stock (for now)
ASrock pro3-m z68 mobo
G.Skill 4gb DDR3 1600 ram
Antec 520w PSU
Sapphire Radeon HD 6870 1gb gddr5
Windows 7 Ultimate 64bit
October 23, 2011 8:07:34 AM

do you have the 2 6 pin connectors connected to the GPU?

you also didn't include the monitor with native resolution. please post back and we'll see...
Score
0
October 23, 2011 8:15:48 AM

Yes, its plugged in. I tried using my 17 inch gateway 720p monitor, a 1080p Samsung monitor and even my TV, via hdmi. Same problem every time.
Score
0
Related resources

Best solution

October 23, 2011 8:21:12 AM

faulty gpu then...still in warranty period--->RMA
Share
Anonymous
October 23, 2011 1:06:59 PM

Hi darksulfur5 have you fix the problem?

I've the same situation...

Thank's
Score
0
October 23, 2011 1:58:35 PM

Two shots in the dark:
- first, have you disabled the onboard graphics / enabled discrete?
- try plugging into another pci-express slot if you have another you can use, preferably closest to cpu
Score
0
October 23, 2011 7:51:35 PM

^ follow the above advice's and see of they help... if all else seems lost - see of you RMA the card. Or better yet just take it to the place that built that the rig for you.

FYI - you'd be amazed what google can spit out if you know how to use it;
http://www.tomshardware.com/forum/308123-33-video-insta...
http://www.computing.net/answers/hardware/no-display-af...
http://www.computing.net/answers/hardware/monitor-doesn...

by now you can understand that your card is faulty...thus the point of getting it replaced under warranty.

http://forums.techarena.in/monitor-video-cards/1411591....
Score
0
October 23, 2011 10:13:37 PM

I wouldn't be so quick to go RMAing the card. Make sure your old drivers are gone completely (use Driver Sweeper), also I'd recommend getting your drivers from AMD instead of Sapphire's website. If its getting close to the end of the RMA period, then perhaps it would be worth returning it, but if you're able to boot almost to windows, I'd say there's a chance its a driver issue still.
Score
0
October 24, 2011 3:47:01 AM

^ there were other threads that show the same problems as OP - no display after windows logo - no display but fans spinning up - no display and no error beeps...
Score
0
October 25, 2011 1:55:01 AM

1. I have a z68 board, the on board graphics aren't suppose to interfere (since its designed to use both anyways), never the less, i turned it off in bios.
2. My psu isn't the problem
3. This is a completely new build with no previous drivers installed (except for the intel drivers for the integrated gpu)
4. The pci-express slot works with one of my older nvidia 6600le cards i had lying around.
5. I saw those posts, but they didnt help me, which is why I asked again, sorry about that. Yes, I know how to use google.
6. This is my 8th time building a pc (my 2nd using a 6780, gave my first one away to my friend who needed a good pc for school, but couldn't afford it) which is why i'm stumped as to whats causing this as ive never had this problem.
7. This is the first time I didn't have the gpu plugged in when I installed windows (since the card got shipped to me a week afterwards).
8. Even though the intel drivers have never ever interfered with any of my builds, and I disabled the drivers with no avail, I'm doing the following:

In a last ditch effort (from what I can tell its some sort of driver issue given it gets up to the windows logo instead of not working at all) im going to re-install windows (with the card plugged in from the start). And I'm very disappointed in Sapphire tech support to say the least . I sent them multiple emails, and opened several tickets on their support website. No response. Thank god Newegg has a good customer service track record (just encase I end up rma'ing this annoying piece of $....). Ill let you guys know if it works or not. Thanks for all you've done so far.
Score
0
October 25, 2011 3:29:14 AM

Definitely rma'ing this. First time buying from sapphire and I get a rotten egg. Not buying from sapphire ever again. :non: 
Sending back to newegg
Score
0
October 25, 2011 3:30:49 AM

Best answer selected by darksulfur5.
Score
0
October 25, 2011 11:01:53 AM

Quote:
This is the first time I didn't have the gpu plugged in when I installed windows (since the card got shipped to me a week afterwards).
well, erm NOW that the truth is out - did you make a clean install of win7 after getting HD6870 GPU?
Score
0
October 25, 2011 4:58:25 PM

This topic has been closed by Mousemonkey
Score
0
!