Asus motherboard hangs bios

Hello,
Bios halts at, press F1 to continue and F2 to change the bios settings.
Doesn`t take any instruction from the keybooard

I have removed all the connnections RAM and CUP and retried, but doesnt help. Also have reset the Bios and removed the bios battery, but still doesnt help.
6 answers Last reply
More about asus motherboard hangs bios
  1. Hi, Try other USB ports and borrow a keyboard for testing.
  2. i am using ASUS M5A88-M motherboard, used different USB ports.
    i have reset the bios through the jumper.
    replaced the battery
    also unplugged all the hardware and kept the board as standalone, still doesnt help.
  3. i have tried both USB and PS2 keyboard, also tried the PS2 to USB converter, didnt help.
  4. Is it a new setup? What CPU using?
  5. 8 months old setup, had been running without trouble so far,
    using MD 3.6 GHz AM3+ FX4100 Processor
    4 GB, Corsair 1333 RAM
  6. Weird. If the board is still under warranty, you can try RMA-ing it. If not, you can try replacing the BIOS chip with a new one (from ASUS eStore if in US or from ebay).
Ask a new question

Read More

Asus BIOS Motherboards