Sign in with
Sign up | Sign in
Your question

ASUS M5A97 R2.0 Can't access the BIOS.

Tags:
  • Asus
  • Motherboards
Last response: in Motherboards
Share
February 2, 2013 9:34:50 PM

First off here are my specs
Motherboard: M5A97 R2.0
CPU: 4.0Ghz 8-Core w/ aftermarket heat sink
PSU: Corsair TX750M
GPU: Asus HD7770 2gb
RAM: 1x8gb corsair vengeance DDR3 1600
HDD: 120GB corsair force gt SSD
Disk drive: ASUS 24x burner/reader

Problem in short: PC powers on, but nothing displays on screen.

Problem leading up to this:

First ever boot up, was used with a PSU CX750M. After fixing the CPU fan problem, when trying to access the BIOS nothing appeared but darkness. Okay... So I put the motherboard disk in, tried to download BIOS things, and went through its speal in linux, but errored at the end. Reset and placed windows 8 disk in, went through the download process fine and dandy. Finished downloading, and I was looking away at the time, but next glance back the computer was off. From then on ever time i tried to boot up, the LED fans would turn on but power off right away. Troubleshooted with my friends already built, working computer, found it was the PSU that failed (as the whole system powered on for 1 second then turned off). Okay... I just replaced the PSU, rewired and everything, and it turns on perfect now, but from the first power up nothing ever shows up on the screen. No noises occur even with a speaker plugged in so windows isnt secretly booting up. I'm planning on troubleshooting again with my friends computer by checking the SSD, GPU, and RAM in his computer. I'm worried its my motherboard.

The MemOK light on the board sometimes flashes on power on, and sometimes only when I push the button.

Everything is plugged in right and I have pulled out the battery on the motherboard many times.

So basically I am wondering if its a RAM issue, or my SSD has corruption from trying to download the BIOS drivers from the disk it comes with, or the motherboard was bad from the beginning as I couldn't even access the BIOS in the first place.

For the time being, does any have maybe a solution to this problem?

Addition detail i find weird: When CPU 8-pin is plugged in, my disk drive when opened, closes after fully opening right away on its own. When the CPU is unplugged however the disk drive stays open. Brand new PSU and way more wattage than i need. Edit: Removing the SATA cable from the back keeps it open also, but right as i plug it back in the disk drive closes on its own.

Addition detail: After reading the manual the RAM card I have isn't on the compatible list, even though my computer device manager on the first time I ever booted it up read the RAM card. I also have to put the card in the 3rd slot (2nd from right) because my heat sink is quite large and the RAM stick is a lot taller than my friend's, who can have 4x4gb sticks of corsair vengence in and runs fine. Would RAM incapability really keep my computer from POSTing or even allow me to access the BIOS?

More about : asus m5a97 access bios

February 3, 2013 2:19:02 AM

Just need a second opinion whether or not it's the incompatible RAM that keeps it from posting. I'm also confused on why my disk drive wont stay open unless either the SATA cable is disconnected or the CPU 8-pin is disconnected. (If I want to put in a disk I have to quickly slide it into place or forcefully hold it :/  )
m
0
l
!