Biostar TZ77XE3 and NVIDIA GTX 460-Display resolution

I have a new build and seemingly can only use the on board video to get proper display resolution. Presently at 1680 x 1050. When I try to use the Nvidia card, it won't give the option for increased resolution, highest being 1280 x 780 or something. I've tried adding customized resolution but it appears fuzzy. Also found proper display driver for my AOC monitor. I've disabled on board video. I have a feeling there's something in the bios I need to adjust but can't tell what. I've uninstalled and re-installed drivers, re-installed operating system.... at a loss. Any help would be appreciated. Thanks.
-Mark
2 answers Last reply
More about biostar tz77xe3 nvidia display resolution
  1. markc23 said:
    I have a new build and seemingly can only use the on board video to get proper display resolution. Presently at 1680 x 1050. When I try to use the Nvidia card, it won't give the option for increased resolution, highest being 1280 x 780 or something. I've tried adding customized resolution but it appears fuzzy. Also found proper display driver for my AOC monitor. I've disabled on board video. I have a feeling there's something in the bios I need to adjust but can't tell what. I've uninstalled and re-installed drivers, re-installed operating system.... at a loss. Any help would be appreciated. Thanks.
    -Mark

    did you install the intel chipset drivers?? so that the pci bus works fine and that the nvidia drivers find the card??
    make sure that in windows device manager you have nvidia video card and not a standard vga card.
    make sure you let nvidia driver finder on nvidia web page find the newest 3xx driver for you.
    you can check your bios rev from the ones posted here.
    http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=581#dl
    there one new beta bios.
  2. smorizio said:
    did you install the intel chipset drivers?? so that the pci bus works fine and that the nvidia drivers find the card??
    make sure that in windows device manager you have nvidia video card and not a standard vga card.
    make sure you let nvidia driver finder on nvidia web page find the newest 3xx driver for you.
    you can check your bios rev from the ones posted here.
    http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=581#dl
    there one new beta bios.


    Yes, installed Intel Chipset drivers, device manager shows correct video card, yes newest 3xx drivers. Might try updating BIOS but I can't imagine that's the problem. Thank you.
Ask a new question

Read More

Chipsets Resolution Nvidia Motherboards Displays