GTX 560Ti Problem - NEED HELP ASAP TY

Coming across a weird problem on a computer where canyourunit.com is saying that the GTX560Ti im using only has 3.0 shaders and therefor can not run battlefield 3.

I go to run battlefield 3 and I get this message.

http://i52.tinypic.com/205v9qs.png

And here is what canyourunit.com says

http://i54.tinypic.com/2cnv4wn.png

---------------------------------------------------------

Any assistance would be appreciated, I know for sure that the GTX560Ti can handle battlefield 3 and also uses 5.0 shaders, I tried reinstalling Mobo drivers and the newest video card drivers 285. Neither helped.
5 answers Last reply
More about 560ti problem asap
  1. You need to get the latest verion of direct x.
  2. inzone said:
    You need to get the latest verion of direct x.


    DXDiag says I have direct x 11.
  3. I know it's said not to bump, but I still haven't solved my problem.
Ask a new question

Read More

Graphics Cards Gtx Battlefield Drivers Computer Graphics