Sign in with
Sign up | Sign in
Your question

Computer will ping router, but won't connect to it

Last response: in Networking
Share
January 19, 2011 9:43:32 AM

Hi all,

I have been attempting to get an old PC to connect to a network, over ethernet. I have been able to ping the router, but when I try to connect to it (by typing the IP address into the browser address bar), it says that "Internet Explorer cannot display the webpage".

I have tried the "diagnose connection problems" wizard, this didn't help (just told me to contact the system administrator, which is me :)  ).

The IP addresses and other related information is all set up correct (it matches what is on the other computers I can connect to the network), although I did have to manually set this up, as the settings that the computer had automatically detected were definitely wrong (again, I checked this using another machine on the network).

The computer is running XP Pro (SP3), and uses an Asus P4R800-VM motherboard (most detailed page is here: Asus Support- Downloads). This uses a 3Com 3C920B-EMB-WNM Integrated Fast Ethernet Controller (which I have updated the drivers for)

The router is a Billion BiPAC 7800N, with gigabit ethernet. It works fine apart from this one computer

Thanks in advance for any help you can give
Anonymous
January 19, 2011 10:24:31 AM

I hesitate to offer you this advice as you seem to know what you're doing but just in case........


Go Start then Run in XP - (Windows key plus R in Vista and Windows 7), then type in the following, including all the spaces:- cmd /k ipconfig /all -- then press Enter and from the black form that shows up, take a note of the numeric code beside the word "gateway" -- usually something like 192.168.0.1. Type exit to close the black form.

Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.
January 19, 2011 10:39:59 AM

Thanks for your response

I've already tried that- when the Obtain DNS and IP address automatically are enabled, it doesn't get the right address (it detects the gateway as 169.254.74.222, which is also the IP address of the computer). Attempting to ping the router (which is at 192.168.1.254) doesn't work when I do this, but when I manually configure the DNS and IP address (based on the details I get from another computer), I am able to ping the router, but I'm not able to do anything more to it.
Related resources
January 20, 2011 2:17:37 AM



First, the IP address of 169.254.74.222 is a "you didn't make it" IP issued by XP.

Set things back up in your local area connection IP properties to automatic, for IP and DNS.

Click:    Start>Run>CMD>ipconfig /renew all

Right-click the network icon in the system tray, selecting "Status"
Click the Support tab.

Your IP address and gateway will show.

If it is still a 169.254.x.x address, check your cables, access the router (from one of your computers that can) and and check that the "DHCP Server Mode" drop down box has "DHCP Server" selected (in the "Configuration" section). While you are there you can verify the IP numbers the router will issue are between 192.168.1.100 and 192.168.1.199. You can manually set that computer to any number in this range that is available. Use your gateway address for the manual DNS entry.

See what happens then.
January 21, 2011 2:08:13 PM

Thanks for your advice

Once again, no improvement. I've given up and installed Ubuntu on another partition, and it works now. Kind of like using a slegehammer to crack a nut, but hey, it works :) 
!