Sign in with
Sign up | Sign in
Your question

My MSI R6790 doesn't play nice with Flash Player

Last response: in Graphics & Displays
Share
Anonymous
October 26, 2011 6:53:18 AM

Hello,

I have an issue with choppy graphics - particularly in Flash Player - on my new desktop PC. I have an MSI R6790 graphics card which I think is supposed to be better than the NVIDIA GeForce 310M I have in my notebook, and yet Flash movies that run fine on the notebook are really choppy on my new computer. I have Win 7 x64 on both computers and the Flash Player version is the same as well.

The problem occurs on all browsers I've tried so far. I've been trying to solve this issue on my own for weeks now but I haven't been able to come up with anything that worked. Here is my setup:

I use Windows 7 Ultimate x64.
My graphics driver is ATI Catalyst version 11.9.
I have DirectX 11 which came with windows - I've installed DirectX 9.0c over it but it still says 11 in dxdiag.

In Programs and Features, I have two Flash Player related items:
- Adobe Flash Player 11 ActiveX 64-bit (version 11.0.1.152)
- Adobe Flash Player 11 Plugin 64-bit (version 11.0.1.152)

I'm not sure what the next logical troubleshooting step would be for solving this issue. Should I reinstall my graphics drivers, and if yes, should I attempt to remove them first?

Or maybe I should try downgrading Flash Player and see if that helps?

Please let me know what you think. And thanks in advance!
October 26, 2011 7:00:31 AM

Well, my suggestion , don't do anything to any of the drivers. All you need to do is disable hardware for internet content in the flash settings. That'll stop the GPU from trying to accelerate the flash content. You don't need that now, not unless using a very heavily compressed flash movies or watching them on a Jumbo screen.
Anonymous
October 26, 2011 7:20:11 AM

alyoshka said:
Well, my suggestion , don't do anything to any of the drivers. All you need to do is disable hardware for internet content in the flash settings. That'll stop the GPU from trying to accelerate the flash content. You don't need that now, not unless using a very heavily compressed flash movies or watching them on a Jumbo screen.

Thanks for the suggestion! Interestingly, that didn't seem to affect playback at all. I'm beginning to wonder if this has anything to do with my graphics card and whether I've posted this thread to the wrong board. :( 

By the way, this is the Flash movie I use for benchmarking. It's kind of demanding, but my other computer seems to handle it fine (around 30 FPS) while this one chops it up (around 1 FPS). I don't think that huge a difference is justified and I guess there must be an underlying issue.

Other than Flash, the problem also seems to affect Windows in some ways. Minimizing and moving windows lags more than I'd expect. Games I've installed seem to work fine, although I do not have any modern, demanding games so I'm not entirely sure.
Related resources
October 26, 2011 7:22:26 AM

I'm lost, did that help from stopping the choppiness in the movies? or did it not help?
Anonymous
October 26, 2011 7:31:12 AM

alyoshka said:
I'm lost, did that help from stopping the choppiness in the movies? or did it not help?


Unfortunately it did not help.
October 26, 2011 7:51:53 AM

Go to Control Panel > System > Hardware(tab) > Device Manager > IDE ATA/ATAPI Controllers > Primary IDE Channel (right click and choose properties)

Click on the "Driver" tab then "Uninstall". Windows will now tell you to restart so let it - ok when the restart has finished it will reinstall the driver for the IDE controllers
Anonymous
October 26, 2011 7:52:11 AM

I've done some further testing, I realized I could be checking CPU usage in task manager during Flash playback.

On my notebook, where the Flash movie runs without issues, I've noticed that two or three out of the four CPU cores are used during playback. Each of them go up to around 40-60% usage during the test.

On my new computer, where I have the choppy playback, only one of the four cores are used, but that one skyrockets to 100% as soon as I start the movie.

So I reckon this is a processor-related issue rather than a graphics-related one. This makes sense also because I have an issue with the CPU fan getting really loud sometimes.

Is there something I could do to try to improve multi-threading in Windows 7? Or perhaps there is something else I should try?
October 26, 2011 7:55:11 AM

Quote:
I've done some further testing, I realized I could be checking CPU usage in task manager during Flash playback.

On my notebook, where the Flash movie runs without issues, I've noticed that two or three out of the four CPU cores are used during playback. Each of them go up to around 40-60% usage during the test.

On my new computer, where I have the choppy playback, only one of the four cores are used, but that one skyrockets to 100% as soon as I start the movie.

So I reckon this is a processor-related issue rather than a graphics-related one. This makes sense also because I have an issue with the CPU fan getting really loud sometimes.

Is there something I could do to try to improve multi-threading in Windows 7? Or perhaps there is something else I should try?

Go to Control Panel > System > Hardware(tab) > Device Manager > IDE ATA/ATAPI Controllers > Primary IDE Channel (right click and choose properties)

Click on the "Driver" tab then "Uninstall". Windows will now tell you to restart so let it - ok when the restart has finished it will reinstall the driver for the IDE controllers
October 26, 2011 7:57:02 AM

Look at the rigs like this:
When GPU acceleration is enabled for Flash content: The GPU will function at 80 to 100% and the CPU will only function at 10%.
When GPU acceleration is disabled for Flash Content: The CPU is going to function at 80-100% per core.

What is the configuration of the new PC:
CPU, RAM, HDD and PSU. GPU we already know off.
Anonymous
October 26, 2011 8:25:26 AM

gnomio said:
Go to Control Panel > System > Hardware(tab) > Device Manager > IDE ATA/ATAPI Controllers > Primary IDE Channel (right click and choose properties)

Click on the "Driver" tab then "Uninstall". Windows will now tell you to restart so let it - ok when the restart has finished it will reinstall the driver for the IDE controllers

Thank you for the suggestion. I've done what you said, then restarted Windows. After the restart Windows told me it has successfully reinstalled the drivers. But the problem unfortunately still remains.

alyoshka said:
Look at the rigs like this:
When GPU acceleration is enabled for Flash content: The GPU will function at 80 to 100% and the CPU will only function at 10%.
When GPU acceleration is disabled for Flash Content: The CPU is going to function at 80-100% per core.

It doesn't seem to affect CPU performance at all, even if I restart Windows after changing the setting in Flash Player. I've tried this on both computers and the results are roughly the same each time.

alyoshka said:
What is the configuration of the new PC:
CPU, RAM, HDD and PSU. GPU we already know off.

CPU: 3.4 GHz AMD Phenom II X4 965 Black Edition
RAM: 2 × 2GB 1600MHz DDR3 Kingmax
HDD: 1TB 7200RPM 16MB Hitachi HDT7210
PSU: Trust 570W Pro Dual Fan
GPU (again): MSI R6790 1GB

gnomio said:
I bet if you use Process explorer and see whats using the cpu Hardware interrupts will be the culprit
have a look
http://filehippo.com/download_process_explorer/

I'll try that and let you know what I find.

Again, I really appreciate you guys trying to walk me through this. Thanks!
Anonymous
October 26, 2011 8:56:02 AM

gnomio said:
I bet if you use Process explorer and see whats using the cpu Hardware interrupts will be the culprit
have a look
http://filehippo.com/download_process_explorer/

I've installed Process Explorer and I'm looking at it, but I'm not quite sure what to keep an eye out for. (Sorry, I'm a noob.)

Under System there is a process named Interrupts. It has a white background and it takes up about 0.5% of CPU usage (during Flash playback, as well).

Under firefox.exe there is a plugin-container.exe that doesn't use any significant amount of CPU but while I play a Flash movie goes up to 25% usage.

(If I use IE instead of Firefox, the above thing happens with iexplore.exe instead of plugin-container.exe, it goes up to 25% during playback.)
October 26, 2011 9:02:05 AM

Now that is surprising, 'cos when I disable my Hardware Acceleration for Flash, my GPU usage goes down to 1% and the CPU usage goes to 47%. With Hardware Acceleration Enabled the GPU usage goes upto 14% and CPU drops down to 31%.
Anonymous
October 26, 2011 9:34:28 AM

Yes, it kinda stumps me too. Interestingly, I have now uninstalled, reinstalled, downgraded, and tried several different versions of Flash Player and each of them had this exact same issue. Both 32-bit and 64-bit versions, on different browsers too. I guess I'll also try to take this up with Adobe support, maybe they deal with this problem with some frequency to have a predefined solution for me.
October 26, 2011 9:50:31 AM

Now, I would say, since it's all been done. Go for the complete Uninstalling of the CCC.
Download the earlier versions of CCC, like 11.4. Used driver sweeper from
http://www.guru3d.com/category/driversweeper/
to clean up ATI stuff completely.
Reboot and install 11.8 or 11.7 and try out the same flash movie.
Post a result here.
October 26, 2011 9:59:20 AM

ok do this
Go to firefox

1) Type about:config into address bar and press Enter.
2) Right click anywhere to bring up a submenu
3) Choose ‘New’ then ‘integer’
4) Paste the following into the dialogue that appears: browser.cache.memory.capacity
5) Click Ok
6) Specify amount in kb (about 80000 should be ok) in the next dialogue that appears
7) Restart Firefox
Anonymous
October 26, 2011 11:43:08 AM

gnomio said:
ok do this
Go to firefox

1) Type about:config into address bar and press Enter.
2) Right click anywhere to bring up a submenu
3) Choose ‘New’ then ‘integer’
4) Paste the following into the dialogue that appears: browser.cache.memory.capacity
5) Click Ok
6) Specify amount in kb (about 80000 should be ok) in the next dialogue that appears
7) Restart Firefox

I've done this but it didn't cure the choppyness, unfortunately.

alyoshka said:
Now, I would say, since it's all been done. Go for the complete Uninstalling of the CCC.
Download the earlier versions of CCC, like 11.4. Used driver sweeper from
http://www.guru3d.com/category/driversweeper/
to clean up ATI stuff completely.
Reboot and install 11.8 or 11.7 and try out the same flash movie.
Post a result here.

Thanks for the idea. I've uninstalled all AMD drivers and software and then used Driver Sweeper in safe mode to remove the remains. Restart, install 11.4, restart again, same results.

Then I repeated it all but this time installed 11.7, and again, the Flash movie lagged.

Right now I've tried downloading the SWF file to my hard disk and using a standalone version of Flash Player to play it but that did not help either.

I wouldn't bother this much with this if I didn't need FP for work, but I do unfortunately. :??: 
Anonymous
October 26, 2011 3:42:24 PM

I think I've pinpointed the issue by running a PassMark Performance Test. My processor seems to be running at 1/4 speed compared to other computers with the same type of CPU.

I'll try to look at BIOS and see if any values there are faulty in some way, or perhaps try using the BIOS default setting.
October 26, 2011 4:13:58 PM

You think a lot, but don't seem to be showing us how you are getting to these conclusions.
You ought to be posting the results of any tests you do here too.
Anonymous
October 26, 2011 6:01:42 PM

alyoshka said:
You think a lot, but don't seem to be showing us how you are getting to these conclusions.
You ought to be posting the results of any tests you do here too.


Sorry about that. It didn't occur to me that benchmarking could help until one of my friends mentioned it to me over the phone so that's why I tried it. The only results that seemed to be off were the CPU frequency and multiplier, which were 800MHz and ×4 instead of 3400Mhz and ×16 that other people with the same processor uploaded as their own results.

In the end, it turned out that my ASRock N68-VS3 UCC motherboard's BIOS doesn't correctly recognize the processor for some reason. When I set the multiplier to auto, the processor was functioning at 800MHz, so I had to manually set the multiplier to ×16 which solved all of the issues I was having. (It also shows how terribly I've misdiagnosed the problem at first, which is kind of embarrassing. Guess I've learned to always do a benchmark first.)

Anyways, thanks for the help guys. Everything works as it's supposed to now.
!