Sign in with
Sign up | Sign in
Your question

MacBook Pro and Motorola SBG901

Last response: in Wireless Networking
Share
April 14, 2011 12:12:26 AM

Weird problem. I have a MacBook Pro (Intel Core Duo, OS X 10.6.7) connected to Comcast internet service via a Motorola SBG901 wireless modem/router combo. Via ethernet, this modem/router is fast with download speeds at 20Mbs +. If I disconnect the ethernet and use wireless, the speed drops consistently down to 0.5 Mbs (yes, one-half Mbs). Deadly slow, and this 0.5Mbs threshold is never varies.

Now, if I access the wireless network with my HP laptop, I get a high speed connection. I have experimented endlessly with different settings in the HTML application for the modem/router, but nothing works. The diagnostics for Airport says the wireless connection is working properly. It seems like it must be a compatibility issue between the MacBook and the router, but I cannot find a solution. Has anyone else had a similar problem? -- Bruce
April 14, 2011 5:26:00 PM

Problem solved. If there is anyone else out there with this issue, go into the Motorola HTML utility and click on Wireless tab. Change the channel from "auto" to another channel. There are 12 to choose from. The auto (default) setting was designed to pick the best channel but in this configuration actually picked one of the worst. Depending on the channel, your download speeds will vary from 0.4 to 20Mbs (assuming you have a similar ISP).
m
0
l
March 11, 2012 4:29:55 PM

I tried the same approach as mentioned above but did not solve the slowness for me. I did solve the problem by going to Router (via URL) -> Firewall Tab and turning off the "IP Flood Detection" checkbox. That solved all the issues and immediately my internet is much faster in my Macbook Pro. I thought I will update this post as this is the first post which comes under Google Search and would definitely help others having a similar problem.
m
0
l
Related resources
January 24, 2013 12:03:59 PM

bharath_gct2002 said:
I tried the same approach as mentioned above but did not solve the slowness for me. I did solve the problem by going to Router (via URL) -> Firewall Tab and turning off the "IP Flood Detection" checkbox. That solved all the issues and immediately my internet is much faster in my Macbook Pro. I thought I will update this post as this is the first post which comes under Google Search and would definitely help others having a similar problem.




I too turned off "Flood Detection" and it immediately made my internet much faster on my PC. Much easier than having to do the bridge connection fix on the motorola sbg901. Now my games search for available servers much faster and HD videos load and run faster as well.
m
0
l
June 29, 2014 4:53:30 PM

I purchased in May 2014 a MacBook Pro, 8 GB RAM, 500GB SSD, 15" screen. I too was having terrible performance with my wireless. My iPad, iPhone 5, iPhone 4, and Dell laptop all could browse my wireless Comcast internet without a problem. Based one Speedtest.net my download is 53 Mbps and upload is 11 Mbps. Everything on my network screamed except for my new MacBook Pro.

I opened a trouble ticket with Apple Support. They asked me to come to the nearest Apple store to speak with their Genius experts. When I arrived, my wireless speed at the Apple store was superb. Needless to say, I knew it would be. My MacBook Pro has had excellent performance with wireless, as long as it was not my Comcast Home wireless network. Go figure. Apple reset many things on the MacBook, and asked me to go home and try it again. I knew it wouldn't make a difference, and it didn't.

FINALLY, I read this post. I have a Motorola SurfBoard SBG6580. I reset the wireless to the defaults. This made no difference. Based on bharath_gct2002 suggestion, my Comcast Internet finally works stunningly well with my MacBook. Please take note: TURN OFF: "IP FLOOD DETECTION" in the Firewall settings. Thank you, Thank you, Thank you!
m
0
l
!