Sign in with
Sign up | Sign in
Your question

Notebook internal Wi-Fi dead?

Last response: in Networking
Share
January 19, 2011 8:07:06 PM

Friends,

I am at wits end with my sister's Compaq Presario CQ50-209WM Notebook PC. She gave it to me to re-format and re-install. You know, a fresh start. All west exceptionally well: Windows Vista Premium is back on there, all drivers are up-to-date, and the laptop runs MUCH better now.

However, I cannot for the life of me get the internal Atheros AR5007 Wi-Fi adapter working and it is very important that I do since my sister uses it for her internet access. I've done everything I could think of. I used the serial number on the bottom of the laptop on Compaq's website to direct me to the drivers for the system. There were 3 different Wi-Fi adaptor driver sets from Broadcom, Intel, and Atheros.

Since I didn't know what was in this particular system, I used Sandra Pro to probe and get me the make and model: Atheros. Well, it didn't work. Although the light for the wi-fi turned from orange to blue (indication "on"), the laptop could not find any networks. There are 3 in my area including my own that is 36" away and currently transmitting a wireless signal.

Windows Network Diagnostics gives me the "There might be a problem with one or more network adapters on this computer" statement and then:

-The network adapter "Atheros AR5007 802.11b/g WiFi Adapter" is experiencing driver or hardware related issues
Click here for information

-Make sure your Internet Protocol Bindings are correct
Ensure that "Internet Protocol Version 4 (TCP/IPv4)" and "Internet Protocol Version 6 (TCP/IPv6)" are selected in the configuration for the network adapter "Wireless Network Connection"
Click here to open the adapter's configuration settings.

Both the above paragraphs are clickable. I follow both of their suggestions and all appears well with the adapter and there are no issues in the device manager contradicting this.

Sooo, I uninstall the driver and the wifi card from device manager and uninstall "Atheros Driver Installation Program" from add/remove programs and restart.

Upon entering Windows, I get the "Windows needs to install driver software for your Ethernet Controller. I plug an Ethernet cable from my router into the laptop and use the recommended setting and let Windows do so. It finds a solution for me and has me "click here to download from manufacturers website." It downloads a driver and, again, the orange wifi light turns blue meaning it is on. But still can find no wireless networks.

After hours of playing in the Networking and Sharing Center, device manager, various websites with numerous different drivers for the wifi card, I've given up. I find it hard to believe that the internal wifi died since it was working before I formatted the hard drive and started from scratch.

However, I am out of ideas and frustrated that despite years of experience, informal, and formal training (A+, Net+, MCP) I am unable to get a simple internal wifi to work.

Any, and I mean ANY suggestions/advice would be greatly appreciated.

More about : notebook internal dead

January 19, 2011 8:24:34 PM

Try another internal adapter if you have one that'll fit the slot. If not, try an external adapter. Chances are that the card is bad if your hardwire NIC is working but the wireless isn't. It could be the motherboard but that chance is slim.

m
0
l
January 19, 2011 11:00:54 PM

when you installed the drivers did you have an option to install driver ONLY?

make sure Windows is in control of the NIC and NOT the Atheros software.
m
0
l
Related resources
January 19, 2011 11:08:48 PM

After downloading the driver from the Manufacture website myself an running the installation and it not working, I've been letting Windows try to help...but still not working.

There is no option to install the driver only. I have tried other drivers (older and newer and 1 was even modded). I forced Windows to use these drivers but although they would "take," they still didn't work.
m
0
l
January 19, 2011 11:24:18 PM

you could try a ubuntu live cd, they should have the wireless drives built in, and see if you can get wireless to work in Linux.
At least you can tell if it is a hardware or software problem
m
0
l
January 20, 2011 8:25:45 PM

What I did to resolve the issue was upgrade to Windows 7. Never even visted Compaq's website for system-specific drivers...all was installed by Windows during the upgrade. Wifi works now as does everything else.

Weird.

Thanks for all the suggestions, folks!
m
0
l
!