Sign in with
Sign up | Sign in
Your question

Acer Aspire won't boot with any OS

Last response: in Motherboards
Share
February 6, 2013 9:49:13 PM

I am working on an Acer Aspire 5517 and it gets the no bootable device error with both Windows 7 and Linux installed on it. I also have tried it with 2 different hard drives and same error message. I have checked BIOS and powered it on without the battery all to no avail. Beginning to think its the motherboard but I was wondering if anyone has any ideas Ihaven't thought of. Thanks in advance. ;) 

More about : acer aspire boot

a b V Motherboard
February 7, 2013 12:41:00 AM

Let's simplify this......do you have a hard drive with a single OS on it that is connected to the first SATA port, which is listed as first priority in boot device order?

If not, can you boot to a Windows CD with a blank hard drive installed (with CD drive listed as first priority)?
m
0
l
February 7, 2013 1:32:54 AM

Yes on both. And I have done both and reinstalled Windows & then went to Linux with both being successful installs. And yet it always comes back with the same message. So I thought it was a bad hard drive. First I tested the new hard drive on another machine and it booted fine. But it came back with the same error message when I put it back in the Acer. Thanks for your help and any further suggestions.
m
0
l
Related resources
a b V Motherboard
February 7, 2013 1:36:22 AM

It helps when you share details like that, so now I know that the drives that are getting device errors on the Acer work fine elsewhere. I'm guessing this is an issue with the SATA ports on the motherboard........do you get same error no matter which port the drive is connected to?

Next guess would be that possibly your power supply is going bad, so perhaps drives aren't powered?
m
0
l
February 7, 2013 2:01:24 AM

I too was thinking the port might be bad. Because its a laptop though that means the motherboard has to be replaced. I had not, however, thought about the power supply. Let me check into that and I will let you know. If you think of anything else please let me know and thank you so much for your help.
m
0
l
a b V Motherboard
February 7, 2013 2:27:36 AM

You're welcome, I hope it gets straightened out.
m
0
l
!