Sign in with
Sign up | Sign in
Your question

5870 crossfire artifacts Battlefield 3

Last response: in Graphics & Displays
Share
October 27, 2011 1:49:31 AM

I am getting some crazy artifacts with my 5870 crossfire set up and battlefield three. I've got the 11.9 drivers and the battlefield CAP. My fps is great but the artifacts are unbearable. I will post a pic when I get back to the pc. I know I'm not really providing a lot of info, but I don't eve know what the problem is. Has anyone else had issues with Battlefield 3 and ATI crossfire setups?
October 27, 2011 5:50:22 AM

What about the other games? Does it artifacts like BF3?
Check the cards temps, make sure those cards aren't overheating...
m
0
l
October 27, 2011 2:49:36 PM

Temps are okay. I've only seen this is BF3 and Dragon Age 2, all other games are fine.. When I put BF3 in windowed mode I have no problems at all.
m
0
l
Related resources
October 27, 2011 3:25:31 PM

Strange... Surely I'm most sure this is a driver issue, try older driver like 11.6 or before, sometime the last driver is not always the best for your card...
m
0
l
October 27, 2011 4:35:37 PM

will the 11.9 CAP work with 11.6 drivers?
m
0
l
October 28, 2011 12:54:48 AM

I'm not sure whether the CAP will work or not, but just try it, it might help you to fix the problem...
m
0
l
October 28, 2011 1:05:16 AM

Is your card overclocked? Artifacts normally means A GPU running hot. Remember the sensors are only at 1 point there might be gaps in the Tim where parts of the die is overheating
m
0
l
October 28, 2011 2:45:53 AM

Maybe this helps...:

On Stuttering - Fix Available




Concerning the CrossFireX stuttering mentioned above, AMD has informed us that the 11.9 CAP 3 that was recommended to install for BF3 is actually the culprit for the stuttering behavior with CFX in this game. AMD recommends to uninstall the CAP and only install Catalyst 11.10 Preview 3 driver. If you already have the CAP installed, your best bet is to uninstall the CAP as well as the driver, and re-install just the driver with no CAP. We have tested this by removing the CAP, and on our system the stuttering with 6970 CFX is gone. We experienced no negative impact to performance in the game by removing the CAP. The gameplay experience is much better with the CAP uninstalled.






"One note – about the stuttering for CFX, the latest CAP is causing that, once you remove it, you should be fine…we’re on it and fixing it as we speak." -AMD
m
0
l
October 28, 2011 7:30:56 PM

Ive uninstalled my drivers and CAP profiles and reinstalled 11.10 v3 and CAP4 that amd just released. and it still doesnt work.

i get frames of 80-90 on high settings but 5 minutes in, my frames drop to 1-2 frames every 3 seconds or so. then eventually i crash to desktop.

im running i5-750, CF 5850's.

is there a fix out there? if not, will there be? I dont want to have to buy another video card. this is frustrating
m
0
l
October 29, 2011 12:54:22 AM

"After 5 minutes, your fps drop to 1-2 frames every 3 seconds and crash".
Really, that's a symptom of an overheating if I'm not wrong. Double check your cards temps when gaming...

Keep trying the older driver until you've found the most stable one. And make sure you get rid (clean) the previous driver before installing the new ones with driver sweeper:
http://download.cnet.com/Driver-Sweeper/3000-2094_4-752...
m
0
l
October 29, 2011 6:06:18 AM

After setting CAP4 generally hangs up at appearance of the first picture, but also without it CROSSFIRE doesn't work, FPS as well as with one card, again AMD have brought, we wait official for the driver or it is played with one card!!!

_________________________
Phenom II X6 1055T, CF 5850
m
0
l
October 30, 2011 6:42:46 PM

dlong said:
Ive uninstalled my drivers and CAP profiles and reinstalled 11.10 v3 and CAP4 that amd just released. and it still doesnt work.

i get frames of 80-90 on high settings but 5 minutes in, my frames drop to 1-2 frames every 3 seconds or so. then eventually i crash to desktop.

im running i5-750, CF 5850's.

is there a fix out there? if not, will there be? I dont want to have to buy another video card. this is frustrating



Hi dlong, i get the same problem, have you an issue?
m
0
l
October 30, 2011 6:57:35 PM

FYI: the problem occurs only in multi...
GPU temperature is OK (60° max on each GPU)

my config :
5870 CF (11.10 prev 3 + CAP 4)
i7 920 @4Ghz
m
0
l
October 30, 2011 7:21:32 PM

2x 5870s with an
i7 920 @3.2. using the 11.9 driver
55-85 FPS on Ultra setting @1920*1200

The 11.10 is suppose to be better for Cf for it but I didn't bother with it as 11.9 is working for me
m
0
l
October 30, 2011 8:44:46 PM

gnomio said:
2x 5870s with an
i7 920 @3.2. using the 11.9 driver
55-85 FPS on Ultra setting @1920*1200

The 11.10 is suppose to be better for Cf for it but I didn't bother with it as 11.9 is working for me


same thing with only 11.9 driver (Driver sweeper, Driver cleaner pro ...)

i have to play without CF.....
m
0
l
November 1, 2011 2:04:38 PM

I think AMD fixed the problem because there are updated drivers as of 11/30. Let us know if it fixes the problem I won't have the game till this weekend but have the same hardware. Crossfire 5870s with i7920.
m
0
l
November 1, 2011 4:32:59 PM

New the driver AMD Catalyst 11.10 WHQL + Application Profile - 11.9 CAP4 solve a problem, all works.
_________________________
Phenom II X6 1055T, CF 5850
m
0
l
!