Sign in with
Sign up | Sign in
Your question

I screwed something up bigtime with my wifi.

Last response: in Networking
Share
January 20, 2011 2:12:37 AM

Belkin Wireless G+ Router

- PC 1: Macbook, plugged directly into router
- PC 2: Win Vista, plugged directly into router
- PC 3: Win XP, belkin wireless card
- PC 4: Win XP, netgear wireless adapter
- PC 5: Android tablet

I could not remember the password on my router, and needed to add my new tablet. So, I reset the password on my router, for access to the wireless network. It was set at 128-bit WEP. (WPA-PSK, if I set it, does not work. The computers not within 5 feet of the router say "limited to no connectivity" and will not acquire and IP address. I once heard something about high encryption screwing with getting a good signal... No clue if that's true, though.)

I generated a hex key based on a complex password I made up. Said password came to 13 hex pairs. Entered into my android tablet the whole key, and I connect just fine. If I attempt the same thing on the windows XP machines (the other two devices that *need* to be connected wirelessly - the macbook is always docked, so it's fine if I'm plugging it directly into the router for now, but the airport doesn't work when I disconnect), I receive an error telling me that:

"The network password needs to be 40 bits or 104 bits depending on your network configuration. This can be entered as 5 or 13 ascii characters or 10 or 26 hexidecmial characters."

I have tried the whole hex password, as well as the ascii text characters, and I'm still getting the error message. I'm starting to bang my head against a wall, here as far as figuring out what I did wrong.

Alternately, I have put the MAC addresses of all 5 devices into the router, and can enable the mac address restriction - allow only certain ones to connect to the router - and turn off the encryption, to see if I can connect. I'm not comfortable enough with that idea to pull the trigger on it. I'm afraid I've left something off and my network will be unsecured, OR my network will be secured and I'll have accidentally locked myself out of my router.

Can anyone point me in the right direction?

More about : screwed bigtime wifi

Anonymous
January 20, 2011 2:36:53 AM

You are not going to like this answer but it's based on days wasted trying to connect two Macs to a D-Link wireless router. Whatever we tried we could not connect both wirelessly and concluded in the end that their was a generational difference between the two Macs and one was causing issues with the router that could not be reconciled .

If possible use WPA instead of WEP -- 13 letter passwords are impossibly complicated.

As for MAC ID filtering -- don't it doesn't provide much security and it causes problems.
m
0
l
January 20, 2011 2:49:45 AM

Please walk me through it? I'm not entirely sure what I want. The tech I'm using is pretty mixed.


Netgear Wireless-G USB 2.0 Adapter, WG111US -- says it supports 64, 128 bit WEP encryptions, and WPA-PSK and WPA2-PSK
Belkin Wireless G Desktop Card, F5D7000 -- says it supports WPA, 64 and 128 bit WEP
Belkin Wireless G Plus MIMO Router, F5D9230-4 (encryption options below)


Security Mode: WPA-PSK (no server)
Authentication: WPA-PSK // WPA2-PSK // WPA-PSK + WPA2-PSK
Encryption Technique: TKIP (default is TKIP) // AES

Pre-shared Key (PSK): (empty field)

(checkbox) Obscure PSK
m
0
l
Related resources
Anonymous
January 20, 2011 2:57:03 AM

Go for WPA-PSK TKIP in the router. But I'd start with wireless security disabled in the router until you get everything working otherwise. Also disable MAC filtering permanently. Turn off any special wireless mode in the router -- go for 802.11 g mode.

Consider whether you can conveniently connect at least one of the computers by wire -- that what we had to do in the end.
m
0
l
January 20, 2011 3:09:20 AM

The computers can not be conveniently cabled (reason for the wireless router in the first place).

I will:
- disable all but 802.11g for wireless modes
- disable all security to test that the computers can connect
- add WPA-PSK after I've verified that the computers can connect without encryption

Then I'll post back here, by tomorrow at the latest. I hope to be able to test before tomorrow night, though. Thanks for the help so far.
m
0
l
January 24, 2011 1:59:57 AM

The windows computer with the internal belkin card is now detecting and connected to my router with WPA-PSK. The computer that was using the netgear card does not. Tonight, I also went out and bought a new belkin wireless n adapter, which supports my router, as well as WPA as an encryption standard, I am still getting the "limited to no connectivity" error, however. The brand new hardware should have been able to detect and connect using WPA-PSK, shouldn't it?

The computer using these wireless usb adapters did only have XP SP2 installed. I'm currently attempting to upgrade to SP3, in case there was something introduced in SP3 that helped to support that encryption through windows networking.
m
0
l
Anonymous
January 24, 2011 2:33:18 AM

You should be alright with SP2.

You mention being unable to run a cable to the router. Could that mean the problem computer is outside the effective wireless range of the router (ignore any claims for range made by the manufacturer -- indoors it's much worse). If the signal is marginal wireless security may time-out or just not connect. So try connecting with security turned off and consider this:

Optimise your reception and avoid interference.

1) raise the router above furniture level
2) Experiment with channels (some will work better or worse depending on your environment)
3) If you can detect strong neighbouring wifi, use a channel 5 stops away from strongest.
4) Relocate cordless phone base or video sender etc.
5) Be prepared to move the computer (or at least turn it so your body is not between the router signal and the wireless a
m
0
l
January 24, 2011 3:33:26 AM

The router has a monitor in front of it (my mac) and a hallway straight into the kitchen. about 12 feet. Then it opens into the kitchen.

At 15, turn left and the tower with the wireless USB adapter is on top of the workbench. Four feet past that is the tower with the internetal belkin card (that is receiving signal). All signals coming into those two computers rate at 4-5 bars. That includes mine and about a half-dozen coming from the rest of the apartment complex.

I will turn the computer with the wireless usb adapter more towards the hallway, around the corner. And I will see if I can elevate my router 1-2 feet (I may not be able to because of how it is cabled up to my modem). If that doesn't work, I will see what I can do about the channels.

Changing the channels shouldn't force me to re-connect and re-password my wireless devices that are working, correct?
m
0
l
January 24, 2011 4:05:28 AM

I was unable to elevate my router. I have started working my way down from the highest channel (11) available, but the computer with the new belkin usb adapter is failing to connect still. Am I following the wrong steps?

- set the channel and apply it
- wait for the router to restart and rebroadcast
- go to the machine and select "repair" from the network connections menu in the taskbar

m
0
l
Anonymous
January 24, 2011 8:16:34 AM

Repair takes ages and usually doesn't work. Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.

I would still urge you to test this connection with the router wired to the computer. It's easy enough to unhook the router and physically take it to the computer where you can at least see if you can connect to the user setup screens in the router. That would help eliminate issues other than wireless.
m
0
l
January 25, 2011 12:41:56 AM

The properties were set correctly, and "obtain automatically" is enabled.

I disconnected my router from my modem, and took the router to the trouble computer. I plugged the router in, and watched it power up, then I plugged the computer into one of the router's ports. When I tried to go to the default address for my belkin router (192.168.2.1) Internet Explorer turned up an "invalid address" and did not load the configuration page for the router.

Since that did not work, I hauled the whole setup - keyboard, tower, mouse, and monitor - within reach of the cable modem, and plugged an ethernet cable into the trouble computer directly. I'm still getting a limited to no connectivity error, with the computer plugged directly into the router. Device manager shows no alerts nor errors, when looking at the network card. It's listed as a CNet PRO200WL PCI Fast Ethernet Adapter in device manager.

When I attempt to connect to the router's IP when hooked up like this, I receive the same "address is not valid" error in IE as before.
m
0
l
Anonymous
January 25, 2011 10:50:46 AM

"default address for my belkin router (192.168.2.1) "

You're sure that's correct ? If not sure check the Belkin manual or:

Start then Run in XP - (Windows key plus R in Vista and Windows 7), then type in the following, including all the spaces:- cmd /k ipconfig /all -- then press Enter and from the black form that shows up, take a note of the numeric code beside the word "gateway" -- usually something like 192.168.0.1. Type exit to close the black form.
m
0
l
January 25, 2011 10:18:15 PM

There is nothing in "gateway" despite the machine being plugged directly into the router.

Would you like me to plug either of the wireless adapters into the computer and run ipconfig again, to see if either of them can pick up a gateway?
m
0
l
Anonymous
January 26, 2011 1:30:12 AM

Check you Network Controller is installed in Control Panel, System, Hardware, Device Manager.

Which socket on the router did you use to connect to the computer.
m
0
l
January 26, 2011 7:18:42 AM

There are no errors or alerts in device manager. I have the ethernet cable running into socket 4, in the back of the router. 1 and 2 are taken up by my macbook and the vista computer.
m
0
l
January 27, 2011 3:35:27 AM

As an additional note, I have also had the computer plugged into slot 3, too, on the router, with the same results.
m
0
l
Anonymous
January 27, 2011 9:42:10 AM

So even with the computer directly connected to the modem (not the router) you get no response. I think you may have to consider if there's a problem with the network adapter on the computer. I'm sorry I cannot be more definite but you do seem to have a rather complex system, though the Macs may not be the issue as far as I can see.
m
0
l
January 27, 2011 10:27:27 PM

How can we test this, to identify or eliminate the adapter as a source of failure? And if it's just the adapter that has failed, why wouldn't the wireless USB adapters I have work? I guess I fail at understanding hardware, but I don't know what I can do to test/cure this problem now that we've hooked it up 3 different ways.
m
0
l
Anonymous
January 28, 2011 4:44:16 AM

As you can gather I'm treading water here a bit -- you're right, if the wireless doesn't work either it's probably not the ethernet adapter.
m
0
l
January 28, 2011 5:13:44 AM


Windows IP Configuration

Host Name . . . . . . . . . . . . : BILL
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : CNet PRO200WL PCI Fast Ethernet Adap
ter
Physical Address. . . . . . . . . : 00-08-A1-1D-6A-3E
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 255.255.255.255
m
0
l
January 28, 2011 11:16:57 AM

Same result. Lmited to no connectivity error displays.

Sorry I didn't reply last night. I fell asleep after the reboot.
m
0
l
January 28, 2011 1:49:48 PM

You mentioned you've enabled MAC ID filtering. It might be blocking the computer
m
0
l
January 29, 2011 4:24:04 AM

My connection to the router is fine, as far as I can tell. The NIC in the computer has 2 green lights on it when connected to my router via cable.

If I connect using either of my wireless USB adapters, I get similar results. Here's one of them. (I'll download the driver for the CNET NIC, but device manager reports no errors with the driver that is currently installed.)


Windows IP Configuration

Host Name . . . . . . . . . . . . : BILL
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : CNet PRO200WL PCI Fast Ethernet Adap
ter
Physical Address. . . . . . . . . : 00-08-A1-1D-6A-3E

Ethernet adapter Wireless Network Connection 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Belkin Surf & Share Wireless USB Ada
pter
Physical Address. . . . . . . . . : 94-44-52-AC-64-3D
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.196.161
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
m
0
l
January 29, 2011 4:25:10 AM

Edmond, I asked about MAC ID filtering. I did not turn it on, nor implement it. It should be at it's default status of disabled.
m
0
l
January 29, 2011 10:31:47 PM

Dadiggle --
There is obviously a miscommunication going on. I will bullet-point and break down what I have done and tested.

~TEST 1~
NIC (CNET Pro 200 WL) is plugged in to the router via ethernet cable, NO USB ADAPTER PLUGGED IN:

Windows IP Configuration

Host Name . . . . . . . . . . . . : BILL
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : CNet PRO200WL PCI Fast Ethernet Adap
ter
Physical Address. . . . . . . . . : 00-08-A1-1D-6A-3E
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 255.255.255.255

~TEST 2~
Wireless USB Adapter (Belkin Surf & Share) is plugged in, NO CABLE TO THE NIC CARD IS PLUGGED IN

Windows IP Configuration

Host Name . . . . . . . . . . . . : BILL
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected <-- this is supposed to do this, for this test
Description . . . . . . . . . . . : CNet PRO200WL PCI Fast Ethernet Adap
ter
Physical Address. . . . . . . . . : 00-08-A1-1D-6A-3E

Ethernet adapter Wireless Network Connection 3:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Belkin Surf & Share Wireless USB Ada
pter
Physical Address. . . . . . . . . : 94-44-52-AC-64-3D
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.196.161
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :


The wireless USB adapter has been installed.
Device Manager shows no errors or alerts regarding the wireless USB adapter.

The NIC (CNET Pro 200 WL) has been installed.
Device Manager shows no errors or alerts regarding the NIC.

Device manager reports both the NIC and USB adapter as, "The device is working properly."

The connections to my router are in place and working properly. The issue is that the computer is not able to detect the network, DESPITE the fact that all the pieces of hardware (router, NIC, wireless USB adapter) are functioning properly.

Are we both on the same page now? I failed to make myself understood last time, but I hope I have cleared it up now.
m
0
l
January 30, 2011 3:09:37 PM

~TEST 1~
- Wireless USB adapter is connected
- NIC is not plugged into the router


C:\Documents and Settings\(user)>ipconfig /release

Windows IP Configuration

No operation can be performed on Local Area Connection while it has its media di
sconnected.

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter Wireless Network Connection 3:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :

C:\Documents and Settings\(user)>ipconfig /renew

Windows IP Configuration

No operation can be performed on Local Area Connection while it has its media di
sconnected.
An error occurred while renewing interface Wireless Network Connection 3 : unabl
e to contact your DHCP server. Request has timed out.

C:\Documents and Settings\(user)>

~TEST 2~
- Wireless USB adapter is NOT connected
- NIC is plugged into the router via ethernet cable


C:\Documents and Settings\(user)>ipconfig /release

Windows IP Configuration


Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 0.0.0.0
Subnet Mask . . . . . . . . . . . : 0.0.0.0
Default Gateway . . . . . . . . . :

C:\Documents and Settings\(user)>ipconfig /renew

Windows IP Configuration

An error occurred while renewing interface Local Area Connection : unable to con
tact your DHCP server. Request has timed out.

C:\Documents and Settings\(user)>
m
0
l
January 31, 2011 12:46:44 AM

I don't think this is the problem but it is worth a look.
Go to the services. (control panel Administrative tools services)
you should see something called DHPC Client, make sure that is started.

Also lets see if you can get any connection if you set you computer as static.
Go to you network adapters and right click properties on your CNet PRO200WL PCI Fast Ethernet Adapter, go to TCP/IP and click "use th following IP address.
you want the first 3 sections the same as you routers ip, you said your router was 192.168.2.1
So make you IP 192.168.2.75 or something, the last section need to be unique to that computer. also need to be in between 1-253
the subnet mask will be 255.255.255.0 I believe
and the default gateway will be the same as you router so 192.168.2.1
and put the Preferred DNS server as 8.8.8.8 (This is one of Google's DNS servers very good for testing)
Click ok, and try to go to the internet,
And try to ping one of you other computers,
you can also try to ping your router and see if it responds.

Make sure 192.168.2.1 is in fact your router's address.
m
0
l
January 31, 2011 3:42:57 AM

I did as you said, including the exact IP address. (I have the NIC directly cabled to the router for this test.)

The network connections show that my local area connection IS connected. My uptime says 2 days and 22 hours (I haven't turned the computer off, but merely switched connections as needed for testing), and 1,449 SENT with 3 RECEIVED. The received only changed once I applied the IP changes you recommended.

I tried going to tomshardware.com on that computer, but it timed out and told me "the address is not valid."

Pinging the computer I'm on now (~.2 is the first assigned network address) I received the following message: "PING: transmit failed, error code 5."

A quick google search tells me this can be caused by an incorrect registry key, anti-virus software, or a firewall. I stopped looking after finding that many possible causes. What's the next step I should take, considering the various ways this could be a problem and be fixed.

Thank you for coming in, cats, to at least push me back into territory where it feels like we're making progress.
m
0
l
January 31, 2011 9:26:24 PM

dnder said:

A quick google search tells me this can be caused by an incorrect registry key, anti-virus software, or a firewall. I stopped looking after finding that many possible causes. What's the next step I should take, considering the various ways this could be a problem and be fixed.


Do any of the things you read online sound similar to your setup, like same anti-virus or firewall? On my quick search of it, McAfee came up alot as the cause of the problem.
m
0
l
January 31, 2011 11:12:05 PM

McAfee. I uninstalled that piece of garbage, and I have internet back on this machine. Thank you for helping me identify this.

Now I can finally go about cleaning this machine and getting some virus logs posted for malware forums. You guys are awesome.
m
0
l
January 31, 2011 11:34:19 PM

McAfee... McAfee..., McAfee... McAfee... MCAFEE AGAIN!!

Always comes preloaded on the latest laptops !!
m
0
l
January 31, 2011 11:54:02 PM

You got to love all of the crapware they preloaded on these new computers.

My first order of business when I get a new laptop is reinstall windows.

Glad you got it working again.
m
0
l
February 1, 2011 12:07:20 AM

But if you reinstall Windows, you might need to reinstall those software that might optimise battery life, such as controlling fan speed, where Windows by itself might not be capable of
m
0
l
February 1, 2011 12:54:52 AM

edmond419 said:
But if you reinstall Windows, you might need to reinstall those software that might optimise battery life, such as controlling fan speed, where Windows by itself might not be capable of


Yeah, companies are pretty good at keeping drives and extra software on there supports sight. So i can download and install what I want.
m
0
l
!