PC won't go past initial bios screen

Just had a brown out that rebooted the PC followed by a black out. There wasn't a surge so I assume everything is in wrking order but maybe not.

When starting I get the usual single beep as the bios loads and I get the initial bios boot screen, but then it sticks on that screen. I cannot enter the bios setup or display the post messages. Everything is powering up properly it seems.
4 answers Last reply
More about past initial bios screen
  1. Force POST to trigger a response by powering up your system without the boot drive connected.
  2. Was able to sort it out on the same day. It was a USB device causing a hiccup. odd that I only got the notification of a response today :/
  3. T_T said:
    Force POST to trigger a response by powering up your system without the boot drive connected.


    Hi,
    I have the same problem with a new build. How would powering up without the boot drive help?
    Thanks in advance.
  4. @allendalelad,

    If you have a display problem, the likely culprits are:
    1. GPU/chipset
    2. RAM
    3. CPU
    4. Electrical Short
    5. Display driver
    6. Mobo

    By booting without the OS drive, barring any other problems, you should see a message like "No boot device found". Seeing this message would indicate that the GPU/chipset isn't the problem. If you haven't already, take a look at our troubleshooting checklist (link in my signature), and if you still have problems, start a new thread with the results of the checklist tests.
Ask a new question

Read More

Asus BIOS Motherboards