Sign in with
Sign up | Sign in
Your question

Second monitor using DVI connection stays in powersave mode

Last response: in Graphics & Displays
Share
October 28, 2011 2:59:04 PM

I am using a Dell Lattitude 620.
have docking station and using a Belkin KVM switch through VGA connection.
Trying to set up a second monitor for same computer throught the available DVI connection on back of docking station.

When computer is turned on the DVI connected monitor will show the usual start up screen, then switches over to primary monito for log in.
As it is switching the DVI connected monitor goes into powersave mode and will not come out.

There is no problem with the monitor as I tested it with another set up.
I have tried the usual display settings but it will not save for some reason.

Any info would be greatly appreciated.
December 21, 2011 2:29:58 PM

Not sure if this helps (I know it was submitted a couple of months ago) but I just recently had a similar if not the same issue happen with my computer. I had two Dell monitors hooked up (one VGA, one DVI) and they were working for a few weeks without any issue. Then I went to lunch one day and came back to one monitor working and the other cycling through being detected (literally it would be detected then disappear over and over again). I tested everything and knew that there was nothing wrong with the video card, nothing wrong with the monitor, and nothing wrong with the cable. finally today I realized that I hadn't tried running my "primary" monitor with the DVI cable my secondary was using and vice versa. for some reason when I switched the two cables they are now both up and running.

If you are still having trouble with your monitor and you haven't tried simply switching which monitor is connected with which type of cord.


avlachos82 said:
I am using a Dell Lattitude 620.
have docking station and using a Belkin KVM switch through VGA connection.
Trying to set up a second monitor for same computer throught the available DVI connection on back of docking station.

When computer is turned on the DVI connected monitor will show the usual start up screen, then switches over to primary monito for log in.
As it is switching the DVI connected monitor goes into powersave mode and will not come out.

There is no problem with the monitor as I tested it with another set up.
I have tried the usual display settings but it will not save for some reason.

Any info would be greatly appreciated.

!