Sign in with
Sign up | Sign in
Your question

New Build - Rampage IV Extreme doesn't POST

Last response: in Motherboards
Share
February 10, 2013 3:14:37 AM

Boots up with all fans running and everything looks like it has power including:
2 HDD, DVD, 2 Geforce GTX 660's (ASUS), Corsair H80 Hydro liquid cool, NZXT Phantom 410 case.

Power supply is a Corsair Pro AX1200 Gold
Memory is 8GB single channel sticks (I've tried 1 at a time with no effect)

I've gone through the checklist - yes.
Here is what I have tried:

Removing the CPU - will not boot, but shows power on MOBO.

Removing all memory - no effect
Removing all components but CPU - no effect
Turning the front panel connectors backward

Here are the big issues: No output display, NO BEEPS (regardless of what I change)
February 10, 2013 3:53:45 AM

the AAFP HD audio cable is plugged in so I should hear something right?
m
0
l
a c 122 Ĉ ASUS
a c 481 V Motherboard
February 10, 2013 5:43:41 AM

look at the last 4 digits on the ser# lable. it tell you the bios rev of the mb. if the mb been in a wearhouse it might not have the cpu code for your cpu or the ram code needed to post.
http://www.asus.com/ROG/RAMPAGE_IV_EXTREME/#support_Dow...
use the usb flashback to put the newest bios on your mb. asus went from a .rom to a .cap file system on there mb. if your bios is older then 1404 you have to flash the bios twice to change both bios from .rom to .cap. most asus mb have fault led. is the ram or cpu fault led on. a lot of time a no post from asus mb is the mb is grounded out on the mb tray (no standoffs or the i\o shield)
or the 4/8 pin atx power for the pci bus in not plugged in. on these mb there two atx power plugs plug 1 and plug two you only need to plug in one of them.
m
0
l
February 11, 2013 12:35:44 AM

Found the issue, instructions aren't clear you have to plug in multiple power sources to the MOBO. Wasn't getting enough power.
m
0
l
!