Sign in with
Sign up | Sign in
Your question
Closed

Major problem with BF3 and 6970 crossfire

Tags:
  • Radeon
  • Battlefield
  • Graphics
Last response: in Graphics & Displays
Share
October 29, 2011 5:08:57 AM

My Rig:

Intel i7 920 @ 4.00ghz
Corsair dominator ram 8gb 1600mhz
7200rpm HDD (soon to be a ssd)
1200w Corsair ATX
Antec 1200
Motherboard = gigabyte ex58 UD5
Graphics card(s)= 6970x2

Now, I am having microstuttering in Bf3 with the latest cap4 for 11.9 and I'm using 11.10 Ref 3 but when I disable crossfire everything is pretty smooth but lower frames, I also disabled UPLS in the registry. I am going insane with this problem I have no idea how to fix it, oh and might I add I have disabled hyperthreading and HPET in the bios, nothing has helped.

Any ideas?

Thanks in advance :cry: 

More about : major problem bf3 6970 crossfire

October 29, 2011 8:04:27 AM

Lots of CF users are experiencing microstuttering.It's a driver issue,so you have to wait for a "possible" fix in future drivers.
October 29, 2011 8:33:48 AM

Meh, had lots of problems with AMD's drivers this year. Thanks for the reply though.
Related resources
October 29, 2011 9:04:58 AM

ive heard reports that hyperthreading is causing microstuddering as well, so make sure its off

edit: i should read better. you did.

crossfire really is a driver thing. i would suggest waiting until drivers fix it (and they probably will) and only using one card if its that bothersome. if you disable 4xMSAA on Ultra settings you will see over 60FPS most the time (at least i do, my card is unlocked and oc'd tho, so mileage may vary)
October 29, 2011 9:43:58 AM

Stef1_1 said:
Meh, had lots of problems with AMD's drivers this year. Thanks for the reply though.


Save yourself the trouble and go nVidia next time :p 
October 29, 2011 10:14:39 AM

The thing is, I see about 75-90fps but the stuttering is crazy. Makes it look like 30fps thus why it's microstuttering.
October 29, 2011 10:16:01 AM

neonneophyte said:
ive heard reports that hyperthreading is causing microstuddering as well, so make sure its off

edit: i should read better. you did.

crossfire really is a driver thing. i would suggest waiting until drivers fix it (and they probably will) and only using one card if its that bothersome. if you disable 4xMSAA on Ultra settings you will see over 60FPS most the time (at least i do, my card is unlocked and oc'd tho, so mileage may vary)


I disable AA and the microstutter is still there but not that noticeable. I have no idea what to do, if the upcoming driver doesn't resolve this I will have to buy a new pair of cards.
October 29, 2011 10:17:05 AM

no no, i mean, use one card and disable 4xMSAA ;)  you are going to have to wait for a new driver to fix the microstutter i think
October 29, 2011 10:20:36 AM

Same thing happened with Crysis 2 at launch. 6990s reported massive stuttering.
October 29, 2011 10:24:05 AM

just going to throw this out there, uve tried with vsync on?
October 29, 2011 10:48:16 AM

Thanks for the replies guys, ok I'll try with one card and 4xMSAA disabled, I also never completed Crysis 2 because I had insane flickering on the trees so I never botherd to complete it and yeah I've tried vsync lol.
October 29, 2011 11:26:51 AM

it might be the 1600mhz ram. some people and the reviewer at toms had problem running CF with 1600mhz ram.

try using the ram at 1333mhz.
October 29, 2011 11:33:40 AM

I don't think setting it to 1333 will help but it's worth the try.
You may also want to try setting it to X.M.P profile(w/1600MHz speed)
October 29, 2011 12:05:02 PM

I'll give it a go guys, I'll let you know in a few hours.
October 29, 2011 12:43:51 PM

@ Viktorbkk
Right now nVidia cards have much troubles with BF3
October 29, 2011 12:45:15 PM

@ OP, Force Triple Buffering in the CCC and enable V.Synch on the game
October 29, 2011 1:08:56 PM

Try enabling v-sync.
Read this. This is a investigation into it.

http://techreport.com/articles.x/21516

Micro stuttering is a problem with cf/sli. Amd and nvidia are try to fix it. The 6870s are hampered terribly by it
October 29, 2011 3:15:40 PM

I've tried Vsync and tripple buffering.....

1333Mhz doesn't work either.
October 29, 2011 5:23:23 PM

Wait for new drivers,hopefully they'll fix it
October 29, 2011 5:33:51 PM

Aye, thanks for the help though. :) 
October 29, 2011 6:01:44 PM

Did you try the drivers Amd released for BF3?
October 29, 2011 7:03:33 PM

Yup, 11.10 Rev 3. Same thing, I tried reseting my overclock aswell the optimized defaults. Same thing happens, I should be able to max this game out no problem I'm seeing people with a GTX 570 running it on ultra, like I said the most annoying thing is that I see the frames are like 65-90 but it feels like 30. It's strange everything above a 100fps though is really smooth but as soon as it dips to about 90 it just gets choppy. I have also noticed when there is alot of objects in the game (not action) it's when the choppiness happens, because this game is cpu heavy do you think my cpu may be dying?
October 29, 2011 7:22:52 PM

Well at least you don't have BSOD like others, they have had success disabling Realtek devices and turn off any Gigabyte overclock utility.
I am trying to put together a list of stats from people having issues, over 95% have Gigabyte boards. It could be caused by driver conflict with another device.
October 29, 2011 7:42:33 PM

billj214 said:
Well at least you don't have BSOD like others, they have had success disabling Realtek devices and turn off any Gigabyte overclock utility.
I am trying to put together a list of stats from people having issues, over 95% have Gigabyte boards. It could be caused by driver conflict with another device.


Jesus, I'm sort of lucky then, the only thing I get is the system hardlocking when the frostbite 2 engine has a DX error when changing Anti Aliasing in game.

Also that would be awesome to see that list.
October 29, 2011 9:55:04 PM

Ok a little update, I did a little test in game. Now I maxed everything with vsync on and moved the mouse, what happens? Microstutter yet again but....When I strafe from left to right it's perfectly smooth. I wonder if a USB mouse (GM-M8000 gigabyte mouse) is causing the major frame skip, I've tried raw mouse input on and off before even this thread was created but to no avail. Is there any suggestions to possibly find a fix to do with the mouse? I think that might be the problem.

Oh also I've tried the console commands Render.AheadLimit 1 and that still doesn't work :p 

One other thing, I've updated my mouse drivers to the latest ver also.
October 29, 2011 10:47:07 PM

Try to manually assign your mouse driver as something like Generic or Compliant and see what happens, also is there any other mouse you can use to test it?
October 29, 2011 11:05:48 PM

billj214 said:
Try to manually assign your mouse driver as something like Generic or Compliant and see what happens, also is there any other mouse you can use to test it?


I'll give it a go, also believe it or not I have no other mouse....

I just did a slight test again, no mouse lag or microstutter what so ever in a vehice in the game it's just when you're on foot, I'm starting to think it's an engine issue.
October 29, 2011 11:12:48 PM

You may want to check the AMD forums, also you could try to update DirectX manually.
We may just have to wait until they fix the drivers.
October 29, 2011 11:44:25 PM

I got the same setup as you, and I'm crashing about 20 minutes into single player. My comp has never crashed before. You think its safe to say its the game?
October 29, 2011 11:45:56 PM

Also, on with all settings on ULTRA/Vysnc off I get like 34 fps average. When I put it on HIGH, I get 70 to 80, with microstuttering. Just want to make sure that this is to be expected at this point in time...
October 30, 2011 12:08:49 AM

@billj214 I will but I just did a quick check of mouse problems with BF3 and there is quite a few, hopefully DICE will fix it in an upcoming patch.

@jon_the_faun Well BF3 for me only crashes when I change the video settings in mid game, other than that it just has major mouse lag. I'm guessing you updated your drivers to 11.10 Preview Rev 3 and installed Cap 4? Cap 3 is a no no with BF3 I get about 65-110 fps with everything on ULTRA and 2xMSAA

http://www.youtube.com/watch?v=Apwx26xCDa4

^ Example of my problem.
October 30, 2011 12:23:22 PM

I hate to bump this thread and I apologize but I found this strange I no longer get any form of stutter in windowed mode. I know crossfire gets disabled in windowed mode but I was experiencing stutter with one card and low fps (not as much) in full screen mode. Well this is just an update and hopefully it will help someone in the future.
October 31, 2011 12:45:41 AM

hey dude thanks for the post, I'm having the exact same issue as you. I thought at first it was a mouse problem too, but I think when you strafe not as much is being rendered. When you turn it has to render a lot more, more quickly.

I have 2x 5770s and I can barely stand to play. I disabled crossfire and it runs better than with 2 cards. So annoying. With 2 5770s I could reasonably run it at high on 1920x1080, but I guess I'll have to downscale until a possible fix happens.

Anyone else had any luck fixing micro stuttering related to AMD crossfire?
October 31, 2011 1:38:14 PM

gravitybear said:
hey dude thanks for the post, I'm having the exact same issue as you. I thought at first it was a mouse problem too, but I think when you strafe not as much is being rendered. When you turn it has to render a lot more, more quickly.

I have 2x 5770s and I can barely stand to play. I disabled crossfire and it runs better than with 2 cards. So annoying. With 2 5770s I could reasonably run it at high on 1920x1080, but I guess I'll have to downscale until a possible fix happens.

Anyone else had any luck fixing micro stuttering related to AMD crossfire?


http://forum.ea.com/eaforum/posts/list/7662562.page

Least we arn't alone :ange: 
October 31, 2011 1:53:37 PM

I'm going to give this a try:

http://hardforum.com/showthread.php?t=1646725


Clean uninstall of drivers and reinstall of drivers + CAP 4. Right now I'm running 11.10 preview drivers. I installed cap 3, then cap 4 on top of that with no uninstall. Maybe a full clean install of 11.10 + cap 4 will do it.

Try the same and report back!

October 31, 2011 2:33:55 PM

gravitybear said:
I'm going to give this a try:

http://hardforum.com/showthread.php?t=1646725


Clean uninstall of drivers and reinstall of drivers + CAP 4. Right now I'm running 11.10 preview drivers. I installed cap 3, then cap 4 on top of that with no uninstall. Maybe a full clean install of 11.10 + cap 4 will do it.

Try the same and report back!


Already tried it dude :)  Doesn't work. I even used ATIuninstaller in safe mode.

It's prolly a driver issue anyway, DICE/AMD should hopefully fix it.
October 31, 2011 10:23:53 PM

its fixed! AMD released a new Catalyst Application Profile today (10/31/11) that fixed my issue. Give it a shot.

Do a full uninstall of AMD catalyst and drivers by using the add/remove program function for catalyst control center. Also do a driver uninstall by going to my computer/device manager/uninstall driver.

After you do that, http://support.amd.com/us/gpudownload/Pages/index.aspx

pick your card, and the new Catalyst App Profile (CAP) is there as well (CAP 4).

GL!
November 1, 2011 1:01:06 AM

hey remember that one time I said it was fixed after like 10 minutes of testing?

Yeah I was wrong. It's still busted. The game is still only playable if I have one card going. Never again will I buy crossfire. I probably wont ever buy AMD/ATI again either. They have perpetual driver issues. Not worth messing with them any more.
November 1, 2011 1:17:41 AM

Use 11.10 pre. Don't use the caps it causes more problems than anything else
November 1, 2011 1:22:18 AM

the new whql 11.10 drivers are out. you can try them too.

first do a clean uninstall of the current installed drivers by using driversweeper. then install the new ones.

Quote:
Yeah I was wrong. It's still busted. The game is still only playable if I have one card going. Never again will I buy crossfire. I probably wont ever buy AMD/ATI again either. They have perpetual driver issues. Not worth messing with them any more.


sadly, a lot of excellent amd gpu are let down by poor drivers lots of times. i myself had a lot of issues with my new 5850 on a new build.
November 1, 2011 1:31:21 AM

I only upgrade my drivers when I run into troubles because a driver update is like a lucky packet. You never know what your going to get
November 1, 2011 5:09:14 AM

Well, worth a shot. I'll get back to you after I've uninstalled my drivers and installed these new ones. I also did a test with the cpu - gpu graph in BF3 it looks like my GPU(s) is the problem.

http://forums.electronicarts.co.uk/battlefield-3-pc/144...

Have a quick read and do a test in game.
November 1, 2011 5:10:38 AM

mayankleoboy1 said:
the new whql 11.10 drivers are out. you can try them too.

first do a clean uninstall of the current installed drivers by using driversweeper. then install the new ones.

Quote:
Yeah I was wrong. It's still busted. The game is still only playable if I have one card going. Never again will I buy crossfire. I probably wont ever buy AMD/ATI again either. They have perpetual driver issues. Not worth messing with them any more.


sadly, a lot of excellent amd gpu are let down by poor drivers lots of times. i myself had a lot of issues with my new 5850 on a new build.


Meh, driversweeper has spyware (opencandy). Any other good driver remover programs?
November 1, 2011 5:42:12 AM

Well, didn't work. Had a feeling it wouldn't here's a screenshot with everything maxed and showing the gpu cpu sync graph.

Looks like they arn't in sync.

http://imageshack.us/photo/my-images/69/bf3graph.jpg/

Suggestions?

Feels like I've wasted £530 thanks to AMD being a bunch of retards.
November 1, 2011 7:40:35 AM

look that's why i suggest to go with nividia because it has no problem with sli and look at amd crossfire i see many people having problems with CF.
especially in BF3
November 1, 2011 1:29:46 PM

pro-gamer said:
look that's why i suggest to go with nividia because it has no problem with sli and look at amd crossfire i see many people having problems with CF.
especially in BF3



yeah man I used to be an Nvidia/intel hater, only buy amd/ati. I guess ill stick with amd procs but next round ill go nvidia. havent done that in like... 8 years.
November 1, 2011 2:15:05 PM

Honestly, do you think they will ever fix this crap?

I was also thinking, maybe it's because I have a 60hz monitor at the moment. Was saving up for an alienware 120hz monitor.

Anyone else think it may be the monitor?
November 1, 2011 2:24:03 PM

not sure!
November 1, 2011 10:37:13 PM

hey dudes further update:

I disabled ULPS, which is a crossfire power saving function. It basically makes one of your cards go completely idle and not draw power if not in use (i.e. desktop, etc). however there are issues where it tries to drop into idle mode while its being used. I disabled ULPS and I have seen a huge improvement in performance, almost no stuttering at all (still a little, but completely playable, and it may even just be server lag).

How to do it:

Go to registry and disable Ulps:

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ass\{4D36E968-E325-11CE-BFC1-08002BE10318}]

and change "EnableUlps" to 0 under the 0000 and 0001 or 0003 keys.

      • 1 / 2
      • 2
      • Newest
!