Sign in with
Sign up | Sign in
Your question

Curious 1/60s frame stutter on Nvidia GTX 560ti

Last response: in Graphics & Displays
Share
October 29, 2011 3:38:40 PM

Hi everyone, this is my first post and was wondering if anyone could help me with a curious issue i have. For the last 2 months i've had an odd stutter on around 50% of my games. Games will run perfectly, vsynced at 60fps, and then after either a few seconds or minutes, they will skip or drop what looks like a single frame. They do this at the tick of a clock, each second, for around 15 seconds, then go back to being perfect. This will recur after a few minutes. I have tried basically everything. A list of what i've done below:

Updated my bios, repeatedly.
Updated my Nvidia drivers
Changed my RAM timings
Checked temps of CPU/GPU, they are well within range, i have water cooling.
Checked my hard drives, perfect.
Loaded games on different drives, problem persists.
Changed all manner of setting in the Nividia CP.

This issue occurs with games like RAGE, Mass Effect 2, Deus Ex: Human Revolution, Dragon Age: Origins, Fallout: New Vegas. It DOES NOT occur in any game that cannot keep 60fps, like The Witcher 2. Curiously, in RAGE, it goes away if i play in windowed mode or without Vsync. Is this just a symptom of Vsync that everyone experiences and maybe i'm over-sensitive to?

My specs below:

Windows 7 64-bit
Gainward Nvidia GTX 560ti "Golden Sample", at 900mhz factory overclocked
8gb GSkill Sniper RAM, 1.5v 9/9/9/24 1t
Intel Core i5 2500
Asus P8p67pro Revision B3.0 motherboard
Western Digital 1tb Caviar Black 6gb/s
650w PSU
October 29, 2011 3:46:18 PM

Masseffectman,

Not so sure what is going on. Could it be Anti-virus or something else that is autochecking? I have a similiar setup and do not experience those issues. Have you gone into the control panel and then administrative tools and then reports and looked to see if you are getting errors that pop up at the same time you are getting the stutter? I am not sure what is going on...Sorry I can't be more help.
m
0
l
October 29, 2011 4:06:05 PM

chiptouz said:
Masseffectman,

Not so sure what is going on. Could it be Anti-virus or something else that is autochecking? I have a similiar setup and do not experience those issues. Have you gone into the control panel and then administrative tools and then reports and looked to see if you are getting errors that pop up at the same time you are getting the stutter? I am not sure what is going on...Sorry I can't be more help.


Hi, thanks for the reply. I've looked into the event viewer, there are no errors or strange programs that happen/startup during the intermittent stutter. I have also uninstalled my AV and disabled Windows firewall and defender. I also have re-started Windows with only basic programs running, same issue. I find it strange that the single frame drop is so rhythmic, occurring once per second exactly, as i don't have any programs polling anything that could cause that.
m
0
l
Related resources
October 29, 2011 10:55:27 PM

I recorded my stutter using Afterburner today, and , if i had to present a visual picture of the frames, then each second (at 60fps) looks like this:

1frame 2frame 3frame 4frame 5frame 6frame 7frame 8frame 9frame 10frame
11frame 12frame 13frame 14frame 15frame 16frame 17frame 18frame 19frame 20frame
21frame 22frame 23frame 24frame 25frame 26frame 27frame 28frame 29frame 30frame
31frame 32frame 33frame 34frame 35frame 36frame 37frame 38frame 39frame 40frame
41frame 42frame 43frame 44frame 45frame 46frame 47frame 48frame 49frame 50frame
51frame 52frame 53frame 54frame 55frame 56frame 57frame 58frame 59frame 59frame

Notice how the 60th frame is the same as the 59th, causing a small, yet annoying stutter. This happens on the 60th frame EXACTLY and is repeated for around 10 to 20 seconds, then goes away fully before returning minutes later.
m
0
l
a b U Graphics card
October 30, 2011 12:53:17 AM

V-sync has the problem cutting the frame rates in half at times. Try to enable tripple buffering.

But if I can make another suggestion to rule out 3rd party services do a clean boot before testing it with different options.

Just go to msconfig then the services tab tick hide all ms services and tick disable all. Then just tick the services related to your gpu. Disable all your start up items except the ones related to your gpu then reboot.
m
0
l
a c 595 U Graphics card
a c 388 Î Nvidia
October 30, 2011 1:06:53 AM

The other option is to turn off VSync. There's really no reason to use it unless you are really getting bad screen tearing. Triple buffering only works with OpenGL games, i.e. Half-Life 1 and anything from Id, like Rage.
m
0
l
October 30, 2011 9:03:10 AM

gnomio said:
V-sync has the problem cutting the frame rates in half at times. Try to enable tripple buffering.

But if I can make another suggestion to rule out 3rd party services do a clean boot before testing it with different options.

Just go to msconfig then the services tab tick hide all ms services and tick disable all. Then just tick the services related to your gpu. Disable all your start up items except the ones related to your gpu then reboot.


I had already done a clean boot, no change. Triple buffering works on RAGE (OpenGL), and doesn't on all other games like Mass Effect 2, due to them being DX9, but it doesn't matter as it makes no difference anyway. Thanks though.
m
0
l
October 30, 2011 9:07:05 AM

17seconds said:
The other option is to turn off VSync. There's really no reason to use it unless you are really getting bad screen tearing. Triple buffering only works with OpenGL games, i.e. Half-Life 1 and anything from Id, like Rage.


There's a huge reason to use Vsync, i have no idea why people say it's fine off. RAGE has massive screen tearing straight across the middle of the screen with it off, Mass Effect 2 has awful tearing during cutscenes, Deus Ex: Human Revolution has a judder as the frame-rate hops between 70 and 120 without Vsync. Turning off Vsync is not an option for me, at least. Thanks.
m
0
l
a b U Graphics card
October 30, 2011 9:10:32 AM

masseffectman said:
I had already done a clean boot, no change. Triple buffering works on RAGE (OpenGL), and doesn't on all other games like Mass Effect 2, due to them being DX9, but it doesn't matter as it makes no difference anyway. Thanks though.

you can force tripple buffering on in any dx game. Do you have rivatuner or dxtweaker. With either of those apps you can switch tripple buffering on for any game dx or not.

Other option is to use nhancer and fine tune your profiles for the games you played. If you haven't used it yet give it a try you will be amazed all the stuff nvidia is hiding from the end user in their drivers with detail explanation of every settings included so you have a idea what your tweaking
m
0
l
a b U Graphics card
October 30, 2011 9:17:20 AM

masseffectman said:
There's a huge reason to use Vsync, i have no idea why people say it's fine off. RAGE has massive screen tearing straight across the middle of the screen with it off, Mass Effect 2 has awful tearing during cutscenes, Deus Ex: Human Revolution has a judder as the frame-rate hops between 70 and 120 without Vsync. Turning off Vsync is not an option for me, at least. Thanks.

v-sync is to stop your LCD/gpu going out of sync. What happens if your gpu waits for the signal from your LCD it will put the frames on a buffer when it runs out of buffers it will overwrite over the completed frames which in the end shows up as tearing on our screens. The tear effect is cause it only change the pixels that needs to be changed.
Now you can disable v-sync and enable tripple buffering which means the gpu has a extra buffer to put the images while it waits for the signal from the LCD. So it won't overwrite the completed frames because it have that extra storage. So use one or the other. I suggest you disable v-sync and try tripple buffering
m
0
l
October 30, 2011 10:32:30 AM

I have been at this issue for two months, trust me, i have put triple buffering on in RAGE, like i said, it made no difference. I have also switched off Vsync in Deus Ex: Human Revolution, and enabled Triple buffering from within that game, it reduced minor regular stuttering, but not the rhythmic stutter that my thread is all about.

As previously mentioned, most of my games look like a tearing nightmare with Vsync off, triple buffering does not clear up tearing, it really just makes sure that your framerate can hop from 30-45-60 if you have Vsync enabled. My point is, with Vsync enabled, and triple buffering on or off, i should't get this odd stutter which seems timed.
m
0
l
a c 595 U Graphics card
a c 388 Î Nvidia
October 30, 2011 3:56:40 PM

What drivers are you using?
m
0
l
a b U Graphics card
October 30, 2011 4:02:11 PM

masseffectman said:
I have been at this issue for two months, trust me, i have put triple buffering on in RAGE, like i said, it made no difference. I have also switched off Vsync in Deus Ex: Human Revolution, and enabled Triple buffering from within that game, it reduced minor regular stuttering, but not the rhythmic stutter that my thread is all about.

As previously mentioned, most of my games look like a tearing nightmare with Vsync off, triple buffering does not clear up tearing, it really just makes sure that your framerate can hop from 30-45-60 if you have Vsync enabled. My point is, with Vsync enabled, and triple buffering on or off, i should't get this odd stutter which seems timed.

it adds a extra buffer which gives your gpu more space to place the buffers. Otherwise it will overwrite the others with the buffers its using by default.
You can read this
http://techreport.com/articles.x/21516

Its a very good article
m
0
l
October 31, 2011 8:42:37 PM

17seconds said:
What drivers are you using?


At the moment i'm using the latest 285.62 drivers, but have rolled back to every driver available for the GTX 500 series since my cards release in January this year, no help. I do a clean install, using the method laid out in the Nvidia forums, uninstall/driversweeper in safe mode/etc.
m
0
l
October 31, 2011 8:45:31 PM

gnomio said:
it adds a extra buffer which gives your gpu more space to place the buffers. Otherwise it will overwrite the others with the buffers its using by default.
You can read this
http://techreport.com/articles.x/21516

Its a very good article


Interesting read, but it really is mostly focussing on SLI setups. The games RAGE and Deus Ex Human Revolution have Triple buffering options in-game, they make no difference to my particular stutter at all. I am thinking that this is an issue pertaining to GTX 560ti cards and all the Nvidia drivers since the models release.
m
0
l
!