No display with new CPU

I just got my new amd fx 4170 cpu and install it the power turns on but no display. I made sure everything was in right and it was so then i take that one out and then try to see if my old cpu would work and it works just fine. So then I just tried once more still no display but the fans moving like it is working. Im thinking it may be a bad cpu but let me hear from you guys.
4 answers Last reply
More about display
  1. sallad116 said:
    I just got my new amd fx 4170 cpu and install it the power turns on but no display. I made sure everything was in right and it was so then i take that one out and then try to see if my old cpu would work and it works just fine. So then I just tried once more still no display but the fans moving like it is working. Im thinking it may be a bad cpu but let me hear from you guys.


    Could you give us a bit more info on the system ?
    and what processsor did you go from ?
  2. teleaddicted said:
    Could you give us a bit more info on the system ?
    and what processsor did you go from ?

    Yeah sorry about
    Motherboard= MSI 970A-G45
    Processor= AMd athlon II x4 640
    power supply= 750 watt
    Graphics card= GTX 480

    If theres more you need then i will be glad to show more specs but i just dont understand why the cpu doesnt work when my old one does
  3. What is the mfg of your PSU?
  4. If you have an older version of the board you will need to update the bios.
    Put the old chip back in and use the MSI live update to update the bios if necessary.
Ask a new question

Read More

CPUs Displays