Z77 extreme4 and weird mouse problem

I recently upgraded from a very old core 2 duo based setup to an ASRock Z77 Extreme4 with a Core i5 3570k with two ATI 6770s . I have a Logitech MX518 mouse and have noticed in certain applications I'm unable to click or only click on certain UI elements. Usually I'll be able to click on something after hitting CRTL ALt DEL and opening the task manager. The applications that I consistently have these problems with are Deluge, VLC and the installer for Diablo3. Fortunately I don't have problems clicking in any of the games I've been playing recently (Borderlands 2, Far Cry 3, Dead Island and Skyrim).

I was originally running Windows 8 but rebuilt my machine with Windows 7 thinking that 8 was the problem. Turns out that wasn't the problem as it's still happening in Windows 7. Here's what I've tried so far:

+ Turn off Crossfire
+ Install different catalyst drivers (currently I'm using 13.2 beta since changing didn't help)
+ Install all of the latest software that is available on ASRock's website
+ Use different USB ports
+ Use a different mouse
+ Turn off Virtu MVP in combinations with CrossFire on or off and different ATI drivers
+ Run MemTest86+ on all combinations of different RAM modules in different slots

Any ideas are greatly appreciated!
2 answers Last reply
More about extreme4 weird mouse problem
  1. Can you try a PS/2 mouse?
  2. That's a good call. Now I just have to locate one :)
Ask a new question

Read More

ASRock Motherboards