Sign in with
Sign up | Sign in
Your question
Solved

5870 and 5970 trifire

Last response: in Graphics & Displays
Share
October 31, 2011 2:55:06 AM

ok, so i had 2 5870's in crossfire for about a year now, never any trouble then one card went bad(out for rma right now)while waiting for this card i came accross a 5970 for a great deal.so i got the 5970 installed it in slot one with my 5870 in slot 2, everything seemed fine till i rebooted,noe i would get BSOD evertime i tried to play a game (Black ops) or tried to run a test (unigine heaven), so i swapped them out, put the 5870 in slot one and 5970 in slot 2, seemed to sork but now my screen flashes like crazy when i have my game in fullscreen mode, also i have gotten a few BSOD also. in bsod it says the file has a problem or has stopped working, ATIKMPAG.SYS, i do a search for this file and i can't find it on my pc.

here is my setup

windows 7 64 bit
msi x58 pro-e motherboard
i-970 intel proccesser
6x2 12 gig 1600 mhz memory
one xfx 5870 runing 850 x 1250
one saphire HD5970 OC running 735 x 1010mhz
240 gb kingston ssd drive on a pci-e sata 3 port
3 650 gb hard cavier black in raid
water cooling
xspc x20 x750 res/pump combo , 369 rad and 120 rad for the 2 vid cards
xspc x20 x200 res/pump combo , 240 rad for cpu
coolmax 950 ps green power.


i believe that everything, aslo i did try using driver sweeper to remove and reinstall the drivers, i also reformated and started from scratch.
any help would be great, thank you in advance,

More about : 5870 5970 trifire

October 31, 2011 3:12:19 AM

have you tried just the 5970 ?
m
0
l
October 31, 2011 3:18:30 AM

well i was thinking about it but would like to have the trifire if i can find a solution.
m
0
l
Related resources
October 31, 2011 3:19:37 AM

^+1 if that has problems most likely a bad card! Trifire will not work if the card is bad.
m
0
l
October 31, 2011 3:21:59 AM

no, both these cards run perfectly alone.
m
0
l
October 31, 2011 3:25:33 AM

The HD5870 down clocked to match the 5970 or the 5970 overclocked to match the 5870?
m
0
l
October 31, 2011 3:28:22 AM

Also ...coolmax not sure if that's what I would run trifire with.
Could you maybe just test the 5970 by running it through 3dmark or somethng ?
m
0
l
October 31, 2011 3:31:07 AM

I didn't do either. From what i saw on other treads you don't need to.
m
0
l
October 31, 2011 3:34:42 AM

If you have issues doing a simple benmark with just the 5970 maybe it has some issues. Although I will agree this shouldn't be needed but if you want to see if the issue might be with the 5970 it is what I would do.
m
0
l
October 31, 2011 3:37:17 AM

spentshells said:
Also ...coolmax not sure if that's what I would run trifire with.
Could you maybe just test the 5970 by running it through 3dmark or somethng ?

Well like i said its water cooler so that would mean changing my setup which i plan to do tommorrow. Also the coolmax id great never any trouble.
m
0
l
October 31, 2011 3:39:36 AM

spentshells said:
If you have issues doing a simple benmark with just the 5970 maybe it has some issues. Although I will agree this shouldn't be needed but if you want to see if the issue might be with the 5970 it is what I would do.

No issues when run alone with either card. I ran heaven on both and stress test. also.
m
0
l

Best solution

October 31, 2011 3:47:49 AM

Like spentshells said then it might be a power issue, fine with 2 x HD5870 but now when adding a more powerful card it might be getting to the limit of the PSU. How many amps does it have on the combined +12 volts?
Never mind found the answer myself http://www.jonnyguru.com/modules.php?name=NDReviews&op=...
The "0" score for performance is most likely your issue!
Share
October 31, 2011 4:12:15 PM

That review does not load it to the max or stick it in a hot box let alone test the safeties or measure ripple and so on. There is only few sites that do proper PSU reviews jonnyguru and hardwaresecrets to name a couple are amongst those.
m
0
l
October 31, 2011 4:15:00 PM

well right now i have it working fine,not sure how or why, my biggest problem at the moment is flickering in black ops in full screen mode.

not to say the next reboot won't mess this up again.
m
0
l
October 31, 2011 4:17:47 PM

As stated in the review by jonny you are probably dealing with lack of power and power regulation since it would make a decent 600watt unit but is trying to supply more.
m
0
l
October 31, 2011 4:28:48 PM

i will look into a new power supply ,i do believe you are right,i just want to be sure and if there are any other options, like motherboard software ect. i would want to just check it all.

also what size psu would you recommend?
m
0
l
October 31, 2011 4:31:01 PM

Best answer selected by kblgy.
m
0
l
October 31, 2011 5:25:44 PM

It has gotten great reviews and is quality
m
0
l
October 31, 2011 5:31:59 PM

thx
m
0
l
!