Sign in with
Sign up | Sign in
Your question

Asus maximus iv extreme + kingston hyper x predator

Last response: in Motherboards
Share
February 14, 2013 5:35:41 PM

Hello, My motherboard's support list for ram does not include this specific type of memory (KHX21C11T2K2). However when i installed the memory the motherboard's debug screen indicates error no55 and then in turns off after 4 beeps. (The pc is brand new)
February 14, 2013 5:47:48 PM

Have you tried turning on XMP?
February 14, 2013 5:49:32 PM

sorry but what do you mean by XMP? do you think that the memory might be the problem that the pc turns off? cause is kinda weird...
Related resources
a c 118 Ĉ ASUS
a c 472 V Motherboard
a c 89 } Memory
February 14, 2013 6:12:17 PM

make sure the dimms have clicked in there slots. on these mb there two banks per the mb guild a0 and a1. the banks are one red and one black dimm. make sure the ram in the same bank. also look at the end of the ser# on the mb. that tell you the bios rev of your mb. most times these mb bios are out of date. if your is way out of date 0802 or under. then the mb may be misisng the cpu and ram code to post. I would look at your mb see the bios# and then see if you can download the newest bios and use the usb flash back port and update your bios.
February 14, 2013 6:20:31 PM

yes i read that most probably is the BIOS... XMP is not on btw. I just literally turned the pc on for first time and after installing everything and i get the 4 beeps (along with the error code) and it goes off. i found the Serial No. from the box and it ends 1098...


PS. i have tried slots a0 and a1 ... i even tried running it only with one dimm. the dimms are in correct position. I tried both in red slots and black slots.

Please help me out cause i wanna turn it on and this is getting really frustrating..
February 14, 2013 6:29:40 PM

btw i've just checked previous BIOS from the asus website and it doesnt seem to have any BIOS ending in 98.


BIOS REV is 3.0
a c 118 Ĉ ASUS
a c 472 V Motherboard
a c 89 } Memory
February 15, 2013 5:33:23 AM

i would download the last bios update for your mb and flash the bios using the usb flashback port.
!