Sign in with
Sign up | Sign in
Your question

Motherboard dead? - All Ports Dead, Front Panel LikeWise

Last response: in Motherboards
Share
February 14, 2013 9:20:14 PM

Hellow. I have a ASUS M4A785TD-M EVO AM3 AMD 785G HDMI Micro ATX AMD Motherboard. It's had some front panel USB moodiness before, but it has been otherwise fine for two years. I built it with a OCZ Fatal1ty 550W Modular Gaming Power Supply.

Yesterday my friend's eighteen month old pulled off the top of the case, and with it, the power button. It is a COOLER MASTER HAF 932 Advanced RC-932-KKN5-GP Black Steel ATX Full Tower case. The top component was loose. I'm just happy she didn't shocked herself, but after that

no power at all. The mobo's green light was on but it wasn't going to do my work for me. I checked all of the pins in the panel and realized the powersw (red & white) cable was detached from the actual power button. I tried crossing the wires, shorting the switch with a flathead and replacing the cable itself with another powersw cable with its own power switch. Nada.

I finally got the power back by using the green and black ATX wire trick but all of the ports are dead. No USB, no graphic card, no ethernet, nada. I originally double checked my power supply by swapping it out with another power supply. I had the exact same result.

I think my motherboard is toast. Am I right? I am completely noob at this stuff so I don't want to just assume if there is something painfully obvious I am missing. ATX cable is plugged in, swapped out ram, ran down the normal checklists....

Any help is appreciated.

I finally got the pan
a b Ĉ ASUS
a c 109 V Motherboard
February 14, 2013 10:18:08 PM

I would try breadboarding.
m
0
l
!