Sign in with
Sign up | Sign in
Your question

CCC problem

Tags:
  • Graphics Cards
  • Catalyst
  • Graphics
Last response: in Graphics & Displays
Share
November 1, 2011 4:36:52 AM

Good day!

I've been using Catalyst 11.1a for quite some time now and everything worked perfectly. Then I upgrade to 11.9 for BF3 but during the installation I get an error...

Quote:
Microsoft Visual C++ 2010 RedistributableFinal
Status: Fail
Version of Item: 10.0.30319
Size: 9 Mbytes


Got no choice to continue and it seems that it installs the Catalyst but whenever I try to access it, nothing happens. It will show that it's trying to open it but then will just stop (I'm accessing it through its root folder as the option from the right click on desktop is not showing). I already tried going back to 11.1a and other versions, everything is just the same.

I already tried uninstalling through the Catalyst uninstaller, manual uninstalling and Driver sweeper then used CCleaner for the registry, still no luck.

BTW, I'm using a Sapphire 6850, Windows 7 32 bit.

Any idea what I should do?

AMD is not responding to my query so I had to post here for help. Any suggestion would be appreciated. Thanks!

More about : ccc problem

November 1, 2011 6:43:11 AM

Thanks for the reply. Yeah, I did update the C++ and tried uninstallalling in safe mode and used 11.10 as I just saw it released, same thing. I get the AMD Vision Engine Control Centre now when I do a right click on my desktop but still not opening.

BTW, it's running in the task manager.
m
0
l
November 1, 2011 7:55:01 AM

I know the Vision Control Center. I just mentioned it earlier to let you guys know that it's already coming up on my desktop because before it wasn't. I don't know if that would mean something.

So... I now allowed CCC in Firewall and my Avira Antivirus. Same thing, nothing comes up.

For the IGP, it's HD 4250. Not sure if that would help.
m
0
l
Related resources
November 1, 2011 11:29:22 AM

Reformatting is the last thing I would like to try but if that's the only way to fix it, I guess I have no choice.
m
0
l
a b U Graphics card
November 1, 2011 11:49:57 AM

I had problem with CCC when i installed latest drivers few weeks ago.
The problem was that driver installer could not delete old ati folders.
C:\Program Files\ATI
C:\Program Files\ATI Technologies
*(C:\Program Files (x86)\ATI
*(C:\Program Files (x86)\ATI Technologies if you have 64bit windows as well)
the files wore locked by the windows and i was unable to delete them.
Thou i was able to rename them.
Also was able to delete using linux boot cd, in case you can't rename them
so

Uninstall Ati drivers
delete or rename the folders (mentioned above ^)
install again
(delete old renamed folders)

after this everything works perfect for me now
m
0
l
November 1, 2011 11:59:33 AM

Well, I already did a manual uninstallation. Basically I deleted those folders for ATI and also deleted the entry in the regedit. Same result. Thanks for the info though.
m
0
l
a b U Graphics card
November 1, 2011 1:25:39 PM

Install the latest .net framework as well as any updates for it.

Have you tried that?
m
0
l
a b U Graphics card
November 1, 2011 2:00:30 PM

The processes for AMD vision called CCC.exe and MOM.exe i had internet security suit block them one time, because mom sounded like something fake lol

http://www.microsoft.com/net as well
m
0
l
November 1, 2011 3:14:55 PM

@Chainzsaw
Downloading it now. Hope it will work.

@duxducis
Yep. I did include CCC.exe and MOM.exe in the exception list. Same thing.

@greghome
Will try the IGP by tomorrow. I'll let you know the result. For now, I'm going to try the updated version of Frameworks.
m
0
l
a b U Graphics card
November 1, 2011 3:47:10 PM

I've had this problem before - it's because you didn't uninstall the old drivers correctly before updating to the new ones. I had to do a system restore, but it works now that I did the uninstall/install correctly.
m
0
l
November 1, 2011 3:58:50 PM

@jessterman21
I might do that system restore tomorrow. A friend just told me to try and do it.


Version 4 of frameworks doesn't work.
m
0
l
a b U Graphics card
November 1, 2011 4:02:57 PM

If system restore doesn't work, try doing a repair of your OS installation.
m
0
l
November 1, 2011 4:07:59 PM

Go to windows Uninstall and choose repair for whatever MS C++ is failing.
Also, you could use something like DriverSweeper in safemode to completely remove CCC remnants after you used the uninstall. Then use CCleaner before installing the updated CCC.
m
0
l
November 1, 2011 5:26:49 PM

^
First, I don't get the Microsoft Visual C++ 2010 RedistributableFinal 10.0.30319 which is the one that is failing. Seconnd, even if I get that, doesn't it only give me an option to uninstall and not repair, right?

@Chainzsaw
Will do.

Thanks for the help guys. I'll give some info tomorrow.
m
0
l
November 3, 2011 8:01:54 AM

I emailed AMD a few days ago and got a reply now.

Spoiler
Make sure your antivirus software is not running in the background.

Install any updates from the motherboard manufacturer for the motherboard BIOS or chipset drivers that are available that you have not installed.

Disconnect any USB devices you do not need to run the computer to eliminate any conflicts on installation.

Please uninstall Microsoft C++ redistributable and then reboot your system.

Reinstall Microsoft .net Framework from the Microsoft website.

Remove all ATI through programs and features in the Control Panel using the
Catalyst Install Manager (CIM). Reboot the system in safe mode and do the
following:

· Delete all ATI folders in C:\programs files and C:\programs files (x86)
· Go to C:\Windows\assembly and sort by "Public Key Token". Locate the following Public Key Token "90ba9c70f846762e" that is associated with ATI. Usually only 2 entries.
· Delete the 2 entries.
Note: the entries should be deleted in safe mode since regular mode may result in a permissions error.
The 2 entries only show up in systems affected by this issue. This means that searching for the 2 entries on systems where CCC loads, the entries are not there.

Then run the Catalyst installation again.

Install the Microsoft Visual C++ 2005 SP1 redistributable patch.


I removed all Microsoft C++ redistributable as they did not mention which one to remove (currently installing them back now).
One noticeable thing to mention is the icon for CCC is coming up in my notification area but CCC is still not opening. I'm just waiting for all the installation to finish so I can check if this will work.


I haven't tried a system restore, a repair of your OS installation or try running with IGP only.

This is really making me crazy!
m
0
l
February 8, 2012 9:38:40 AM

So any luck? IM SO SICK OF THIS HAPPENING EVERY TIME I UPDATE MY DRIVERS

It was working fine for me for a couple months because I never updated my vision control center when updating my drivers, the other day my eyes were hurting to I used VCC to lower brightness on my monitors, then today when I go to put them back on normal IT WONT @#$%ING OPEN AGAIN.

I am ABSOLUTELY FED UP WITH THIS SOFTWARE. This has happened at least 10 times and every time the fix is different.

GET IT TOGETHER AMD. REWRITE YOUR HORRIBLE $#%^ @#$% CONTROL CENTER SOFTWARE.
m
0
l
a b U Graphics card
February 23, 2012 2:39:20 PM

as i said before and still I have same problem if update drivers i can't access AMD control panel unless i manually delete the old folders.
for me its not problem with AMD but i need to reinstall windows, thou if i fallow those steps everything works
m
0
l
February 23, 2012 3:58:17 PM

Well, for me nothing really works. Not going to reinstall windows for this, but maybe in the future.
m
0
l
!