Sign in with
Sign up | Sign in
Your question

No GPU Power (GPU fans not working) while...

Tags:
  • Homebuilt
  • Power
  • Systems
Last response: in Systems
Share
December 30, 2011 12:18:37 AM

CPU fan and Mobo LED's stay lit with their appropriate colors.

Recently i bought new parts to build my own computer as a first timer and everything seemed to be going smoothly until the power up.I plugged my PSU in as the last step, flipped the PSU switch and hit the power button on my motherboard and got power on all my case fans and the leds on my mobo light up. The problem that im having is that my video card seems to be receiving no power, none of the fans on the GPU spin and im receiving no signal to my monitor. To boot, im not receiving any motherboard Q-code sounds.

What did i do wrong? Could i have gotten a defective GPU?

Comp. Parts:

GIGABYTE GV-R695OC-1GD Radeon HD 6950 1GB 256-bit GDDR5 PCI Express 2.1 x16
G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666)
ASUS P8P67 DELUXE (REV 3.0) LGA 1155 Intel P67 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Acer G235HAbd 23'' 5ms 1920x1080 WideScreen LCD monitor 300 cd/m2 1000:1
Intel Core i5-2500 Sandy Bridge 3.3GHz (3.7GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 2000 BX80623I52500
Rosewill CHALLENGER Black Gaming ATX Mid Tower Computer Case
Corsair Enthusiast 750w

More about : gpu power gpu fans working

December 30, 2011 12:20:52 AM

As a side note, when i hit the power button on my computer, it turns on for a second or 2 then shuts off, then it turns on by itself and stays on untill i d/c power.
m
0
l
December 30, 2011 1:34:23 AM

Check all the power connections in your system, you could have something loose or not plugged in.
m
0
l
!