Graphics card no display no beeps with power cable i get beeps

Hello,
Tricky one here. I have plugged in HD5850 into PCIe with 6 Pin power cables attached. I get no beeps no screen. Monitor stays on amber!If I disconnect both 6 pin power connectors I get a beep from the motherboard upon switching on but no display. Any ideas or are they fried??? Thanks people
16 answers Last reply
More about graphics card display beeps power cable beeps
  1. PSU is 800W
  2. Hmm Seems Like You Don't Have Enough Power Is Your 800W A Cheap Nasty Make?
  3. Atrix 800w High Efficiency Quad 12v Power Supply
  4. Hmmm It Should Work Then Have You Got An Extra Card You Can Test?
  5. Yeah i've got a Radeon X1900XT in at the moment which was my old card. I knew the 5850 was faulty when I bought it, thought the Oven Trick might solve it but no joy! Just a bit disheartened that it doesn't display. Any ideas? Thanks for the correspondence by the way
  6. 1900xt; old school... i remember when that was a great card.
  7. Yeah it does the job, so any ideas buddy?
  8. if the 1900XT works and the 5850 doesnt... then im sorry you might be SOL unless you can fix the actual card. you must have gotten one hell of a deal on the 5850 if you knowingly bought a fried card
  9. But why without the 6 pin power connectors do I get a beep from the motherboard as if its going into post??
    Thats what I dont get
  10. Does the motherboard have onboard video?
  11. im thinking OP would be having this issue with all cards if it was a problem with his onboard video, no?
  12. What I am getting at is with the power unhooked from the discrete card, the board may be defaulting to onboard video, thus giving the single "all is okay" beep.
  13. jitpublisher said:
    What I am getting at is with the power unhooked from the discrete card, the board may be defaulting to onboard video, thus giving the single "all is okay" beep.

    Makes perfect sense
  14. Thanks guys, After baking it again......... now i'm getting the fan on full speed with both PCIe 6 pins in place. Noticed oxidisation around the internal connecting pins from the PCIe Power pins just at the connection to the Board. Could this be the problem?
  15. its not detected after checking through onboard vga. Will reballing help?
  16. Motherboard is now giving me 2 beeps followed by 8 telling me that its a graphics card problem. Well I never!!!!!!!!!!!!! Anyways im thinking about reballing anyone willing to give me a second opinion?
Ask a new question

Read More

Radeon Graphics Cards Power Cable Graphics Displays