Sign in with
Sign up | Sign in
Your question

G1 Sniper 3 still has problems after RMA return

Last response: in Motherboards
Share
February 19, 2013 2:01:32 AM

Okay.. So i seriously don't understand this. I have a Gigabyte G1 Sniper 3 Motherboard and just got myself a second GTX 670 FTW (2GB) Edition and everytime i try to play Skyrim the screen goes black and forces a restart. I RMA'ed this board because i was pointing fingers at my PCI Express 3rd Slot (There's 4 on this board).

It worked fine with the first and second slots but the manual says to do the first and third slot since they're both 16x. But with what i did recently with my cards, i can no longer use the first and second slots because i have 2 Kuhler 620's mounted on both of my cards so i need space between them and HAVE to use that darn 3rd Slot again. Gigabyte returned this board to me doing the exact SAME thing i sent it in for. Now the only thing left to do is do a swap for a new one. The thing is, i'm afraid of the new board doing the same thing to. No way it's other hardware causing this. I continue to blame the board and that third slot. Is there something i'm missing here to get around this problem? Please help. :( 
February 19, 2013 2:57:25 AM

I've even tried to run a Graphics Card by itself on the third PCI Express slot, and it still crashes when attempting to run Furmark, or a game like Skyrim.
m
0
l
February 19, 2013 2:42:01 PM

Hello? If nobody can help here, then i'll make another board in the Gigabyte forum and try my luck there.
m
0
l
!