Sign in with
Sign up | Sign in
Your question

Why won't CrossfireX enable on 2x 1GB 6870s?

Last response: in Graphics & Displays
Share
Anonymous
November 4, 2011 12:29:31 AM

Hi,
So my system specs are;
AMD Phenom ii x4 965 BE @ 3.4GHz
Standard AMD Heatsink and fan
Corsair DDR3 1333MHz (2x2GB)
Asus M4A88T-V EVO/USB3
Corsair TX650w PSU
NZXT Phantom Full Tower Case
1st 6870 is Sapphire (used as main card)
2nd 6870 is XFX (shows up as disabled in CCC)
So essentially in CCC i click on AMD CrossfireX under the performance options, click enable, then apply and nothing happens apart from the enable box unticking itself.
In the Graphics hardware section it shows my main adapter as the Sapphire one, and then my XFX is listed as the "Disabled Adapter" (http://i.imgur.com/HaQCb.png)
Why is that listed as disabled when i have the crossfire bridge installed and both cards seem to be running when i power on my machine.
If anyone could help me out with this I'd really appreciate it as I just bought the second 6870 to play BF3 on ultra.
November 4, 2011 1:21:33 AM

Hello and welcome.
Uninstall the current CCC and AMD drivers and install the latest CCC 11.10, also make sure your CF bridge is properly connected and no problem with it.

Also, i would test the new card alone first.
Anonymous
November 4, 2011 12:37:55 PM

Thanks for the help.
I've been uninstalling and reinstalling CCC for a while to no avail.
Not sure what the problem was, but I had it working an my old case and then i moved my setup to a new case and it stopped crossfire.
I just changed my crossfire bridge to the one I got with my XFX card and it didn't work, swapped back over to the Sapphire provided Crossfire Bridge and it works now.
Not sure what the problem was but it fixed itself. :) 
thank you for helping though :) 
!