Sign in with
Sign up | Sign in
Your question

SP2 Security Center - Firewall Irritation - Any Ideas?

Tags:
  • Configuration
  • Security
  • Firewalls
  • Customization
  • Dial Up Connection
  • Windows XP
Last response: in Windows XP
Share
Anonymous
a b 8 Security
September 3, 2004 1:21:03 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

As I rely on two hardware based firewalls, I have only ever used the MS
Firewall for a couple of dial-up connections I use on an infrequent basis.
With SP2 I have the MS firewall switched off and despite the fact that I
have unchecked the Check Firewall is running option, it still reverts to
checking a day after I have unchecked the box. This is annoying and
especially so when other non-technical members of the household log on
and get the warning about the firewall not running.
Anyone know how to fix this permanently? Some Reg setting somewhere no
doubt but I've searched the Kb but with no result so far.
--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976

More about : sp2 security center firewall irritation ideas

Anonymous
a b 8 Security
September 3, 2004 6:26:08 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Harry,

Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
click Start, click Control Panel, and then click Security Center. Click
Change the way Security Center alerts me. Clear the check boxes beside the
items for which you don't want to receive alerts, and then click OK.

Additional Information

From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI

<quote>
Disable the Security Center service:

Start/Run --> services.msc

Find "Security Center" in the list, double click on it, set "Startup type"
to Disabled.

There is also a Group Policy setting available to disable the Security
Center (Start/Run--> gpedit.msc).

Take a look at the chapter for the Security Center in 06_CIF_Maintenance.DOC

What settings are added or changed in Windows XP Service Pack 2?
Group Policy settings (page 26 for me)

06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
Service Pack 2, Part 6: Computer Maintenance") can be downloaded from here:

http://www.microsoft.com/downloads/details.aspx?FamilyI...

Note: WinXPSP2_Documentation.zip contains all the .doc downloads...

</quote>

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"brush-head" <harrydotbroomdoteclipsedotcodotuk> wrote in message
news:2dmdnZwM1eHytKXcRVn-uA@eclipse.net.uk...
As I rely on two hardware based firewalls, I have only ever used the MS
Firewall for a couple of dial-up connections I use on an infrequent basis.
With SP2 I have the MS firewall switched off and despite the fact that I
have unchecked the Check Firewall is running option, it still reverts to
checking a day after I have unchecked the box. This is annoying and
especially so when other non-technical members of the household log on
and get the warning about the firewall not running.
Anyone know how to fix this permanently? Some Reg setting somewhere no
doubt but I've searched the Kb but with no result so far.
--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
Anonymous
a b 8 Security
September 3, 2004 6:26:09 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Ramesh [MVP] wrote:

> Harry,
>
> Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
> click Start, click Control Panel, and then click Security Center. Click
> Change the way Security Center alerts me. Clear the check boxes beside the
> items for which you don't want to receive alerts, and then click OK.
>
> Additional Information
>
> From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI
>
> <quote>
> Disable the Security Center service:
>
> Start/Run --> services.msc
>
> Find "Security Center" in the list, double click on it, set "Startup type"
> to Disabled.
>
> There is also a Group Policy setting available to disable the Security
> Center (Start/Run--> gpedit.msc).
>
> Take a look at the chapter for the Security Center in 06_CIF_Maintenance.DOC
>
> What settings are added or changed in Windows XP Service Pack 2?
> Group Policy settings (page 26 for me)
>
> 06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
> Service Pack 2, Part 6: Computer Maintenance") can be downloaded from here:
>
> http://www.microsoft.com/downloads/details.aspx?FamilyI...
>
> Note: WinXPSP2_Documentation.zip contains all the .doc downloads...
>
> </quote>
>
Thanks Ramesh - I should have started there in the first place - obvious
really.

--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
Related resources
Anonymous
a b 8 Security
September 4, 2004 5:02:02 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Bush-Head--

Thanks for the additional information. You can also just put "services.msc"
in the run box and turn off the Windows Firewall by turning off the Windows
Firewall/Internet Connection Sharing service. Some people have been
reporting regularly that when they turn it off at the firewall that even if
it doesn't show up after reboot, it continues to run in the background
listed in Task Manager. Why that happens to them, I don't know.

Chad Harris
_______________________________________



"brush-head" <harrydotbroomdoteclipsedotcodotuk> wrote in message
news:p u-dnTNk0P4koqXcRVn-sA@eclipse.net.uk...
Ramesh [MVP] wrote:

> Harry,
>
> Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
> click Start, click Control Panel, and then click Security Center. Click
> Change the way Security Center alerts me. Clear the check boxes beside the
> items for which you don't want to receive alerts, and then click OK.
>
> Additional Information
>
> From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI
>
> <quote>
> Disable the Security Center service:
>
> Start/Run --> services.msc
>
> Find "Security Center" in the list, double click on it, set "Startup type"
> to Disabled.
>
> There is also a Group Policy setting available to disable the Security
> Center (Start/Run--> gpedit.msc).
>
> Take a look at the chapter for the Security Center in
> 06_CIF_Maintenance.DOC
>
> What settings are added or changed in Windows XP Service Pack
> 2?
> Group Policy settings (page 26 for me)
>
> 06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
> Service Pack 2, Part 6: Computer Maintenance") can be downloaded from
> here:
>
> http://www.microsoft.com/downloads/details.aspx?FamilyI...
>
> Note: WinXPSP2_Documentation.zip contains all the .doc downloads...
>
> </quote>
>
Thanks Ramesh - I should have started there in the first place - obvious
really.

--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
Anonymous
a b 8 Security
September 4, 2004 5:05:59 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Ramesh--

Thanks for this info. Some people report if you don't turn the service off,
either the one you mentioned or the one that is labeled Windows
Firewall/Internet Connection sharing, that the firewall will continue to run
in the background in Task Manager. Do you know why that happens? Also I
was glad to get the run box command I didn't have. Do you know places/sites
for lists of run box commands--I have a number, but am always looking for
more and do you know the command that opens Windows Firewall applet?

Thanks,

Chad Harris
______________________________
"Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
news:eTd1VPZkEHA.3520@tk2msftngp13.phx.gbl...
Harry,

Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
click Start, click Control Panel, and then click Security Center. Click
Change the way Security Center alerts me. Clear the check boxes beside the
items for which you don't want to receive alerts, and then click OK.

Additional Information

From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI

<quote>
Disable the Security Center service:

Start/Run --> services.msc

Find "Security Center" in the list, double click on it, set "Startup type"
to Disabled.

There is also a Group Policy setting available to disable the Security
Center (Start/Run--> gpedit.msc).

Take a look at the chapter for the Security Center in 06_CIF_Maintenance.DOC

What settings are added or changed in Windows XP Service Pack 2?
Group Policy settings (page 26 for me)

06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
Service Pack 2, Part 6: Computer Maintenance") can be downloaded from here:

http://www.microsoft.com/downloads/details.aspx?FamilyI...

Note: WinXPSP2_Documentation.zip contains all the .doc downloads...

</quote>

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"brush-head" <harrydotbroomdoteclipsedotcodotuk> wrote in message
news:2dmdnZwM1eHytKXcRVn-uA@eclipse.net.uk...
As I rely on two hardware based firewalls, I have only ever used the MS
Firewall for a couple of dial-up connections I use on an infrequent basis.
With SP2 I have the MS firewall switched off and despite the fact that I
have unchecked the Check Firewall is running option, it still reverts to
checking a day after I have unchecked the box. This is annoying and
especially so when other non-technical members of the household log on
and get the warning about the firewall not running.
Anyone know how to fix this permanently? Some Reg setting somewhere no
doubt but I've searched the Kb but with no result so far.
--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
Anonymous
a b 8 Security
September 5, 2004 2:49:29 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi Chad,

For the first part, I don't get it fully; any details would be appreciated.
Regarding the RUN commands, the WSCUI is a CPL applet, found in the
%Systemroot%\System32 folder (*.CPL files) file named WSCUI.CPL in XP
Service Pack 2. Similarly you can launch any CPL file from Start/Run dialog.
Windows 9x systems require you to type Control <CPLApplet> example CONTROL
INETCPL.CPL. To launch the Firewall dialog, type Firewall.cpl. Similarly,
some DLL files also have a Cpl applet entry-point which you can view using
Dependency Walker or any Portable Executable analysis tool available on the
web.

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"Chad Harris" <ddram32_nospam@yahoo.com> wrote in message
news:uEJX1FqkEHA.3372@TK2MSFTNGP09.phx.gbl...
Ramesh--

Thanks for this info. Some people report if you don't turn the service off,
either the one you mentioned or the one that is labeled Windows
Firewall/Internet Connection sharing, that the firewall will continue to run
in the background in Task Manager. Do you know why that happens? Also I
was glad to get the run box command I didn't have. Do you know places/sites
for lists of run box commands--I have a number, but am always looking for
more and do you know the command that opens Windows Firewall applet?

Thanks,

Chad Harris
______________________________
"Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
news:eTd1VPZkEHA.3520@tk2msftngp13.phx.gbl...
Harry,

Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
click Start, click Control Panel, and then click Security Center. Click
Change the way Security Center alerts me. Clear the check boxes beside the
items for which you don't want to receive alerts, and then click OK.

Additional Information

From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI

<quote>
Disable the Security Center service:

Start/Run --> services.msc

Find "Security Center" in the list, double click on it, set "Startup type"
to Disabled.

There is also a Group Policy setting available to disable the Security
Center (Start/Run--> gpedit.msc).

Take a look at the chapter for the Security Center in 06_CIF_Maintenance.DOC

What settings are added or changed in Windows XP Service Pack 2?
Group Policy settings (page 26 for me)

06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
Service Pack 2, Part 6: Computer Maintenance") can be downloaded from here:

http://www.microsoft.com/downloads/details.aspx?FamilyI...

Note: WinXPSP2_Documentation.zip contains all the .doc downloads...

</quote>

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"brush-head" <harrydotbroomdoteclipsedotcodotuk> wrote in message
news:2dmdnZwM1eHytKXcRVn-uA@eclipse.net.uk...
As I rely on two hardware based firewalls, I have only ever used the MS
Firewall for a couple of dial-up connections I use on an infrequent basis.
With SP2 I have the MS firewall switched off and despite the fact that I
have unchecked the Check Firewall is running option, it still reverts to
checking a day after I have unchecked the box. This is annoying and
especially so when other non-technical members of the household log on
and get the warning about the firewall not running.
Anyone know how to fix this permanently? Some Reg setting somewhere no
doubt but I've searched the Kb but with no result so far.
--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
Anonymous
a b 8 Security
September 6, 2004 3:50:17 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Ramesh--

On the firewall:

I mean that if you look at these XP groups, and others people are starting
to say that they will turn the SP2 Windows Firewall off, (because they are
running another software firewall they like better) and it will still show
up in Task Manager Processes running (in the background but running). The
concern for them there isn't the CPU; it's that they don't want firewall
conflicts between two software firewalls.

They also can click a hyperlink at the Security Center but my understanding
of that is simply it turns the SC's recognition of the firewall off. It
also has the title "internet connection sharing" so does that merit any
reason services may need to be left on.

So I would say to go to Services and just turn the firewall off there--that
should stop it from running in the background, but some people have reported
that it still starts up anyway. There is probably a registry setting that
would stop it and I guess I can hunt for that.

On run commands:

I have some collections of commands to use for control panel applets, but
I'm always looking for as many commands as I can find that will work in that
box, including going through O'reilly Win 2K command type books. AYK, you
can't just tack .cpl onto an applet and have it come up, but it does work
with firewall.cpl. If you put control in the run box, you'll bring all the
applets up in a folder--I was hoping I could use them to get a mouseover of
the command but that doesn't happen. I'm looking over Dependency Walker or
any Portable Executable analysis tool available via google right now. Any
context you can give me of which to use is appreciated. Thanks for
introducing me to them.

Chad Harris
__________________________________




"Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
news:ejKGPNqkEHA.3552@TK2MSFTNGP12.phx.gbl...
Hi Chad,

For the first part, I don't get it fully; any details would be appreciated.
Regarding the RUN commands, the WSCUI is a CPL applet, found in the
%Systemroot%\System32 folder (*.CPL files) file named WSCUI.CPL in XP
Service Pack 2. Similarly you can launch any CPL file from Start/Run dialog.
Windows 9x systems require you to type Control <CPLApplet> example CONTROL
INETCPL.CPL. To launch the Firewall dialog, type Firewall.cpl. Similarly,
some DLL files also have a Cpl applet entry-point which you can view using
Dependency Walker or any Portable Executable analysis tool available on the
web.

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"Chad Harris" <ddram32_nospam@yahoo.com> wrote in message
news:uEJX1FqkEHA.3372@TK2MSFTNGP09.phx.gbl...
Ramesh--

Thanks for this info. Some people report if you don't turn the service off,
either the one you mentioned or the one that is labeled Windows
Firewall/Internet Connection sharing, that the firewall will continue to run
in the background in Task Manager. Do you know why that happens? Also I
was glad to get the run box command I didn't have. Do you know places/sites
for lists of run box commands--I have a number, but am always looking for
more and do you know the command that opens Windows Firewall applet?

Thanks,

Chad Harris
______________________________
"Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
news:eTd1VPZkEHA.3520@tk2msftngp13.phx.gbl...
Harry,

Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
click Start, click Control Panel, and then click Security Center. Click
Change the way Security Center alerts me. Clear the check boxes beside the
items for which you don't want to receive alerts, and then click OK.

Additional Information

From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI

<quote>
Disable the Security Center service:

Start/Run --> services.msc

Find "Security Center" in the list, double click on it, set "Startup type"
to Disabled.

There is also a Group Policy setting available to disable the Security
Center (Start/Run--> gpedit.msc).

Take a look at the chapter for the Security Center in 06_CIF_Maintenance.DOC

What settings are added or changed in Windows XP Service Pack 2?
Group Policy settings (page 26 for me)

06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
Service Pack 2, Part 6: Computer Maintenance") can be downloaded from here:

http://www.microsoft.com/downloads/details.aspx?FamilyI...

Note: WinXPSP2_Documentation.zip contains all the .doc downloads...

</quote>

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"brush-head" <harrydotbroomdoteclipsedotcodotuk> wrote in message
news:2dmdnZwM1eHytKXcRVn-uA@eclipse.net.uk...
As I rely on two hardware based firewalls, I have only ever used the MS
Firewall for a couple of dial-up connections I use on an infrequent basis.
With SP2 I have the MS firewall switched off and despite the fact that I
have unchecked the Check Firewall is running option, it still reverts to
checking a day after I have unchecked the box. This is annoying and
especially so when other non-technical members of the household log on
and get the warning about the firewall not running.
Anyone know how to fix this permanently? Some Reg setting somewhere no
doubt but I've searched the Kb but with no result so far.
--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
Anonymous
a b 8 Security
September 8, 2004 4:31:08 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi Chad,

If you're referring to the alg.exe process running in the Task Manager, this
info might help you:
http://www.blackviper.com/WinXP/service411.htm#Applicat...

For a SOHO, if you're using a third-party proxy util (say AnalogX Proxy),
you should no longer need this service running (ICF / ICS)

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"Chad Harris" <ddram32_nospam@yahoo.com> wrote in message
news:o i%232cS8kEHA.3428@TK2MSFTNGP11.phx.gbl...
Ramesh--

On the firewall:

I mean that if you look at these XP groups, and others people are starting
to say that they will turn the SP2 Windows Firewall off, (because they are
running another software firewall they like better) and it will still show
up in Task Manager Processes running (in the background but running). The
concern for them there isn't the CPU; it's that they don't want firewall
conflicts between two software firewalls.

They also can click a hyperlink at the Security Center but my understanding
of that is simply it turns the SC's recognition of the firewall off. It
also has the title "internet connection sharing" so does that merit any
reason services may need to be left on.

So I would say to go to Services and just turn the firewall off there--that
should stop it from running in the background, but some people have reported
that it still starts up anyway. There is probably a registry setting that
would stop it and I guess I can hunt for that.

On run commands:

I have some collections of commands to use for control panel applets, but
I'm always looking for as many commands as I can find that will work in that
box, including going through O'reilly Win 2K command type books. AYK, you
can't just tack .cpl onto an applet and have it come up, but it does work
with firewall.cpl. If you put control in the run box, you'll bring all the
applets up in a folder--I was hoping I could use them to get a mouseover of
the command but that doesn't happen. I'm looking over Dependency Walker or
any Portable Executable analysis tool available via google right now. Any
context you can give me of which to use is appreciated. Thanks for
introducing me to them.

Chad Harris
__________________________________




"Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
news:ejKGPNqkEHA.3552@TK2MSFTNGP12.phx.gbl...
Hi Chad,

For the first part, I don't get it fully; any details would be appreciated.
Regarding the RUN commands, the WSCUI is a CPL applet, found in the
%Systemroot%\System32 folder (*.CPL files) file named WSCUI.CPL in XP
Service Pack 2. Similarly you can launch any CPL file from Start/Run dialog.
Windows 9x systems require you to type Control <CPLApplet> example CONTROL
INETCPL.CPL. To launch the Firewall dialog, type Firewall.cpl. Similarly,
some DLL files also have a Cpl applet entry-point which you can view using
Dependency Walker or any Portable Executable analysis tool available on the
web.

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"Chad Harris" <ddram32_nospam@yahoo.com> wrote in message
news:uEJX1FqkEHA.3372@TK2MSFTNGP09.phx.gbl...
Ramesh--

Thanks for this info. Some people report if you don't turn the service off,
either the one you mentioned or the one that is labeled Windows
Firewall/Internet Connection sharing, that the firewall will continue to run
in the background in Task Manager. Do you know why that happens? Also I
was glad to get the run box command I didn't have. Do you know places/sites
for lists of run box commands--I have a number, but am always looking for
more and do you know the command that opens Windows Firewall applet?

Thanks,

Chad Harris
______________________________
"Ramesh [MVP]" <ramesh@nojunkmails.com@mvps.org> wrote in message
news:eTd1VPZkEHA.3520@tk2msftngp13.phx.gbl...
Harry,

Open the Security Center by typing WSCUI.CPL in the Start, RUN box. Or,
click Start, click Control Panel, and then click Security Center. Click
Change the way Security Center alerts me. Clear the check boxes beside the
items for which you don't want to receive alerts, and then click OK.

Additional Information

From Torgeir Bakken , Scripting expert and Microsoft MVP Scripting and WMI

<quote>
Disable the Security Center service:

Start/Run --> services.msc

Find "Security Center" in the list, double click on it, set "Startup type"
to Disabled.

There is also a Group Policy setting available to disable the Security
Center (Start/Run--> gpedit.msc).

Take a look at the chapter for the Security Center in 06_CIF_Maintenance.DOC

What settings are added or changed in Windows XP Service Pack 2?
Group Policy settings (page 26 for me)

06_CIF_Maintenance.DOC ("Changes to Functionality in Microsoft Windows XP
Service Pack 2, Part 6: Computer Maintenance") can be downloaded from here:

http://www.microsoft.com/downloads/details.aspx?FamilyI...

Note: WinXPSP2_Documentation.zip contains all the .doc downloads...

</quote>

--
Ramesh, Microsoft MVP
Window XP Shell/User
http://www.mvps.org/sramesh2k


"brush-head" <harrydotbroomdoteclipsedotcodotuk> wrote in message
news:2dmdnZwM1eHytKXcRVn-uA@eclipse.net.uk...
As I rely on two hardware based firewalls, I have only ever used the MS
Firewall for a couple of dial-up connections I use on an infrequent basis.
With SP2 I have the MS firewall switched off and despite the fact that I
have unchecked the Check Firewall is running option, it still reverts to
checking a day after I have unchecked the box. This is annoying and
especially so when other non-technical members of the household log on
and get the warning about the firewall not running.
Anyone know how to fix this permanently? Some Reg setting somewhere no
doubt but I've searched the Kb but with no result so far.
--
Harry Broom

"The meek shall inherit the earth, but not the mineral rights"

John Paul Getty 1892 - 1976
!