Sign in with
Sign up | Sign in
Your question

PC doesn't boot up - faint high pitched noise from the PSU

Tags:
Last response: in CPUs
Share
April 12, 2012 9:08:07 AM

Model: Aspire M5641
Graphics card: GeForce 8400GS 512MB
OS: Windows 8 Customer Preview

Here's how it usually goes down, I put the PC to sleep right before I get to sleep myself and turn it back on the next morning. I do this every day and each day I get a blue screen error which I assumed had something to do with the OS being a customer preview, to which my solution was to hold down the power button to turn the PC off and turn it back on.

This worked gloriously for about 2 months, but this morning it went all wrong.

I turned it off by holding down the power button as usual, tried to turn it back on and I get nothing, no display, no lights, no CPU fan not even the PSU fan. But I could hear a continuous faint high pitched noise from the PSU.

Done:
Tried booting it up without the RAM, HDD, CMOS battery and anything else that I could think of but nothing worked.

Wired up the Green cable from the PSU to the Black one which got the PSU fan running.

Any help would be greatly appreciated.
a b à CPUs
April 12, 2012 10:13:48 AM

Maybe something got scrambled in the CMOS, try resetting/clearing it.
m
0
l
a b à CPUs
April 12, 2012 10:30:45 AM

What PSU have you got buddy?
m
0
l
Related resources
April 12, 2012 10:38:35 AM

Are you sure that its not the cable making the high pitched queel? They tend to do that if not pushed in all the way.

Sorry if this question sounds condescending!

Jay
m
0
l
April 12, 2012 2:04:14 PM

abekl said:
Maybe something got scrambled in the CMOS, try resetting/clearing it.


Thanks for the replies guys, the PSU's the one that came with the branded Aspire, FSP Group Inc.
m
0
l
a c 172 à CPUs
April 12, 2012 2:07:39 PM

No, cables do not make high pitched squealing noises.

Tim, it sounds like your PC just died.

Does your system have an internal speaker installed? If your system normally makes a single short beep when it boots successfully, it does.

If you have an internal speaker installed, disconnect everything from the motherboard except CPU and cooler, power supply, and case wiring. turn on the system. If those components are good, you should hear BIOS beeps telling you that you have no memory installed.

Most motherboards will generate a series of long single beeps. Silence indicates a bad power supply, motherboard, or CPU.
m
0
l
April 12, 2012 2:13:18 PM

O
houldendub said:
What PSU have you got buddy?


I'm hoping for a PSU issue rather than a motherboard one for obvious reasons, in any case the PSU is from FSP Group. Thanks for any help.
m
0
l
April 12, 2012 2:17:12 PM

jsc said:
No, cables do not make high pitched squealing noises.

Tim, it sounds like your PC just died.

Does your system have an internal speaker installed? If your system normally makes a single short beep when it boots successfully, it does.

If you have an internal speaker installed, disconnect everything from the motherboard except CPU and cooler, power supply, and case wiring. turn on the system. If those components are good, you should hear BIOS beeps telling you that you have no memory installed.

Most motherboards will generate a series of long single beeps. Silence indicates a bad power supply, motherboard, or CPU.

Thanks for the reply man, I've tried this, as said in my initial post. I do have an internal speaker which would, under normal circumstances beep on boot, but this time around I got nothing even when I had the RAM removed.
m
0
l
April 12, 2012 2:19:44 PM

As far as i'm concerned it could even be the power button that got broken.
m
0
l
April 12, 2012 2:27:35 PM

Pedrovsky said:
As far as i'm concerned it could even be the power button that got broken.

If you could explain why that would make the PSU hum, you're gold. In all seriousness though, there's only an extremely small off chance at most that this is true.
m
0
l
!