Folder templates not working in SP2

Archived from groups: microsoft.public.windowsxp.customize (More info?)

I added those registry file to enable Folder Templates (WebView).

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explo
rer]
"AllowLegacyWebView"=dword:00000001
"AllowUnhashedWebView"=dword:00000001
"RevertWebViewSecurity"=dword:00000001

With SP1 all worked fine.
With SP2 it says:
Your current security settings prohibit running ActiveX controls on this
page. As a result, the page may not display correctly.

Now there is no list of files - just an empty background with my custom
controls.
The area is "My Computer" which is not available from Internet
Settings/Security

What else should I change in the registry?
3 answers Last reply
More about folder templates working
  1. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Your also need to set this so as not to be bombarded by dialog boxes.
    SH.RegWrite "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0\1201", 0, "REG_DWORD"

    This is required on any version of Windows.
    --
    ----------------------------------------------------------
    http://www.newmatilda.com/home/default.asp
    "George Valkov" <null@somewhere.com> wrote in message news:uA7J2MZkEHA.3520@tk2msftngp13.phx.gbl...
    > I added those registry file to enable Folder Templates (WebView).
    >
    > [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explo
    > rer]
    > "AllowLegacyWebView"=dword:00000001
    > "AllowUnhashedWebView"=dword:00000001
    > "RevertWebViewSecurity"=dword:00000001
    >
    > With SP1 all worked fine.
    > With SP2 it says:
    > Your current security settings prohibit running ActiveX controls on this
    > page. As a result, the page may not display correctly.
    >
    > Now there is no list of files - just an empty background with my custom
    > controls.
    > The area is "My Computer" which is not available from Internet
    > Settings/Security
    >
    > What else should I change in the registry?
    >
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Thanks for the information, but I've already tried this option.
    Also tried 1200=0 and 1201=0. I also did this for Lockdown\0. And finally
    did all of this for HKLM\... and for .DEFAULT\, restarting the computer
    after each try.

    Is it because I had no time to upgrade to the final SP2? Currently it uses
    XP SP2-rc1.

    This smart fox XP SP2-rc1 test installation won't let me cheat on it that
    easy! It doesn't want to listen to me and obey the settings!

    PS:
    In some Linux versions there is an option for paranoia security...
    In XP-SP2 this also seems to be true... Except that it can't be disabled!


    "David Candy" <david@mvps.org> wrote in message
    news:OrTfwkbkEHA.3712@TK2MSFTNGP15.phx.gbl...
    Your also need to set this so as not to be bombarded by dialog boxes.
    SH.RegWrite "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet
    Settings\Zones\0\1201", 0, "REG_DWORD"

    This is required on any version of Windows.
    --
    ----------------------------------------------------------
    http://www.newmatilda.com/home/default.asp
    "George Valkov" <null@somewhere.com> wrote in message
    news:uA7J2MZkEHA.3520@tk2msftngp13.phx.gbl...
    > I added those registry file to enable Folder Templates (WebView).
    >
    >
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explo
    > rer]
    > "AllowLegacyWebView"=dword:00000001
    > "AllowUnhashedWebView"=dword:00000001
    > "RevertWebViewSecurity"=dword:00000001
    >
    > With SP1 all worked fine.
    > With SP2 it says:
    > Your current security settings prohibit running ActiveX controls on this
    > page. As a result, the page may not display correctly.
    >
    > Now there is no list of files - just an empty background with my custom
    > controls.
    > The area is "My Computer" which is not available from Internet
    > Settings/Security
    >
    > What else should I change in the registry?
    >
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.customize (More info?)

    Thank You!
    It seems that the problem was due to unfinished business or bug in SP2-rc1.
    The final version now obeys the registry settings.


    "David Candy" <david@mvps.org> wrote in message
    news:OrTfwkbkEHA.3712@TK2MSFTNGP15.phx.gbl...
    Your also need to set this so as not to be bombarded by dialog boxes.
    SH.RegWrite "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet
    Settings\Zones\0\1201", 0, "REG_DWORD"

    This is required on any version of Windows.
    --
    ----------------------------------------------------------
    http://www.newmatilda.com/home/default.asp
    "George Valkov" <null@somewhere.com> wrote in message
    news:uA7J2MZkEHA.3520@tk2msftngp13.phx.gbl...
    > I added those registry file to enable Folder Templates (WebView).
    >
    >
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explo
    > rer]
    > "AllowLegacyWebView"=dword:00000001
    > "AllowUnhashedWebView"=dword:00000001
    > "RevertWebViewSecurity"=dword:00000001
    >
    > With SP1 all worked fine.
    > With SP2 it says:
    > Your current security settings prohibit running ActiveX controls on this
    > page. As a result, the page may not display correctly.
    >
    > Now there is no list of files - just an empty background with my custom
    > controls.
    > The area is "My Computer" which is not available from Internet
    > Settings/Security
    >
    > What else should I change in the registry?
    >
    >
    >
    >
Ask a new question

Read More

Configuration Microsoft Registry Windows XP