Sign in with
Sign up | Sign in
Your question

Bad Ethernet Port? ASRock z77 [Extreme 4]

Last response: in Motherboards
Share
February 20, 2013 8:36:59 PM

I just build a new gaming PC. Install went great, I now have windows 7 installed and transfered over steam and all my files. The next step is to hook it up to the internet. It didn't work at first, but then I was thinking and I though I should run the disk that came in the box of my router [Netgear Dual Band Router]. It will let the two comunicate together, and everything will be happy, and work.

I put in the disk, hit run, clicked setup, and then it said to connect it to the ethernet cable. I did that and hit retry. Same pop up occoured. Unplugged, retried. Same thing.

So, is my ethernet port on my motherboard bad? If you dont think so, then what should I do to connect to the internet? Also, have you ever heard of a bad ethernet port?

PC Specs-
ASRock z77 Extreme 4
Intel i5 3570k
nVidia GTX 550ti (Next upgrade, after I connect to internet)
8gb 1333mhz Generic RAM.
500w PSU
Cheap-O ThermalTake Case

I dont know if any of that stuff matters, but if it does then its here for you.
Thank you!
a b V Motherboard
February 21, 2013 3:31:04 AM

Did you install the motherboard drivers? New motherboards usually come with a drivers disc. Have you checked Device Manager to see if there are any problems (usually flagged with an exclamation point inside a yellow triangle)?
m
0
l
February 21, 2013 3:41:13 AM

You need to install the drivers for the Broadcom BCM57781 chipset that your motherboard uses for Ethernet. Until you do that nothing you try otherwise will show an internet connection.
m
0
l
!