Turbo Boost is working... however it wants.

I have a Gigabyte z68x-ud3h-b3 rev1.3 mb and an Intel i5-2500k cpu.

While I had Win7 on F10 BIOS, Turbo Boost worked as expected: when it was on Auto setting if it was 1 core it would clock to 3.7, 2 cores to 3.6, 3 cores to 3.5 and 4 cores to 3.4. I would manually set in BIOS that Turbo Boost clocks to 3.7 in all those scenarios and that's what it did.

Now I have Win8 on UEFI and Turbo Boost is behaving oddly. When everything is on Auto, even though it says right there that it should work the same way Auto did before, it actually works like how I used to manually set it (always clock to 3.7 regardless of the number of cores in use). When I do manually set it like I used to do, Turbo Boost simply doesn't work at all and the maximum clock is at 3.3.

Has anyone experienced such a thing? Does anyone have any idea why it is so?

p.s. c1e is off, c3/c6 is off, cpu thermal monitor is on, eist is on.
4 answers Last reply
More about turbo boost working wants
  1. I have tried some other scenarios and things are getting weirder and weirder.

    If I switch Turbo Boost from Auto to Enabled (and leave the individual settings to Auto), it goes up to 3.4 regardless of how many cores are in use.

    If I leave 1 core to Auto, but switch 2, 3, 4 cores to 37, Turbo Boost will work how I originally wanted, it would go to 3.7 regardless of how many cores are in use. The problem is that if I set it to 38, it will still only go to 3.7. If I change the 1 core scenario from Auto to 37 or 38, Turbo Boost simply stops working.
  2. check the latest bios.
  3. I am on the latest (as I wrote in the first post), there is only 1 UEFI image available for my mb. That's the funny part, while I was on an older version, F10 BIOS, everything worked in an expected manner.
  4. you'd better use legacy bios instead of uefi one because as i know uefi bios on z68 is not mature, it is just for overclocking on some ivb. if you hav 2500k, ther is no difference even improvement to use uefi bios .. and some functions unavailable in z68 uefi bios than legacy one.
Ask a new question

Read More

Gigabyte CPUs BIOS Intel i5 Turbo Boost Motherboards