Is My CPU or Motherboard Dead?

I got this problem like 2 weeks ago. Basically I had the computer on for about 2 days straight, which I never did before, and then I turned it off. Later I turned it back on and the fans and LEDs all turned on for like half a second and then the thing just shut off again. So it won't boot.

I have literally tried everything. Unplugging all the hard drives, optical drive, RAM, GPU, everything unnecessary. The same thing happened. Basically, all the fans and stuff go for half a second and it shuts off, but then I cannot even get that to happen, nothing turns on at all unless I wait like 15 seconds, then if I press the power button again the LEDs and fans spin again and shut off, same deal.

So I tested a different PSU, going from a 650w to a 250w was a big difference, but I had all the extra stuff unplugged so it shouldn't of been a big deal. Well this time, I had a slightly different reaction... the LED that the heatsink had (yes the heatsink had LEDs) lit up, but nothing spun or anything. The light was just on, and the heatsink fan span very slowly.

So I assumed it was the motherboard. I had everything tested, and apparently the PSU was dead. They hooked a 500w to the mobo (with the GPU and everything still plugged in, so I have no idea if it was sufficient wattage), but the same thing happened with me when I put in the 250w... just got the heatsink to light up and that's really it.

I RMAd the PSU, so I have a new one now and though I didn't test it I'm sure it's fine. Just RMAd the mobo as well back to Gigabyte, but after like 2 weeks they JUST sent me an email and they said they tested it and now they're just shipping it back. I'm going to assume that it's fine...

But is my CPU okay? Or is that is what's dead? Because now they're just shipping back my thought-to-be-dead mobo. I really hope I can get it to work with this new PSU, but I have a feeling it's still not going to turn on. How do I tell if the CPU is dead? I spent forever searching it up and I can't seem to get a straight answer. I physically looked at it as well, it's perfectly fine, no burns or anything.
5 answers Last reply
More about motherboard dead
  1. The easiest way is to install it in a known good motherboard. Can't you have it tested by a shop if the system still doesn't work when you get the motherboard back? Leaving the system on for 2 days didn't cause the issue. Systems are designed to be powered on 24x7.
  2. I will have the shop test it once I get it back again, I suppose....
  3. Only if it the system doesn't work and you don't have another system to test components like the CPU.
  4. Alright, I got everything plugged in with the mobo and new PSU and all, and it's working fine now.
  5. So both the PSU and motherboard went bad? Glad you got it working again.
Ask a new question

Read More

CPUs