Sign in with
Sign up | Sign in
Your question

HDD aren't showing up anymore!?!? HELP!!!

Tags:
  • Asus
  • Hard Drives
  • Motherboards
Last response: in Motherboards
Share
February 24, 2013 3:53:15 PM

Today I moved all my components to a new case which included a 128gb SSD and a 1tb HDD + whilst moving I have also added 2x brand new drives. I have connected everything the way it was but now I can't get any of my original HDD's to show up... The only drives that show up are my optical drive + my 2x brand new unformatted drives!!!

I have no idea how this has happened. I have a Asus Z68 motherboard and my HDD brands are WD & Seagate. My original drives that aren't showing contain a lot of data that I can't lose. Does anyone have any idea what I can do to fix it. I know I should test the HDD/SSD in another computer but I know they are working 100% it seems more to do with my motherboard. I have tried using the same SATA ports as before and the same SATA ports that worked with the new HDD and still now luck. The motherboard is also set to ACHI and has been working flawlessly for over year how it as been...

Can anyone help me out here?

More about : hdd showing anymore

February 24, 2013 5:53:13 PM

Bump!
I am really stuck for ideas here i don't see how 2 of my HDD's can break by moving them to another case and using exactly the same cables and sata ports!?!?!?
a b Ĉ ASUS
a c 104 V Motherboard
February 27, 2013 6:00:39 AM

Hi Jack,


Check the power connectors to the HDDs are seated properly and check the SATA cables also (they can break internally, though it would be odd if two did at the same time).

I am assuming those two drives that won't show were not running in RAID before as you mention AHCI. Are they not showing up in UEFI, or just Windows?

-Raja

!