Sign in with
Sign up | Sign in
Your question

Vsync stutter (frame skip).

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
November 8, 2011 1:21:51 PM

Now I have 2x6970's so Vsync is needed to stop the immense microstutter I get under 90fps, the only problem is it seems to judder stutter (miss a frame) when moving the mouse sometimes, is this a known issue with the game or any other way to resolve it?

More about : vsync stutter frame skip

November 8, 2011 1:35:22 PM

Which game? lol

Also, Vsync doesn't help with microstutter. It's really only meant to stop screen tearing. If you're getting microstutter then you might need to OC your CPU.

What are your system specs?
November 8, 2011 9:09:14 PM

Sorry man, yeah I did rush this thread a little.

My system specs are:

i7@4.00gz 920d0
2x6970's HIS
ATX 1200w PSU
8gb Corsair dominator 1600mhz
7200rpm HDD
Gigabyte EX58-UD5

Now the game I was talking about was BF3 it microstutters to hell without vsync on (drops below 90fps and feels like 40-30fps). With vsync on it smooth and a stable frame rate but really choppy, I used a framerate limiter 3rd party app (DXtory) to help with the choppiness in game when vsync is enabled but it's still there not as much but It's still clearly visible.

11.10 installed with 11.9 Cap4.
Related resources
November 8, 2011 9:22:20 PM

Stef1_1 said:
Sorry man, yeah I did rush this thread a little.

My system specs are:

i7@4.00gz 920d0
2x6970's HIS
ATX 1200w PSU
8gb Corsair dominator 1600mhz
7200rpm HDD
Gigabyte EX58-UD5

Now the game I was talking about was BF3 it microstutters to hell without vsync on (drops below 90fps and feels like 40-30fps). With vsync on it smooth and a stable frame rate but really choppy, I used a framerate limiter 3rd party app (DXtory) to help with the choppiness in game when vsync is enabled but it's still there not as much but It's still clearly visible.

11.10 installed with 11.9 Cap4.

have a look if triple buffering is disabled. Or enable triple buffering and enable vsync
November 8, 2011 9:41:14 PM

There is no reason to run a frame limiter unless you're getting screen tearing. That includes vsync. Just turn it off.

With a multi-gpu setup, vsync is actually going to make micro-stutter worse. You need to adjust your settings accordingly. I like to keep my average fps ~90 to account for dips; I start seeing micro-stutter at ~50fps, so I don't like my minimum fps to ever drop below that. Also, if both of your cards are always at 100% usage, you're going to see micro-stutter more often. I don't know what settings you're running at or what your gpu usage is, but you may want to turn MSAA down/off and see if that helps. I think a lot of BF3 micro-stutter is driver related, but until that gets worked out, you may have to turn down a setting or two.
November 8, 2011 10:57:08 PM

Well, I'm running them at ultra and MSAA on when I turn of MSAA without vsync it keeps it about 70-100fps but when it dips below 90fps like I said, immense microstutter, I've discussed this in a previous thread but it does look like it's running at about 40fps when it reaches 90fps, Vsync stops this but I get very choppy mouse movement (or frameskipping?) when moving the mouse when vsync is on. Who knows, hope it's driver related, also I have tried triplebuffering through the CCC and D3D overrider, nothing has helped.
November 8, 2011 11:31:57 PM

tripplebuffering only works when you have vsync enabled.
November 8, 2011 11:38:21 PM

iam2thecrowe said:
tripplebuffering only works when you have vsync enabled.

No it doesnt. use dx tweaker or rivatuner to enable it.
November 8, 2011 11:40:24 PM

It may be worth doing a clean install of those drivers, I have a very similiar setup with 2x 6970's and using same drivers and CAP4 and have not seen any tearing or stutterring and I am using eyefinity as well. I was suprised to see just how smooth it did run on high settings.

I would do a driver sweep and reinstall drivers, even if to only rule it out.
November 9, 2011 12:38:02 AM

Did a fresh re-install of windows. Didn't work.

Faulty cards?

EDIT: The frame limiter actually reduces stuttering though.
November 9, 2011 12:56:04 AM

Stef1_1 said:
Did a fresh re-install of windows. Didn't work.

Faulty cards?

EDIT: The frame limiter actually reduces stuttering though.

You say when moving the mouse? What mouse is it?
November 9, 2011 12:56:18 AM

slow hdd? make and model of psu? I had 6870 crossfire and abandoned it bc of terrible micro stuttering... although your running much more powerful gpus so i don't know
November 9, 2011 1:00:30 AM

I may have a slow hdd, 7200rpm. It's about 2 years old....I'll try and buy a new 7200rpm in a few days to test it out.

PSU is corsair ATX 1200w
November 9, 2011 1:01:04 AM

gnomio said:
You say when moving the mouse? What mouse is it?


Gigabyte M8000

Drivers for this mouse are crap, latest ones were released about a year ago.
November 9, 2011 1:04:28 AM

Stef1_1 said:
Gigabyte M8000

Drivers for this mouse are crap, latest ones were released about a year ago.

Which drivers are you using?
Disable pointer shadows and uninstall it. See if the windows generic driver is better.

Also go to device manager. Click on your first sata channel that your hdd is on. Right click properties. Check what speed its reported
November 9, 2011 1:18:38 AM

random question; which two pcie slots do you have the cards in?
November 9, 2011 1:57:10 AM

My cards are in PCI-E slots 1 and 2, both are running 16x.

Sata:

I/O Range 0170-0177
I/O Range 0376-0376
IRQ 0x0000000F (15)

Also I have no mouse drivers installed at the moment thanks to a fresh install of windows.

EDIT: I'm not sure which SATA it is in but this is the second one think this is CD-ROM

I/O Range 01F0 - 01F7
I/O Range 03F6 - 03F6
IRQ - 0x0000000E (14)
November 9, 2011 2:17:15 AM

Do you by chance have both bridges connected?

It shouldn't make a difference but I found having 2 was causing some odd behaviour in crossfire.
November 9, 2011 2:21:55 AM

G6ET1987 said:
Do you by chance have both bridges connected?

It shouldn't make a difference but I found having 2 was causing some odd behaviour in crossfire.


I tried 1 and 2, no difference. Been trying to resolve this for a week lol.
November 9, 2011 3:07:46 AM

Disabled crossfire and ran with auto settings, with vsync on, smooth as butter. Enabled crossfire with vsync on, massive frame skipping (microstutter) when moving the mouse. Must be a crossfire issue.

So am I stuck with this issue, AMD won't sort it out in some drivers? Does anyone have information on how to get in contact with the Catalyst team?
November 9, 2011 3:34:44 AM

many people have jumped ship myself being one of them, you just have to get to the point where enough is enough...
November 9, 2011 3:36:00 AM

Awesome, spent £530 on two cards that microstutter.
November 9, 2011 3:51:14 AM

Found this post

http://www.techpowerup.com/forums/showthread.php?t=1545...

(Scroll to the bottom to see solution). That's what I had to do to REDUCE stuttering, so it looks like it's an incompatibility issue with my monitor, because this doesn't happen in other games. Like for example this never happened in BFBC2.

My monitor is a VH226 Asus...May get a 120hz.

EDIT: I have also noticed in the perfoverlayenable command in BF3 it doesn't show gpu or cpu spikes when the stutter occurs. Strange I have never come across a monitor VGA incompatibility issue before.
November 9, 2011 3:54:18 AM

I have heard that it is common but I am yet to experience it even slightly, you have probably done it already but may be worth swapping the cards around in position, possibly even different slots? run 8x 8x pci-e or something.
November 9, 2011 4:31:07 AM

I'll try but honestly the more I read this thread I posted the more it sounds exactly like my monitor is the issue, he even has the same make as my monitor (Asus).

Never buying an Asus again if this is the issue.

Need a 120hz anyway...silky smooth :p 
November 9, 2011 4:45:28 AM

Hey,

So just an FYI BF3 does indeed have issues with crossfire right now. AMD is working on the patch. It is entirely CF related. What happens is for some reason beyond me, your 2nd GPU's usage will drop to around 50% and then you get super terrible framerate. Just use a program like MSI Afterburner to monitor it and after it happens a couple times check out the graphs and you'll see what I mean.

I find that reducing MSAA helps but not entirely a fix. The only fix will be a driver update. I record my FPS constantly and even when I average 70-90 depending on the level I still get those stuttering moments due to the 2nd card dropping out. It's a pain in the ass for now. And yeah, single card it runs great just I have to lower settings.
November 9, 2011 4:47:54 AM

I get stable gpu usage on both GPU's 99% with vsync off and they scale very well when vsync is on.

Also I don't get the stuttering "moments" it looks like it's a constant 30fps when it's 90fps with vsync off. I hope to christ it is a driver issue or monitor issue and I don't have to sell these things and get a couple of more cards. I will be broke.
November 9, 2011 4:51:56 AM

Hmm. Might be a different issue then.

That said I'm quite sure it is in fact driver related. For the time being maybe just run single card with BF3.

Also, to the "triple buffer" replies: Notice that it is under the heading OpenGL Settings. OpenGL is not DirectX... And the only OpenGL game in recent gaming history is RAGE.
November 9, 2011 4:55:34 AM

Thing is, I don't get Microstuttering in DX9 Applications but DX11 I can notice it only a little, although yes I do know that the CPU and GPU's require to communicate alot more with DX11 but still I have absolutely no MS in DX9 same applied to the OP in that thread link I posted.

I really am starting to think that I need to get rid of this 3 year old monitor.

Anywhoo, thanks peeps for replying and trying to help. I will buy a 120hz in a couple of weeks anyway to test it out. If the same problem applies I'll just RMA the monitor :p 
November 9, 2011 1:41:06 PM

No way it is a monitor issue, I would not waste your money on that

its microstuttering and unfortunatley AMD treats there multi-gpu customers as a minority

it was a problem over a year ago for me and is still a problem, pathetic...

Id return the damn cards and never use crossfire- ever again...

at least that what I plan to do bc when I spend over 500 on gpus and the performance is not excellent then there is something wrong with that equation and beyond that who wants to tinker for hours wondering if that fix will in fact work or not. For me I was fed up and made a change and I rec that you do the same...

its called opportunity cost and in the end I could be doing alot more then troubleshooting crossfire setups for the time and money.. my 2 cents
November 9, 2011 1:42:01 PM

maybe thigns will change in the 7k series but until I see verifiable smooth fps results I will be staying away from AMD dual gpu setups
November 9, 2011 3:02:42 PM

You're going to get micro-stutter with vsync. I guess you can insist on keeping it on for whatever reason, but that's not solving the problem. And you're running a whole load of third party software that's intended to interfere with your drivers... why?

To reduce micro-stutter, you need high fps. I'll repeat, LOWER YOUR SETTINGS to the point where you don't see micro-stutter. If you see it under 90 fps, lower your settings so you never drop below 90 fps. It's not a hard concept. For me with my 2x5850 at 1920x1200, I run the game on high with MSAA off. I don't get any micro-stutter. If I change to ultra textures, I only lose a few fps, but I get micro-stutter. It might be a driver issue, or it might be my cards can't handle those settings smoothly. You keeping the same settings that aren't working and trying everything but the simplest solution isn't going to solve your issue.
November 9, 2011 3:44:31 PM

^ yeah but the annoying thing is that you are playing BF3 with the same exact settings, if not worse then my single oc'ed 560ti with dual 5850s, now thats just not right imo....

obviously the 5850s have more raw power but after your lower the settings to get fps over 100, then you are not utilizing much of your hardware imo... also you could practically be playing the game with the same settings smoothly (with no microstutter) with a single oc'ed 5850 for that matter

in the end your right but when I had my 6870s I felt like the OP does, if you have such a setup why would you not want to run AA and vsync +tb.... its the early 2000s anymore afterall...

for me and anyone else, the midrange cfx solution makes absolutely no sense given the current driver support and what it has been for the past 1.5 yrs. horribly not worth the money imo

...If I were the OP Id sell and move on to a more reliable solution if it is deemed to be not to your liking in the end, your call, but to me its an obvious one
November 9, 2011 7:34:21 PM

jjb8675309 said:
^ yeah but the annoying thing is that you are playing BF3 with the same exact settings, if not worse then my single oc'ed 560ti with dual 5850s, now thats just not right imo....

obviously the 5850s have more raw power but after your lower the settings to get fps over 100, then you are not utilizing much of your hardware imo... also you could practically be playing the game with the same settings smoothly (with no microstutter) with a single oc'ed 5850 for that matter

in the end your right but when I had my 6870s I felt like the OP does, if you have such a setup why would you not want to run AA and vsync +tb.... its the early 2000s anymore afterall...

for me and anyone else, the midrange cfx solution makes absolutely no sense given the current driver support and what it has been for the past 1.5 yrs. horribly not worth the money imo

...If I were the OP Id sell and move on to a more reliable solution if it is deemed to be not to your liking in the end, your call, but to me its an obvious one


Why would I want any online first person shooter to ever drop below 60fps, single card or not?
November 9, 2011 7:40:20 PM

I have two 6870 1GB and I was getting 60FPS in 1920x1080 in ultra settings no motion blur and AA or w/e it is called turned to 8 instead of 16.... all the sudden since yesterday I have been getting 30-45fps and it gets choppy is this some kind of update to BF3 that messed up the drivers that used to work perfectly fine? 11.10 drivers by the way.
November 9, 2011 7:41:07 PM

^my point exactly, that is crap and I feel sorry for you
November 9, 2011 8:02:37 PM

The thing is I have been using them fine for the 5 days before it started... makes no sense world of warcraft is the same I get 40fps in the game I dont get it GPU1 has 60-70% usage and GPU2 has 100% usage from what MSI afterburner tells me
November 9, 2011 8:07:38 PM

If it was a monitor issue your likely to see ghosting, dont believe you would see any stuttering.
November 9, 2011 8:34:19 PM

Yup, I paid £530 for the same settings as one card? I don't see this issue that bad in other games, only BF3. As the OP stated in that other thread I posted he had to use a frame limiter to eliminate the stutter completely, I'm using it to REDUCE stuttering, trust me I used it as a last resort maybe it is a driver issue or cat issue I don't know but in other games, specially DX9 Games I see none.

Now I can show you an example of what I see when I don't use vsync:

http://www.youtube.com/watch?v=EHzzmskIDBw

Example what I see with vsync:

http://www.youtube.com/watch?v=LNEP03QA54E&feature=rela...

(I have it a little bit worse). That guy was on a single gpu setup. So maybe it's driver related and yes I have tried an overclock.

I see no ghosting but as the OP stated in that thread I posted he resolved it by using a 3rd party app thus it has to be a monitor issue?

Btw I had NO stuttering in DX11 in BFBC2 or Far Cry 2 (Which is well known for MS).
Anonymous
November 9, 2011 8:35:57 PM

I'll take a card off your hands for you! ;>
November 9, 2011 8:43:09 PM

One question, I've had these cards over a year. If they tested the cards in another setup would it still show the MS? If so I will RMA them tomorrow.

I have a 2 year warranty on them so it should be fine.
November 9, 2011 8:48:00 PM

I think you guys are blaming "OMG AMD HAS CRAPPY DRIVERS" instead of doing proper troubleshooting. If it's more than one game, and you didn't update your drivers, obviously the drivers aren't the issue.
November 9, 2011 8:50:19 PM

So RMA?
November 9, 2011 8:50:41 PM

i5 2500k stock (Waiting on cooler)
MSI Z68A-GD80 (G3)
8GB Corsair Blue memory
XFX 6870 1GB two in crossfire
SeaSonic 1000W 80+ Platinum
1TB WD Caviar Black 64MB cache
Corsair 500R

I get about 8 FPS less using a single card I have tried both to see if they did not work correctly... I even reinstalled windows 7... how do I go from 60fps to 40fps next day without making and changes to drivers at all.

45FPS in BF3 ultra (used to get 60 all the time)
40FPS in wow (Used to get 60)
and Dead Space 2 I have no issues because I have vsync disabled since it only caps at 30 in that game. I have no other games to test currently. How else can I troubleshoot to see what the problem is with this?
November 9, 2011 9:16:13 PM

flips said:
i5 2500k stock (Waiting on cooler)
MSI Z68A-GD80 (G3)
8GB Corsair Blue memory
XFX 6870 1GB two in crossfire
SeaSonic 1000W 80+ Platinum
1TB WD Caviar Black 64MB cache
Corsair 500R

I get about 8 FPS less using a single card I have tried both to see if they did not work correctly... I even reinstalled windows 7... how do I go from 60fps to 40fps next day without making and changes to drivers at all.

45FPS in BF3 ultra (used to get 60 all the time)
40FPS in wow (Used to get 60)
and Dead Space 2 I have no issues because I have vsync disabled since it only caps at 30 in that game. I have no other games to test currently. How else can I troubleshoot to see what the problem is with this?


Go into catalyst and change everything back to default. Make sure you don't have overdrive turned on, as it's possible to underclock your cards. Make sure crossfire is turned on. Also verify you have the latest drivers and crossfire profiles.

Get cpu and gpu monitoring software. We're going to be looking at temperatures and usage. I use core temp (there's a windows 7 gadget that has better output) and msi afterburner, respectively. Also get a fps monitor. Fraps works well. Start all three of those programs.

Play BF3 for a while. Anytime you notice lag, look at your fps. If it's low/dropped, it's not micro-stutter. If it's not low/didn't drop it's micro-stutter. Alt-tab out and look at your usage (if you have a second monitor, it makes this a lot easier). What are you cpu and gpu usage at? Is your gpu usage low on one or both cards? Is your gpu usage constantly pegged at 100%. What about your cpu (I doubt this is your problem, but maybe)? Now look at your temps. Are they in a safe range? Below 85C should be ok, but I would only expect your top gpu to approach that.

This is the type of troubleshooting you need to do to gather enough information to make an informed decision. I'll be happy to help you figure out what's going on at that point.
November 9, 2011 9:33:40 PM

Hi iam new to Toms Hardware.

I had my PC for slightly over a year now. Here are the specs...

AMD 630 X4 2.8 ghz
4gb DDr3 ram
500gb hard disk (of some sort)
gigabyte GA-MA770T-ES3 mboard
650w generic power supply (dont know wat brand)
Sapphire ati 5850 graphics card

Antec 900 case running on win 7 professional 32 bit (as from today, originally 64nit_


I recently bought an asus gtx 570 direct CUII card to play BF3 at decent settings. The performance was great, until i noticed that after playing for about 20 mins, the game slowly stutters/micro stutter. I dont know the proper technical term but the graphics gets a bit hickuppy even though FPS was solid (mini freezes that lasts microseconds). This problem never occured before i installed the GTX 570. Even in other games such as F1 2011, Driver san Francisco the phenomenon occurs. I tried many Nvidia drivers from the latest to the oldest but none solved issue. I sent the G card back to the seller and plugged the old one in and suprise, same issue. Today i reinstalled windows 7 (32 bit) and downloaded ati drivers and same issue occurs in battlefield 3, even with fixes. I tried using the fix for battlefield 3 (you have to go to game command menu thingi and change settings) which helped for 2 days and then problem reappeared. It seems nothing seem to fix the issue. And this happens only after playing for about 20 mins. If i close the game and start another level, the phenomenon occurs again after around 20 mins.

I know this symptom is very unusual, but i really need help guys :-(. Iam not an expert in computing so can you please try to help me out here?
November 9, 2011 9:47:14 PM

^start your own thread
November 9, 2011 10:04:17 PM

hapkido said:
Go into catalyst and change everything back to default. Make sure you don't have overdrive turned on, as it's possible to underclock your cards. Make sure crossfire is turned on. Also verify you have the latest drivers and crossfire profiles.

Get cpu and gpu monitoring software. We're going to be looking at temperatures and usage. I use core temp (there's a windows 7 gadget that has better output) and msi afterburner, respectively. Also get a fps monitor. Fraps works well. Start all three of those programs.

Play BF3 for a while. Anytime you notice lag, look at your fps. If it's low/dropped, it's not micro-stutter. If it's not low/didn't drop it's micro-stutter. Alt-tab out and look at your usage (if you have a second monitor, it makes this a lot easier). What are you cpu and gpu usage at? Is your gpu usage low on one or both cards? Is your gpu usage constantly pegged at 100%. What about your cpu (I doubt this is your problem, but maybe)? Now look at your temps. Are they in a safe range? Below 85C should be ok, but I would only expect your top gpu to approach that.

This is the type of troubleshooting you need to do to gather enough information to make an informed decision. I'll be happy to help you figure out what's going on at that point.


I was getting 45-60 fps and dips to 30 or so on both FPS from MSI and Fraps then my computer froze up and had to reset so I could not collect temps but I can tell you that GPU 2 gets hotter than GPU 1 which used to be the other way around. Now in catalyst if I go to overdrive to see if its showing both GPU it shows this

GPU1
Spoiler
" alt="" class="imgLz frmImg " />
Spoiler
" alt="" class="imgLz frmImg " />
" alt="" class="imgLz frmImg " />
November 9, 2011 10:31:16 PM

Please, I know I'm being an ahole but can you not hijack my thread please?
November 9, 2011 10:45:34 PM

Just thought it would help us both out since we are having similar issue.
      • 1 / 2
      • 2
      • Newest
!