Sign in with
Sign up | Sign in
Your question

[Driver] Battlefield 3 won't work

Last response: in Graphics & Displays
Share
November 8, 2011 4:45:30 PM

So today I updated my graphics driver to version 11.10 (http://sites.amd.com/us/game/downloads/Pages/radeon_win...), and while everything seemed to work, I tried to play the game Battlefield 3. First time I tried to do it, the screen would flash, freeze and display messages telling me the driver stopped responding and has recovered, only for the same to happen again and again until i rebooted. I've uninstalled and reinstalled all the drivers, and now the screen will just appear to freeze, but respond to pressing the windows button on the keyboard, which at least gives me the option to shut down the game.

Is there anything I can do to get the game working again, other than downgrade to an older driver version?
November 8, 2011 4:46:33 PM

Forgot to mention, my graphics card is a Radeon HD 6870, which is slightly overclocked.
m
0
l
November 8, 2011 4:59:39 PM

What are the rest of your specs and resolution playing at?
m
0
l
Related resources
November 9, 2011 11:58:45 AM

I have exactly the same problem!

My specs are:

i7 930 |stock|
ATI HD6870 |stock|
12gb Corsair Dominator
PS Corsair 550W
MSI PRO-E MB

Windows 7 64bit
playing Battlefield 3 @1920x1080px

everything worked normally until it crashed. After crash, i repeatedly receive message that drivers stopped responding, and the game freezes.

Any advice?
m
0
l
November 9, 2011 4:14:20 PM

I've read on the EA forums that downclocking your cards to factory/reference settings have helped some people. You could try that. BF3 wouldn't work with my system using w7 32bit but there was a temp "fix" by adjusting the VRAM in windows to 2.5gbs. But I ended up getting 64-bit & 8gbs of RAM and the game hasn't crashed since.
m
0
l
November 11, 2011 4:41:22 PM

I have had I guess something of the same problem. When I start the game the screen flashes a few times, then I get a black screen, not centered or full screen size, and actually looks like a normal windows screen just over sized, or like when you are playing a game and yahoo flashes a message disrupting your screen, but not able to put it back. Only once was I able to get into the game options, after ctrl+alt+del, now after I rebooted again even this will not give me anything...just a black screen. The task manager shows it is running, and I can see it when the task manager is open, but when I close it I go back to no sound or display.

System:
Dell Inspiron N4110
Processor: i5 - 2430M CPU 2.40GHz
Graphics: AMD Radeon HD 6630MD
Mobile Intel R HD Graphics
OS: Windows 7 32 bit
RAM: 4 GB

m
0
l
!