Sign in with
Sign up | Sign in
Your question

ATI 5970 black screen then restard

Last response: in Graphics & Displays
Share
November 9, 2011 4:12:30 AM

Hello,

I recently put togethor a new system and i am having some troubles with it. Not sure if this is the right place to post so im sorry if it isn't. These are my system specs:


AMD Phenom II X4 840 3.2ghz CPU
8GB G-Skill Sniper 1333 RAM
Gigabyte ATI HD 5970 2GB Video Card
AsRock Fatal1ty 990FX Professional Motherboard
Corsair 650w PSU
Western Digital 1TB HDD
Windows 7 Ultimate 64bit OS

So, pretty much what happens is the screen will randomly go into power saving mode and then the computer will either restart or just do nothing. I have to do a hard reboot sometimes otherwise it will just do nothing. Even after the restart it will only work for like 5-10 mins then black screen again.

The manual for the graphics card says it requires a minimum 650w PSU which is what i have. Nothing has been overclocked so i'm under the impression that this should be enough to power it?

I've put in a 6850 from another computer at the moment to see how that goes, cause i'm thinking it could be that the PSU isn't powerful enough.

Anyone have any other ideas as to what it could be? Thanks in advance!
a c 90 U Graphics card
November 9, 2011 4:32:02 AM

tweaktown made a reviews of it and use a 850 watts psu maybe your psu is not able to drive it the card use 399 watts on load in single
m
0
l
November 16, 2011 9:26:22 AM

scout_03 said:
tweaktown made a reviews of it and use a 850 watts psu maybe your psu is not able to drive it the card use 399 watts on load in single


Thanks for the reply, i guess i'll just have to upgrade my psu
m
0
l
Related resources
March 27, 2012 8:57:36 PM

HI, did the new PSU help?, because my friend has the same problem
m
0
l
March 28, 2012 12:44:46 AM

Delete the current drivers and try to use Catalyst 12.1 and see if the problems still persist.
m
0
l
!