Sign in with
Sign up | Sign in
Your question
Closed

First build failure? -- ASRock microcode error

Last response: in Systems
Share
January 7, 2012 9:45:12 AM

Hello, I've been putting together a new build for the last few hours. I got everything up and running eventually. However, I was unable to access the BIOS after installing my Windows 7 OS. Initially I used it to set CD Rom priority above my 128GB Crucial M4 SSD in order to load windows. After loading, whenever I tried to access the BIOS via the delete key, it would just keep restarting over and over, almost like an infinite loop until I managed to miss the delete key where it would load up windows.

I needed to access the BIOS in order to get it to recognize my backup 1TB HDD which I plugged in after windows was installed.

So, I read that hitting the clear CMOS button would reset the BIOS, which could help if it was failing. I hit clear CMOS, the computer restarted, and then I got a 0E error on my Dr. Debug on the motherboard. According to the manual, this means that it could not find the microcode.

Hitting the clear CMOS again, it will give an A3 error, which means IDE Enable. If I hit f12, delete, or f2, it changes to 0E.

Specs:

i5-2500k processor
8gigs g.skull 1600 MHz RAM
128gb Crucial M4 SSD
1tb seagate barracude 7200 rpm HD (backup)
AMD Radeon 6870 GPU (1GB)
750W Antec Earthwatts PSU
Coolermaster 212+ CPU cooler
Liteon 22x Optical drive
ASROCK x68 Extreme 3 Gen 3 motherboard

EDIT: If you're reading this, the error appears to be progressing slightly. Check my most recent post for revisions/updates if you'd like. Thank you in advance for your time on helping me fix this issue.
January 7, 2012 10:04:11 AM

You have to disconnect power before clearing CMOS.
January 7, 2012 10:10:18 AM

Hmm. I didn't see that in the quick troubleshooting guide. I just turned it off, switch off PSU, unplugged, and hit the button. Then I plugged it back in, turned the PSU back on, and turned it back on. I again got the A3 error instead of 0E, which is IDE enabled. So I hit delete to access the BIOS since nothing was happening. And now it's back to 0E -- cannot find microcode.

I had this happen earlier when I was first loading it up. I hit the clear CMOS on accident -- which gave me the 0E error. So I kept resetting it, no avail. I hit it again (and unplugged it somewhere around there) and finally got it to work -- going to A3 and then hitting delete to access the BIOS. This was before I had installed windows.

The second time I hit the clear CMOS was because I was legitimately having trouble accessing my BIOS. This was after I had installed drivers and windows updates and antivirus.
Related resources
January 7, 2012 10:19:14 AM

I believe it's possible to damage the BIOS ROM if you have the power connected when pressing clear CMOS. Especially if the PC is running.
January 7, 2012 10:20:15 AM

Well, after re-clearing the CMOS after the 0E error, leading to the A3 error, I am able to access the BIOS via the F1 key. This is only temporary and freezes after a few seconds, before I can do anything in it. Then the motherboard gives me the error 0d, which according to the manual that code is "reserved for future AMI SEC error codes."

Sigh. I regret pressing that stupid CMOS button..
January 7, 2012 10:26:16 AM

FinneousPJ said:
I believe it's possible to damage the BIOS ROM if you have the power connected when pressing clear CMOS. Especially if the PC is running.



Well, I did press it earlier though and had problems but eventually was able to get to the BIOS. I thought at the time the problem was I pressed it mid windows installation (accident -- keyboard/mouse weren't working, thus I was unable to select language to install windows in and my buddy pointed out that it had gone from lit to unlit, so I hit it. Turns out, it was because I had plugged it into a USB 3.0 slot and drivers hadn't been installed yet), so due to that my SSD had tiny fragments of it installed and that had priority for boot. So when I finally got to the BIOS via more CMOS resets followed by the A3 error followed by the delete key, I changed it to put the optical drive first which let me load windows. The problem appeared to be solved.

I only encountered future problems when trying to access the BIOS later, via a BIOS reset loop (where my computer restarts before I have time to do anything in the BIOS).

Also, I think most CMOS resets are via battery resets or turning some switch on the motherboard.

It should be noted that my CMOS reset -- at least, the one I've been using, is a button on the back of the computer next to all of the motherboard plug ins. The button usually glows red. The first time I hit it I had no idea what it did and thought it was just another "reset button."
January 7, 2012 10:26:42 AM

Sounds like it may indeed be damaged. I don't know if there's any way to save it. Maybe you could try downloading a BIOS update on another PC. Or try to return the mobo (now wait for the moralists to tell you it's wrong).
January 7, 2012 10:28:16 AM

If your SSD has a corrupted installation it might help to disconnect it. Have you tried doing that?
January 7, 2012 10:33:33 AM

First I just tried replicating my previous fix by putting in the Win 7 disc. When that failed I tried unplugging the SSD and plugging in the TB with the Win 7 disc to see if it would prompt a new install... and I'm still getting a combination of A3 and 0E errors: IDE enabled and microcode not found, respectively.

EDIT: Also, I was under the impression that all on my SSD had been fixed. When I had problems the first time, it hadn't actually "installed" windows yet. It was at the prompt for language selection and I hadn't formatted or anything yet.

If I have to send it back, would I need to do anything related to my SSD? Like, it has drivers and probably BIOS related stuff on that.

And how would I go about installing a BIOS update to another computer? I mean, I can't really access this new computer at all... if I installed the updates on another computer, how would I get them into the new one?

It just seems hard to believe that one little button on the back of my computer can cause complete system failure if it's pressed... I don't know...

I appreciate all your help. Looking into RMAing it right now..

EDIT 2: I'm guessing I won't even be able to RMA it, as it will probably be considered my fault.
January 7, 2012 11:39:23 AM

Well, I made progress... Hitting F11 I was able to successfully prompt a drive to boot up in (which F12 failed to do). Hitting esc from that menu tookme to the BIOS. From there I was able to configure settings putting my SSD first priority (default put the blank TB there apparently). Currently I am in the Win 7 computer repair thing. It's checking my system for problems "attempting repairs." I am sincerely hoping that if this doesn't work, starting windows normally will (which was my other option)... I was able to fix my BIOS problems using the F11 method and my TB is set up. Ugh, this has been a frustrating night (almost 9 hours I've been at this damn thing).

EDIT: Now it seems as though I am unable to leave the BIOS menu. Everytime I exit, BIOS relaunches. Restart, BIOS relaunches. The BIOS seems to be working wonderfully -- as it should have been before I had any problems. However, after leaving and discarding changes about 4 or so times, I get the option to launch windows repair wizard or "start windows normally." Starting it normally = BIOS menu, repair wizard = searching for a few minutes to find nothing and a prompt into system restore. Because I am using an SSD, I have no restore points so I exited out of that.

EDIT 2: Well, this persisted so finally I changed the boot order to optical > SSD. I just loaded off a disc and windows is restarting... Maybe I'll try a fresh install... I figure it can't possibly get worse than it already is.

EDIT 3: Fresh install in progress... I don't know if this will do anything but I'm praying it will. Having to pay to RMA this thing back to newegg would just about kill me. I'm wishing right now that I had purchased the MOBO from amazon. Even if it was 20 dollars more, their customer service and return policies rock and I wouldn't have a reshelving fee + shipping fees + new motherboard fee (if RMA fails).

NOTE: With the installation in progress, this is the first time my Dr. Debug on the mobo isn't screaming various error messages at me.

Best solution

January 7, 2012 12:09:22 PM
Share

Let's hope it works. Obviously if you attempt to return it, you don't admit to messing with it. Just claim it was like that when you got it :lol: 
January 7, 2012 12:21:25 PM

Well, I just got in. It seems that everytime I restart, I go directly to the BIOS. After exiting 1-4 times, windows will finally begin.

Couple questions: If you were in my shoes, would you return in an attempt to get one that didn't have this problem? I mean, it appears that I have a temporary fix which lets me get into my computer.

Keep in mind, an RMA will take at least a couple of weeks, during that time I'll have no computer, save for this craptastic netbook I'm currently on. The biggest problem is the fact that my Windows 7 is OEM (I know, system builders only... but perhaps I was planning on selling this machine ;) ) which binds it to my motherboard.

I suppose I could monitor it for a few days and see. I still have like 28 days to RMA it if I do. I could also stop windows from activating for 30 days.

Second, because I had to delete the previously formatted windows I had on my SSD and install a new one, could there be any sort of corruption or problems with my SSD? I don't know too terribly much about them, and just want to make sure everything is superb. This computer I'm building is supposed to be one of longevity.

Note: Last 4 restarts have been only 1 exit from the BIOS.
January 7, 2012 12:34:07 PM

Best answer selected by mathgod.
January 7, 2012 12:36:15 PM

Yes, if it appears it cannot be fixed I would attempt to return it. It's not like you have anything to lose.
!