Sign in with
Sign up | Sign in
Your question

Fail.. maybe even Epic Fail...

Last response: in Components
Share
April 20, 2012 8:05:37 AM



white 20pin - Raidmax case PCU 430W
Black 20pin - Rosewill 630W

Can you see whats wrong? :pt1cable: 

So just got this new PSU and well everything else new for this build.. was excited to have it for the weekend.. whats this my PSU is missing a cable!?!?!?!?! *face palm" but wait its not missing... its in the slot next to it! theres 2 in one slot!!! wtf guys.. lol

so as im pulling my hair out trying to figure out why my comp wont post or even turn on (it would blink the LEDs) I grab my little 430 out of the closet (and it has all of 1 sata power but atleast it had a 24v plug) hooked up just the board/ram/fans/case leds and BAM posts.. x_x seriously my pos PCU posted and has lasted years but this brand new psu is missing a freaking cable all together!? I dont think i can move it to its right slot since its missing the medal male plug.... well off to bed now that the stress of that is over haha


Rosewill Green Series RG630-S12 630W
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

More about : fail epic fail

a c 139 ) Power supply
April 20, 2012 11:00:23 AM

That's completely normal for a PSU with no -5V output.
a c 139 ) Power supply
April 20, 2012 11:04:04 AM

Notice the -5V white wire on the Raidmax motherboard connector?
That's the one missing on the Rosewill.

What motherboard are you powering?
Related resources
a b ) Power supply
April 20, 2012 11:20:01 AM

+ 1 irony points for the fail statement (given that you've failed)
April 20, 2012 4:16:53 PM

then why wont this PSU work hmph

its an ASRock pro3 Z68 gen3
a c 139 ) Power supply
April 20, 2012 4:43:48 PM

ASRock Pro3 Z68 Gen3 is a very modern motherboard which doesn't make use of -5V power. In the past -5 rail was provided for peripherals on the old school ISA bus.

So Rosewill Green 630 would be a good match and it's a well though of PSU.
Rosewill Green Series 630 W (RG630-S12) Power Supply Review

It could be the UPS Gorilla booted the PSU during delivery and it showed up DOA.


April 21, 2012 1:08:59 AM

had the PCU tested, its DOA, oh wells sent it back for a new one. Thanks yall! guess i faced palmed myself
!