Sign in with
Sign up | Sign in
Your question
Solved

ASUS MS228-H and ATI HIS 5750

Tags:
  • Graphics Cards
  • LED Monitor
  • Graphics
  • Displays
Last response: in Graphics & Displays
Share
November 11, 2011 5:10:12 AM

need help......having a serious problem.....my LED is giving me some problems.....1st problem is that the display gets randomly turn off and on since last 2 months.......2nd problem is that i am having serious green dots appearing on display since last 1 month...both of these problems randomly occur and randomly diappear........
I am using HDMI connection....
Now i want to know that it is my LED problem or my GPU problem....plzz help and pardon me for my poor English....


PC specs:
processor: i5-2400
mobo: MSI P67A-C43
gpu: ATI HIS 5750 iceq
Display: ASUS MS228-H
Ram: 4gig

More about : asus ms228 ati 5750

a b U Graphics card
November 11, 2011 6:30:07 AM

A single . is enough, you know!

What is your PSU? It could be a problematic GPU. If you are in warranty get an RMA, but do check out other possibilities as well before RMA.
m
0
l
November 11, 2011 7:28:57 AM

hell_storm2004 said:
A single . is enough, you know!

What is your PSU? It could be a problematic GPU. If you are in warranty get an RMA, but do check out other possibilities as well before RMA.



PSU is cooler master 550W.... GPU is not in warranty....it is 1.6 years old...:D ....everything else is new.......
there is also another problem.....sometimes when i start my PC and gets to desktop a freaking sound comes from the casing for sometime.....after 2 or 3 mins the sound disappears.....may be its gpu fans sound....sound seems like krkrkrkrkrkr.........

oh man dont tell me to get a new GPU...:( 
it is still giving awesome fps in battlefield 3...30-40 fps..
i luv my old buddy...:p 


m
0
l
a b U Graphics card
November 11, 2011 9:04:17 AM

Your PSU is frankly pretty poor. But still should be enough for a 5750. I am guessing your bad PSU damaged your GPU. 1.6 years ain't that much. Most GPU's have 3 years warranty or more.
m
0
l
November 11, 2011 12:20:55 PM

hell_storm2004 said:
Your PSU is frankly pretty poor. But still should be enough for a 5750. I am guessing your bad PSU damaged your GPU. 1.6 years ain't that much. Most GPU's have 3 years warranty or more.

there is another thing....i ran GPU at full overclocking....in pak we get hardly 1 year warranty.....
m
0
l

Best solution

a b U Graphics card
November 11, 2011 12:24:27 PM

Oh boy... That warranty thing is pretty sad to hear! Anyways, artifacts (the green dots that you are talking about) are pretty much a sign of faulty GPU. It is happening intermittently now. I am guessing it would go up pretty soon.

If you are not on the latest drivers, then do that, at least make sure its not a driver issue.
Share
November 11, 2011 12:26:46 PM

one more thing...when the issue occurs....i remove the HDMI cable from LED and then plugg in the issue is solved
m
0
l
November 14, 2011 2:51:54 PM

Best answer selected by junaid_14014.
m
0
l
!