Sign in with
Sign up | Sign in
Your question

TV & Monitor switching, resolution issue

Last response: in Graphics & Displays
Share
November 11, 2011 1:46:40 PM

Hi guys. I have a monitor (1900x1200) and TV (1900x1080) hooked up to my Windows 7 PC via hdmi cables. Is there a way to switch my main display over to my TV so I can play games/watch videos on my TV instead of my monitor? Currently I have it set to to extend by default, then when I turn on my TV I press Windows + P to switch over my TV as my main display (then switch back to extended when I'm done).

However when I do this, it seems to still try to display 1900x1200 on the TV and as a result it is missing some lines from the top and bottom of the screens (e.g. the taskbar is halved in height and if i full screen youtube the playback bar is missing). Is there a way to fix this resolution issue, or a is there better way to switch displays (eg. third party app)? Could it be related to upscaling? I have a radeon 5870 running the latest drivers, if that helps. I don't need to have both screens working at the same time as they are quite far apart so its not really possible to use both at the same time. Thanks!
a b C Monitor
November 11, 2011 2:13:51 PM

Hello... what happens when you run in "clone" mode?... a monitor is a passive device, thus Windows doen't care if my TV or Monitor is off or on... But i'm running the same resolution on both... and dont have to ever switch any thing... the resolutions are preset in my Windows device settings and Nvidia control panels for the monitors and Video output settings to 1080p.

You might have to run Windows at the resolution of 1080P, the maximum setting of your TV set... for simple ON/OFF operation as you want.
Related resources
November 11, 2011 2:50:14 PM

The problem with having clone mode / same resolution is that I get black borders on my monitor then :( 

blade, the windows key + p shortcut seems to control this. It works but my TV doesnt scale properly. However I found you can adjust the overscan in the CCC control panel, which seems to fix my problem.

Now I've got another problem where I get glitches when I scroll. It looks like its related to having AMD Overdrive enabled.
November 11, 2011 2:52:53 PM

What sorts of glitches?

What is the input mode of your TV? Do you have a PC mode you could select?
November 11, 2011 2:59:19 PM

When i scroll a window or do a selection, there's some weird corruption displayed for a very short time. It's sort of like screen tear but its a fat black line. It's fine if I am playing a game and if I turn off AMD Overdrive it works perfectly, I believe its related to the memory clocks and some sort of power saving mode - I dont know too much about it yet, saw an article on it here: http://forums.amd.com/game/messageview.cfm?catid=260&th...
November 11, 2011 3:06:56 PM

Right. Ok. I had a 5870 for a while (it ended up dying on me) but you have to edit your CCC profile so that the want_0 (idle) and want_1 (2D) clock speeds are higher.

The easiest way to do it is to go to CCC and create a custom proflie over overdrive settings.

Once you have the profile, save it, and go back to default. You can only edit it when it is not in use.

Now go to C:\Users\*your user name*\AppData\Local\ATI\ACE\Profiles

Open the XML file with a text editor and change the Want_0 and Want_1 values for CoreClockTarget_0, MemoryClockTarget_0, and CoreVoltageTarget_0.

You can set them to the same values as Want_2 and your card won't go to power saving mode
November 11, 2011 3:55:23 PM

Cheers, thanks for that. I noticed it only happens when its in extended mode - since I only will be having one of the monitor or tv enabled at any one time this isn't really an issue but ill look into that profile stuff anyway.

Just in case anybody else has the same problem, there's also a better alternative to using Win + P. Basically using Windows + P will need your primary monitor on so you can see the popup and tab through it. Instead, you can select each desktop on its own via windows display dialog and create a preset for each one in CCC and assign it a hotkey. Now I just have to press Ctrl+Shift+1 to output to my monitor and Ctrl+Shift+2 for my TV.

I have another problem now where if I use the HDMI/DVI port on my Samsung TV the image is sharp and there's no need to configure overscan even, but there are "dancing" red pixels on screen (I am using a HDMI->HDMI cable). If I use a port labelled as just HDMI, there's no red pixels but the image is overly sharp and text isn't as clear (also need to configure the overscan to get it to display within the bounds of the TV screen). Arrgh! Thought this would be easy...
November 11, 2011 4:10:22 PM

Use the configuration that doesn't give you red pixels.

Then go to the start menu and type "calibrate" and click calibrate display color.

This will walk you through a setup for your display.
November 11, 2011 5:42:41 PM

I changed the source of my TV to 'PC', enabled Screen Fit instead of 16:9 and reduced the sharpness levels (I think hooking it up the DVI port enables these changes automatically). All working fine now, with clear text and no artifacts, thanks for all the help!

One last thing - is there a way i can increase the font size on my TV and not my monitor? Even though the text is fairly sharp close up, when Im sitting far back its quite small. From having a quick look around it looks like I have to change it manually each time I change monitors?
November 11, 2011 6:00:36 PM

I believe that is the case. Unfortunately as it is a windows setting, not a display setting.

If it is possible I don't know how to do it.

Glad to help with what I did.

If you have what you need, please close the thread by selecting a best answer.

Thanks!
November 11, 2011 7:11:37 PM

hmm, how do i do that?
November 11, 2011 7:18:22 PM

In the bottom corner of ever response should be a link that says:

"Select as best answer"
November 11, 2011 7:20:16 PM

I dont have that, might be because im a noob member :( 
November 11, 2011 7:25:10 PM

Ah, ok I see. this is a discussion thread, not a question thread.

Nevermind!
!